Welcome to the North American Subaru Impreza Owners Club Monday December 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-20-2007, 11:21 AM   #1
da-chaz
Scooby Newbie
 
Member#: 127256
Join Date: Sep 2006
Chapter/Region: E. Canada
Location: Toronto (GTA), Ontario, Canada
Vehicle:
2006 Impreza 2.5i
SGM

Question SRS Airbag Light stays on during prolonged cold starts.

Hi All. This has been the second time that it has happened to my fully-stock 2.5i 4EAT MY06, 13.5k KMs.

On a cold start, say about 8 hours or more during -4C and colder, the SRS Airbag light comes on during ignition but stays on for the remainder of the drive (upto 1 hour). The quick fix, is to shut the car off about 2-3 minutes later after it's warmed up a bit and to restart it -- at which point the sensor does not light up and we're good to go.

Albeit hardly critical or crucial but this issue seems to be reoccuring now that the temperatures are dropping. Has anyone else had to deal with anything like this?
* Registered users of the site do not see these ads.
da-chaz is offline   Reply With Quote
Old 01-22-2007, 09:37 AM   #2
da-chaz
Scooby Newbie
 
Member#: 127256
Join Date: Sep 2006
Chapter/Region: E. Canada
Location: Toronto (GTA), Ontario, Canada
Vehicle:
2006 Impreza 2.5i
SGM

Default

Sorry for the "bump" but it happened again. I'm guessing it's time to call up the dealership and bring it back to be fixed under warrenty.

Update: So I called up the dealership and booked an appointment for tommorow. Apparently this is a "known" issue that is exclusive to 06 2.5i Imprezas. Subaru of America has yet to formally respond but the dealership wants me to come in for an inspection anyways.

Last edited by da-chaz; 01-23-2007 at 10:01 PM. Reason: Updated
da-chaz is offline   Reply With Quote
Old 01-30-2008, 11:09 PM   #3
joosrsx
Scooby Newbie
 
Member#: 81428
Join Date: Feb 2005
Location: Minot ND
Vehicle:
2007 WRX Limited
Silver

Default

I have the same prob on my 07 WRX. Did the dealership fix the prob?
joosrsx is offline   Reply With Quote
Old 01-31-2008, 07:49 AM   #4
da-chaz
Scooby Newbie
 
Member#: 127256
Join Date: Sep 2006
Chapter/Region: E. Canada
Location: Toronto (GTA), Ontario, Canada
Vehicle:
2006 Impreza 2.5i
SGM

Default

It seems that whatever they did has fixed the problem. I was told informally it was due to pinched wiring, that only affected the passenger-side airbag. Usually "restarting" will correct the issue.

Now I'm just having trouble turning over when trying to do a cold start in temperatures lower than -10C.
da-chaz is offline   Reply With Quote
Old 01-31-2008, 02:08 PM   #5
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

There is a TSB that relates to what you both are describing on the 06-07 Impreza. The dealer will have to check it out and see what code it is setting.
munkis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SRS light stays on.... how to check what is going on? psyber_0ptix Service & Maintenance 2 04-22-2009 04:13 PM
airbag light stays on jargon Service & Maintenance 3 09-29-2006 08:10 PM
Airbag light stays on WarHawk187 Interior & Exterior Modification 1 07-12-2005 08:40 AM
SRS Airbag light came on. How do I reset? cybin Service & Maintenance 7 12-21-2003 12:40 AM
('93-'01) Airbag light stays on after changing seats gary501 Impreza Forum 8 10-15-2001 08:48 PM


All times are GMT -4. The time now is 07:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.