Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-22-2007, 11:58 PM   #1
Blakjack
Scooby Newbie
 
Member#: 138129
Join Date: Jan 2007
Default Knock sensor - known suspect?

Newbie (to this forum) just bought a '97 Outback Legacy 2.5 for cheap, can't get through emissions with knock sensor code permanent in memory.

I was going to replace it, wiring seems ok, but I figured it was worth a shot seeing if this is a part that is known to fail (also an expensive part). Don't have a hell of alot of experience working on this motor. Hope to change that soon.

Side info : Car has sat for some time, gas may have gone a little bad but runs fine and definitely doesn't knock.

Oil's a little thin, but not more than one would expect.

Thanks for the input!
* Registered users of the site do not see these ads.
Blakjack is offline   Reply With Quote
Old 01-23-2007, 11:44 AM   #2
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

Subaru had a problem with knock sensors in that year, make sure that the sensor is grounded (remove the mounting bolt and look for corrosion) if thats ok replace the sensor.
crampfan is offline   Reply With Quote
Old 01-23-2007, 11:44 AM   #3
Blakjack
Scooby Newbie
 
Member#: 138129
Join Date: Jan 2007
Default

Thanks, it looks good, I took it off and reinstalled it, same code. The fact my local parts store has it in stock is probably a good indication.

Thanks for your time.
Blakjack is offline   Reply With Quote
Old 01-25-2007, 06:46 PM   #4
JRSC13
Scooby Newbie
 
Member#: 49479
Join Date: Nov 2003
Chapter/Region: MWSOC
Location: columbus
Vehicle:
05 05xt sti stg 2
pp

Default

really common
JRSC13 is offline   Reply With Quote
Old 01-26-2007, 09:03 PM   #5
Blakjack
Scooby Newbie
 
Member#: 138129
Join Date: Jan 2007
Default

Sweet, I'm used to nightmarish wiring issues with POS cars - sure would be nice if I could just install this new sensor and roll.

Thanks for all the help guys, letting me know this is a common problem is really the difference between me getting this car or not - VA emissions is kind of chitty.
Blakjack is offline   Reply With Quote
Old 01-28-2007, 10:40 AM   #6
North Ursalia
Miss You Mom
Oct 1940 - Feb 2008

Super Moderator
 
Member#: 809
Join Date: Jan 2000
Chapter/Region: NESIC
Location: NH, Land Of Many Trees
Vehicle:
2000 2.5 RS, '14 For
92 5MT SVX

Default

You will probably have to clear the codes after installing it, but you should be good after that. The torque spec is very low on that bolt- don't crush the sensor when you put the new one in.


Brian
North Ursalia is offline   Reply With Quote
Old 01-28-2007, 11:36 AM   #7
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Once it is installed clear the memory. The Sensor is around 95 bucks or so from the dealer.
blackfang is offline   Reply With Quote
Old 01-29-2007, 12:20 PM   #8
Blakjack
Scooby Newbie
 
Member#: 138129
Join Date: Jan 2007
Default

Thanks all, going to hammer at it today, anybody know where the damn thing is?
Blakjack is offline   Reply With Quote
Old 01-30-2007, 03:37 PM   #9
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

Quote:
Originally Posted by Blakjack View Post
Thanks, it looks good, I took it off and reinstalled it, same code. The fact my local parts store has it in stock is probably a good indication.

Thanks for your time.
/\/\ um....if you took it off and reinstalled it, I don't think it moved
sigh...it's on the left side, top, between the cyls. (left side is drivers side)
crampfan is offline   Reply With Quote
Old 01-30-2007, 04:22 PM   #10
Blakjack
Scooby Newbie
 
Member#: 138129
Join Date: Jan 2007
Default

Thanks. What I meant to say is that my emissions guy removed and reinstalled it.
Blakjack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fs: knock sensor, oil press. switch, cam position sensor, water temp sensor, ex mani jakesurfin Engine/Power/Exhaust 9 06-15-2009 01:28 PM
fs: knock sensor, oil press. switch, cam position sensor, water temp sensor jakesurfin TXIC Private Classifieds 4 06-15-2009 01:28 PM
2nd Knock Sensor Location, 2nd Knock Sensor Locatoin! SentinelSison UTEC 3 05-24-2006 10:06 PM
Jorge's Daily hash: Knock sensor, false knock, filters and electronics... RiftsWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 20 09-10-2003 10:49 AM
knock link or msd knock sensor? wrxtcy Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 0 07-22-2002 07:21 PM


All times are GMT -4. The time now is 12:07 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.