Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-25-2007, 12:46 AM   #1
HighRevimpreza
Scooby Specialist
 
Member#: 90235
Join Date: Jun 2005
Chapter/Region: SCIC
Location: Valencia
Vehicle:
1993 GC ej255 swap
White

Default Car wont start

I was driving home then i parked my car for 10 mins out side then went back boom it wont start any more =(.It cant be my battery but i can check that tomorrow but I'm guessing its my starter cause it doesn't click any more> Any one got any suggestions?
* Registered users of the site do not see these ads.
HighRevimpreza is offline   Reply With Quote
Old 01-26-2007, 08:59 PM   #2
beaviscih
Scooby Specialist
 
Member#: 123362
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Dorothy's House
Vehicle:
'93 Crapcan, '98L
Sold, '04 STi - Sold

Default Car Won't Start

Does it turn over at all? My '02 did the same thing about 6 months ago... it turned out to be the OEM fuel pump.
beaviscih is offline   Reply With Quote
Old 01-28-2007, 08:25 PM   #3
HighRevimpreza
Scooby Specialist
 
Member#: 90235
Join Date: Jun 2005
Chapter/Region: SCIC
Location: Valencia
Vehicle:
1993 GC ej255 swap
White

Default

thanks, i fixed it =) it was my starter.
HighRevimpreza is offline   Reply With Quote
Old 01-29-2007, 02:26 PM   #4
dude6033
Scooby Newbie
 
Member#: 138806
Join Date: Jan 2007
Default could be

ignition switch
dude6033 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Alarm wont stop going off, car wont start!! felixk Car Audio, Video & Security 3 08-20-2009 05:10 PM
Parking lights wont work now car wont start inevitable_101 Electrical & Lighting 0 07-21-2009 04:51 PM
car wont start in the cold gallstone Normally Aspirated Powertrain 2 01-08-2002 04:03 PM
Need help ASAP! Car wont start! Dane Normally Aspirated Powertrain 8 03-25-2001 12:04 AM
Car WOnt Start, 2 weeks old emprezadent General Forum Archive 3 02-03-2001 06:27 AM


All times are GMT -4. The time now is 08:59 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.