Welcome to the North American Subaru Impreza Owners Club Sunday August 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-26-2007, 12:02 AM   #1
alpnwhite96
Scooby Specialist
 
Member#: 115482
Join Date: May 2006
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2006 WRX Limited
Aspen White

Default 06 wrx seems f-ed after bodyshop

but it is kind of weird.

car was hit by deer to front right fender.

took car to bodyshop to fix.

car is fixed, fender looks great, he even buffed out a scuff on my rear bumper.

drive car to from bodyshop back to work (3 miles), notice white smoke from passenger side of engine bay, think its just maybe chemicals burning off?

drive car from work to home (5 miles), notice smoke is pouring out of the engine, stupidly still assume it's chemicals, but it is really ****ing awful, but no check engine lights or any performance decrease.

(next day)

drive car from home to work ( 5 miles), and if i do not have the fan on high and recirculate, smoke pours in through the vents, and by the time i get to work, i pop the hood, and see flickers of flames.

i immediately run inside and grab a pot of fresh coffee, the first liquid i could grab, and pour it on the passenger side of the engine, making sure not to douse any electronics.

call bodyshop, say we've got a problem.

towed my car back to bodyshop. we check the oil, it is barely touching the dipstick.

he lets me get under it and i notice oil filter is slightly loose, doh, my fault.

tighten oil filter by hand, done and done, and i do not notice an oil on the plastic bellypan of the car.


car is still smoking heavily, and losing oil.

my car has the spt intake + heatshield.

if you are standing at the front of the car with the hood up, the smoke is coming from the space between the left side of the engine and the plastic heatshield.

ive been too busy to take anything apart yet to check on WTF is happening, but first plan of action is to do an oil change and make sure theres not two gaskets stuck on the filter or anything?

* Registered users of the site do not see these ads.
alpnwhite96 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-26-2007, 01:05 AM   #2
Wannascooby
Scooby Specialist
 
Member#: 112992
Join Date: Apr 2006
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2006 WRX TR
Crystal Gray

Default

wow....that sucks. if I were you I'd check the car RIGHT NOW. Sounds like the cars been through more then it deserves...ouch. Good luck and keep us updated
Wannascooby is offline   Reply With Quote
Old 01-26-2007, 01:13 AM   #3
alpnwhite96
Scooby Specialist
 
Member#: 115482
Join Date: May 2006
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2006 WRX Limited
Aspen White

Default

yea im gonna check it tomorrow... just been so busy / tired w/ work lately that i just haven't driven it much.

91 camry... not as fun as the wrx.
alpnwhite96 is offline   Reply With Quote
Old 01-26-2007, 01:13 AM   #4
alpnwhite96
Scooby Specialist
 
Member#: 115482
Join Date: May 2006
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2006 WRX Limited
Aspen White

Default

it seems like a small problem w/ a huge symptom... but we'll see...
alpnwhite96 is offline   Reply With Quote
Old 01-26-2007, 01:22 AM   #5
plode
Scooby Specialist
 
Member#: 116910
Join Date: Jun 2006
Default

check turbo oil feed lines and also passenger side valve cover, any dents or anything in oil pan too.
plode is offline   Reply With Quote
Old 01-26-2007, 05:49 PM   #6
alpnwhite96
Scooby Specialist
 
Member#: 115482
Join Date: May 2006
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2006 WRX Limited
Aspen White

Default

changed the oil today at work.

there was no gasket glued to the oil pan, so the oil filter was fine.

oil was black, black as NIGHT, and it was fully synthetic only 5k miles old.

wonder whats going on here... maybe i killed my 06, maybe i didn't.

anyways, finished up the oil change at 5:15, drove it home, it is still smoking, although it is either 1) the residual oil burning off (didn't have time/stuff to clean it) or 2) the problem is still there.

either way, i'm cancelling my planned trip to baltimore until no more smoke is arising and i'm 100% sure no more oil is being "consumed"
alpnwhite96 is offline   Reply With Quote
Old 01-27-2007, 12:21 PM   #7
alpnwhite96
Scooby Specialist
 
Member#: 115482
Join Date: May 2006
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2006 WRX Limited
Aspen White

Default

Ok, it's definitely NOT the oil filter.

changed oil + new filter yesterday.

now i seen fresh oil dripping out from somewhere...

no floorjack again agh.
alpnwhite96 is offline   Reply With Quote
Old 01-27-2007, 01:33 PM   #8
Nanuk
Scooby Newbie
 
Member#: 138756
Join Date: Jan 2007
Location: North Dakota
Vehicle:
2003 WRX
Silver

Default

I hope someone at the body shop did'nt hot rod her and screw it up for you?? Caught a Ford dealer doing that to me years ago, my truck was getting worked on, they used it as a parts runner.
Nanuk is offline   Reply With Quote
Old 01-27-2007, 03:33 PM   #9
alpnwhite96
Scooby Specialist
 
Member#: 115482
Join Date: May 2006
Chapter/Region: MAIC
Location: Richmond, VA
Vehicle:
2006 WRX Limited
Aspen White

Default

i can totally see those ****ers hot roddin gmy car.

the bodyshop manager is/was cool as **** adn reasonable, so hopefully he will have my back.

06 wrx, stage 2 cobb, :wtc:.

sti turbo, ssautochrome tmic waiting to go in too.
alpnwhite96 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
07 STI Longblock into 06 WRX turbofied Subaru Conversions 5 01-02-2015 01:44 PM
FS : 06 WRX Complete Engine for sale WrxSti2000 Private Vehicle 'For Sale' Classifieds 0 06-03-2010 11:18 AM
06 WRX loses radio reception after headunit swap Guru Imakuni Car Audio, Video & Security 2 08-20-2008 07:29 PM
06 STi PROTUNED by ED @ EQtuning downsti Proven Power Bragging 2 08-22-2006 01:53 PM
Car doesnt seem to "GO" after 4k... then CEL drkwtsn Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 06-14-2005 03:08 PM


All times are GMT -4. The time now is 07:29 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.