Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-27-2007, 12:50 AM   #1
d40winker
Scooby Newbie
 
Member#: 128010
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2002 Impreza WRX
white

Default Threw P0442 code-emission leak

Hey I was driving home for work and I saw the light come on. My AP said it is P0442 and the manual calls it an "evaporative emission control system leak detected".

Im not sure what this is or what causes it. When I had my exhaust put on about three weeks ago I used the same gaskets, not sure if that could be the issue. I also thought earlier today I heard the turbo spool louder than usual which might be a leak. Any and all help is appreciated. Thanks
* Registered users of the site do not see these ads.
d40winker is offline   Reply With Quote
Old 01-27-2007, 08:07 AM   #2
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

...ya likely knocked a VAC hose off...has NOTHING to do with the exhaust system
Uncle Scotty is offline   Reply With Quote
Old 01-27-2007, 10:03 AM   #3
d40winker
Scooby Newbie
 
Member#: 128010
Join Date: Oct 2006
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2002 Impreza WRX
white

Default

Well that happened about a week ago and I zip tied it back on there. Could it be from that even though it was awhile ago?
d40winker is offline   Reply With Quote
Old 01-27-2007, 08:51 PM   #4
blackfang
Scooby Specialist
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Check your gas cap, tighten it until it clicks and clear memory. If the code comes back on, take it in.
blackfang is offline   Reply With Quote
Old 01-28-2007, 12:02 AM   #5
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by blackfang View Post
Check your gas cap, tighten it until it clicks and clear memory. If the code comes back on, take it in.
....the gas cap is NOT the issue here, unless it was left off completely
Uncle Scotty is offline   Reply With Quote
Old 01-28-2007, 11:25 AM   #6
blackfang
Scooby Specialist
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Quote:
Originally Posted by Uncle Scotty View Post
....the gas cap is NOT the issue here, unless it was left off completely
Ok you must be right then. Here are some things to check out then
http://www.obd-codes.com/trouble_cod...cted-small.php

Since you already know that if the gas cap is left loose in any way and not tightened until it clicks, it will set off the CEL with that code. You could possibly have something else bad in that system like the purge Solenoid, cut hoses or hoses with a hole in them.

Last edited by blackfang; 01-28-2007 at 11:32 AM.
blackfang is offline   Reply With Quote
Old 01-29-2007, 06:24 AM   #7
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by blackfang View Post
Ok you must be right then. Here are some things to check out then
http://www.obd-codes.com/trouble_cod...cted-small.php

Since you already know that if the gas cap is left loose in any way and not tightened until it clicks, it will set off the CEL with that code. You could possibly have something else bad in that system like the purge Solenoid, cut hoses or hoses with a hole in them.
















....yeah...I already knew that



NEXT......
Uncle Scotty is offline   Reply With Quote
Old 01-29-2007, 06:18 PM   #8
blackfang
Scooby Specialist
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Wow! Look at that, the first thing it tells you to do is check the fuel cap which is exactly what I said. I never said that was the ONLY repair that had to be made. It is a start and then you chimed in. In addition, the OP didn't state what other measures if any were done when I made my post.

If you want to be a smartass, then fine be one.
blackfang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Anyone get a P0442 evap emission control turbocolin Factory 2.0L Turbo Powertrain 6 09-27-2006 08:44 PM
Cel : P0442 Evaporative Emission Control System Leak Detected (small Leak)?? mrtrex Factory 2.0L Turbo Powertrain 4 05-09-2006 07:45 PM
P0442 code, only when cruising 48mpg Service & Maintenance 1 05-08-2005 04:46 PM
Threw P0442 DTC evL`WrX Service & Maintenance 4 04-13-2005 10:38 AM
P0442 Evaporative Emission Control System Leak Detected (small leak) Si2WRX Factory 2.0L Turbo Powertrain 1 05-01-2002 10:48 PM


All times are GMT -4. The time now is 03:18 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.