Welcome to the North American Subaru Impreza Owners Club Monday April 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-27-2007, 11:38 PM   #1
cdigerlando
Scooby Specialist
 
Member#: 6070
Join Date: Apr 2001
Chapter/Region: South East
Location: Longwood, FL
Vehicle:
9202 SVX, WRX
92 Sil/Blk, 02 Sil

Default Oil and exhaust gas spewing out of breathers

I have a 92 SVX that has oil and exhast gasses coming out of all of the breathers. Crankcase and both camcovers. I disconnected them and checked. I'm also getting oil spewing at high load and RPM. Any idea what is going on? Bad valve seals?
* Registered users of the site do not see these ads.
cdigerlando is offline   Reply With Quote
Old 01-28-2007, 08:33 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
05 GTO/11 Sonata(!)

Default

Could be a bad PCV valve, pull it and check it or just replace it. If not that there could be internal engine issues causing excessive blowby.
Mulder is offline   Reply With Quote
Old 01-28-2007, 08:51 AM   #3
cdigerlando
Scooby Specialist
 
Member#: 6070
Join Date: Apr 2001
Chapter/Region: South East
Location: Longwood, FL
Vehicle:
9202 SVX, WRX
92 Sil/Blk, 02 Sil

Default blowby

Quote:
Originally Posted by Mulder View Post
Could be a bad PCV valve, pull it and check it or just replace it. If not that there could be internal engine issues causing excessive blowby.
I'm thinking its blowby, as I vent everything to atmosphere. I am also turbocharging. Stand alone EMS, injectors. It is odd to me that both sides of the motor would start at the same time. I had one guy say it might be seals in my turbo, but the thing is pretty new.
cdigerlando is offline   Reply With Quote
Old 01-29-2007, 02:27 PM   #4
dude6033
Scooby Newbie
 
Member#: 138806
Join Date: Jan 2007
Default check

your pcv valve. shake it, if it rattles, it is probably good. Could clean it out too.
dude6033 is offline   Reply With Quote
Old 01-29-2007, 05:52 PM   #5
cdigerlando
Scooby Specialist
 
Member#: 6070
Join Date: Apr 2001
Chapter/Region: South East
Location: Longwood, FL
Vehicle:
9202 SVX, WRX
92 Sil/Blk, 02 Sil

Default

Quote:
Originally Posted by dude6033 View Post
your pcv valve. shake it, if it rattles, it is probably good. Could clean it out too.
As I said before, I do not use a PCV valve. I vent directly to atmosphere. Any other ideas. Other than this I am quite stumped. I probably need to do a bleed down test.
cdigerlando is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Burning oil and blowing blue smoke out of exhaust stikboy9 Factory 2.0L Turbo Powertrain 27 03-06-2007 02:39 PM
I threw a P0300 and a p0301 pulling out of the gas station last night... ScoobyNubieToo! AccessPort 10 08-24-2006 08:41 AM
Gas leaking out of exhaust flp_sde Factory 2.5L Turbo Powertrain 10 12-13-2005 04:15 AM
gas flowing out of my downpipe NeaD Normally Aspirated with bolt-on Forced Induction Powertrain 13 08-06-2004 11:39 PM
Dino Oil and Regular Gas k44 North West Impreza Club Forum -- NWIC 15 04-03-2004 01:09 AM


All times are GMT -4. The time now is 12:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.