Welcome to the North American Subaru Impreza Owners Club Tuesday November 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-28-2007, 05:19 PM   #1
MAJRMSA
Scooby Newbie
 
Member#: 22399
Join Date: Aug 2002
Location: Houston, TX
Vehicle:
2002 wrx
250k mile high club

Default Help diagnose grinding noise

Hey,
I have a 2002 Wrx with about 105,000 miles. All service is up to date except the belts which I am planning on doing very soon. The car makes a grinding noise like a metal to metal noise that seems to be coming from the belts or the compressor in that area. When I turn on my A/C the noise somewhat goes away and when I depress the pedal I hear the same noise. I accelerate in 1st gear and the noise becomes louder as I go higher in the rpms. It's been doing this for a month now and I am thinking it's the compressor. Any suggestions would help. The only mod on the car is an up-pipe. Thanks
* Registered users of the site do not see these ads.
MAJRMSA is offline   Reply With Quote
Old 01-29-2007, 10:54 PM   #2
MAJRMSA
Scooby Newbie
 
Member#: 22399
Join Date: Aug 2002
Location: Houston, TX
Vehicle:
2002 wrx
250k mile high club

Default

Any help is appreciated. Does anyone know the symptoms of a bad compressor?
MAJRMSA is offline   Reply With Quote
Old 01-30-2007, 07:26 PM   #3
crampfan
Scooby Specialist
 
Member#: 74321
Join Date: Nov 2004
Chapter/Region: MWSOC
Location: clarksville AR
Vehicle:
2004 wrx wag
black UTEC stg 4

Default

I would try adjusting the belts first, if the noise is still there, try removing one belt at a time and starting the engine. Try that first.
crampfan is offline   Reply With Quote
Old 02-25-2007, 08:58 PM   #4
buzzard
Scooby Newbie
 
Member#: 84904
Join Date: Apr 2005
Default

A shot pulley bearing sounds like metal on metal. You could have a bad idler pulley bearing, or a bad bearing in the compressor. Troubleshoot it by loosening the ac belt so it's just tight enough to take up the slack, but not enough to really load the pulleys. If the noise goes away, its a bearing in the compressor or the idler pulley. If it doesn't go away, tighten the a/c belt back up and try another belt.
buzzard is offline   Reply With Quote
Old 02-25-2007, 09:11 PM   #5
eb1888
Scooby Newbie
 
Member#: 115226
Join Date: May 2006
Location: michigan
Vehicle:
2005 wrx wagon

Default

Use a two foot or so piece of heater or other hose as a stethiscope to isolate the noise location.
eb1888 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I need your help diagnosing this noise/problem Six Stars Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 18 03-21-2007 10:23 AM
Help diagnosing a noise ASAP (belts??) JLow03 Legacy Forum 10 02-27-2006 09:21 PM
need some help diagnosing a noise AndrewF844 Texas Impreza Club Forum -- TXIC 13 08-11-2005 05:22 AM
help diagnose tranny noise from my sti WRXout Transmission (AT/MT) & Driveline 2 12-22-2004 01:17 PM
Need Help diagnosing suspension noise USA1 Brakes, Steering & Suspension 3 11-24-2003 03:46 PM


All times are GMT -4. The time now is 08:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.