Welcome to the North American Subaru Impreza Owners Club Friday December 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-16-2007, 03:57 AM   #1
dictoresno
Scooby Specialist
 
Member#: 139816
Join Date: Feb 2007
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2002 WRX, VF34 swap
WRB

Default just a friendly reminder about air filters and MAF sensors!

so today i got in my car, started right up and began to pull out of the parking lot. once i got to the street, the car died. i figured somehow i managed to stall it out, no problem, went to restart but it just putters and died again. so now im thinking great, something is really wrong. called my friend whos a mechanic to help push me off the street and begin the diagnosis. after 20 mins of poking and prodding, we unplugged the maf sensor thinking maybe its related to that. once unplugged, the car started right up. so we took the sensor to his house and found it was clogged with some type of tree/leaf particle and some dirt. i took my chances and a few sprays of brake cleaner (didnt have electric parts cleaner) everything appeared to be perfectly clean. back on the car it goes, and bam, starts right up good as new.

so in ending, make sure the most simple of maintenance such as air filters, are taken care of!! luckily this was not a huge problem.
* Registered users of the site do not see these ads.
dictoresno is offline   Reply With Quote
Old 05-16-2007, 03:54 PM   #2
Samurai Jack
Scooby Specialist
 
Member#: 21145
Join Date: Jul 2002
Chapter/Region: NESIC
Location: Not in my own time
Vehicle:
2002 Enemy of Aku

Default

Did you change your air filter?
Samurai Jack is offline   Reply With Quote
Old 05-18-2007, 06:08 AM   #3
dictoresno
Scooby Specialist
 
Member#: 139816
Join Date: Feb 2007
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2002 WRX, VF34 swap
WRB

Default

lol not yet, waiting for a day off to head to the store.
dictoresno is offline   Reply With Quote
Old 05-18-2007, 01:10 PM   #4
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Did you have a filter in the box? I mean if you got leaves and dirt in there....
Aaron'z 2.5RS is offline   Reply With Quote
Old 05-20-2007, 08:30 PM   #5
WRXDriftR
Scooby Guru
 
Member#: 65065
Join Date: Jun 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
04 WRX/ STi Hybrid
6MT, VF43

Default

just order an air filter online with a whole bunch of other maintenence parts like oil filters and a fuel filter or two. you wont have to run out and youll save on parts over dealership prices if you get alot. Shipping wont even be that bad with a large purchase.
I know www.subaruparts.com has pretty awesome prices for the OEM subaru maint. parts and with shipping its still a good 20-30% cheaper than the dealership and even competing online sites.
WRXDriftR is offline   Reply With Quote
Old 05-20-2007, 10:06 PM   #6
nast
Scooby Newbie
 
Member#: 124325
Join Date: Aug 2006
Location: Vancouver, BC
Vehicle:
98 Forester S
White

Default

why is it a bad idea to clean the MAF with brake cleaner again?
nast is offline   Reply With Quote
Old 05-20-2007, 10:22 PM   #7
BrigadoonB
Scooby Specialist
 
Member#: 100524
Join Date: Nov 2005
Chapter/Region: RMIC
Location: Denver
Vehicle:
2012 WRX
SWP

Default

where was your MAF sensor
BrigadoonB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
99 RS Parts: Full Dash, Full Exhaust, ECU, SRS, Air Bag, And MAF Sensor. scubydrew414 1993 - 2001 Impreza Specific Parts 41 03-17-2010 02:51 AM
FS: Blitz stainless steel air filter and MAF housing. 04stiguy89 NWIC Private Classifieds 12 08-09-2009 10:47 PM
Help! Change Oil, Cleaned Air Filter, and MAF now car acting weird Soulofdarkness Engine Management & Tuning 13 05-22-2009 11:05 PM
Questions About Air Filter and Maf Sensor Location Kevin Thomas Normally Aspirated Powertrain 1 09-24-2005 05:28 PM
K&N air filter and oil - does it mess up the MAF? root Service & Maintenance 6 06-17-2004 03:37 PM


All times are GMT -4. The time now is 08:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.