Welcome to the North American Subaru Impreza Owners Club Thursday August 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-05-2007, 12:07 PM   #1
MKXIII
Scooby Specialist
 
Member#: 130388
Join Date: Oct 2006
Chapter/Region: MWSOC
Vehicle:
2007 WRX STI Limited
Urban Steel Gray Metallic

Default Stuck Clutch Pedal

this weekend i was driving to a friends house for the superbowl when the clutch pedal got stuck about halfway down....it wasn't so stuck that it wouldn't move...it was just stuck down half way that i had to stick my foot under it and pull it up...then i cycled it by pushing down leting go and so on...what should i do or check about this stuck clutch pedal problem?...by the way i have a 2007 limited sti.....and it has happened once or twice before....also i dont think it had anything to do with it but it was 2 degrees out side....help please
MK
* Registered users of the site do not see these ads.
MKXIII is offline   Reply With Quote
Old 02-05-2007, 12:22 PM   #2
kharris4
Scooby Specialist
 
Member#: 46018
Join Date: Oct 2003
Chapter/Region: MWSOC
Vehicle:
2003 wrx
silver(mostly stock)

Default

What Happened When You Got It Unstuck? Did It Pop Back Up, Or Did It Lack The Pressure Needed To Pop Back Up?
kharris4 is offline   Reply With Quote
Old 02-05-2007, 05:06 PM   #3
MKXIII
Scooby Specialist
 
Member#: 130388
Join Date: Oct 2006
Chapter/Region: MWSOC
Vehicle:
2007 WRX STI Limited
Urban Steel Gray Metallic

Default

it poped back up into its normal position....
MKXIII is offline   Reply With Quote
Old 02-19-2007, 08:02 AM   #4
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2013 Smugmobile
and DADCORE

Default

I'm having the same issue in my '02 WRX Wagon right now.

edit: I bled the system A LOT. It feels like it's fixed now. I'll have to see if it happens again. If so there is a leak somewhere.

Last edited by Jard; 02-19-2007 at 12:13 PM.
Jard is offline   Reply With Quote
Old 02-24-2007, 09:23 PM   #5
Sean LTD
Scooby Newbie
 
Member#: 130439
Join Date: Oct 2006
Chapter/Region: SWIC
Location: Sierra Vista, Arizona
Vehicle:
2007 STi LTD
Urban Metallic Grey

Default

My clutch became completely unresponsive when shifting from first to second. The grind was terrible. Pressing the peddal did nothing. I pulled over, turned off the car, started it again, and presto. It worked. I've grinded 2nd a few times since buying the car because it doesn't disengage all the way all the time. I'm taking it in after the weekend. Thought the problem was similar to yours. Keep us posted.
Sean LTD is offline   Reply With Quote
Old 02-25-2007, 11:05 AM   #6
noitseuq
Scooby Newbie
 
Member#: 136439
Join Date: Jan 2007
Default

i need legitimate post!
noitseuq is offline   Reply With Quote
Old 02-25-2007, 11:33 AM   #7
former3g
Scooby Specialist
 
Member#: 58858
Join Date: Apr 2004
Chapter/Region: Tri-State
Location: Morristown, NJ
Vehicle:
'10 EVO X GSR w/SSS
'02 i35 Grandpa Edition

Default

I had this problem once when it was cold out. I had it checked out at the stealership service shop and they “could not duplicate”
former3g is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clutch pedal stuck to floor Change Transmission (AT/MT) & Driveline 30 10-13-2012 06:32 PM
Stuck Clutch Pedal MY98 ehime Forester Forum 4 08-10-2008 01:05 PM
Stuck clutch pedal in cold weather? ASpec818 Transmission (AT/MT) & Driveline 4 12-26-2007 08:30 PM
My leg gets stuck on a clutch pedal! *sigh* paulney Outback Forum 2 12-22-2005 04:26 AM
Clutch pedal keeps getting stuck to the floor. powerlabs Transmission (AT/MT) & Driveline 9 07-06-2005 10:12 PM


All times are GMT -4. The time now is 01:43 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.