Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-06-2007, 10:05 PM   #1
04.STI
Scooby Specialist
 
Member#: 36812
Join Date: May 2003
Chapter/Region: Tri-State
Location: CNJ
Default my Impreza's idle bounces!

Hey guys,

2000 Impreza 2.2l

Well heres the problem im a bit confused, the other day i was driving and when i came to a stop my check engine light came on and my cars idle bounced from 1000 to 500 to 1500 to 500 to 1500... etc it keeps doing that .. today the light came off and its still doing that! does anyone know why? i hooked up OBD2 to it and nothing..
* Registered users of the site do not see these ads.
04.STI is offline   Reply With Quote
Old 02-07-2007, 12:30 AM   #2
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

front 02 sensor is going out
i'll betcha.....


if you can check it with your scanner
see the amount of correction going on in the AF mixture
car is trying hard to keep within specs

based on my experiences
I'd have to go with a soon to be dead fron 02 Sensor...

same deal happened to me not too long ago.

Jamie
Subie Gal is offline   Reply With Quote
Old 02-07-2007, 12:42 AM   #3
PRoJeKV6
Scooby Specialist
 
Member#: 108315
Join Date: Feb 2006
Chapter/Region: Tri-State
Location: IN A WORLD . . . ONE MAN . . .
Vehicle:
'04 WRX
WRB, BBS, PTSD, DD's, BRB

Default

I know this may be completely unrelated (as I own a VW), but every little bit helps.

I made a U-Turn, and all of a sudden my idle started to dip from ~600 - ~2000 RPMs and back again continuously. Sometimes the car would stall on some of the dips. So driving the thing around was a bish . . . especially slow rolling starts.

I had my Passat in the shop for almost 2 months while the asshats didn't know all that was wrong was a fuggin' burnt FUSE!

I got 16 engine codes from this one fuse.
PRoJeKV6 is offline   Reply With Quote
Old 02-07-2007, 02:49 PM   #4
IMPREZive 02 WRX
Scooby Specialist
 
Member#: 11436
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NJ
Vehicle:
1999 Impreza RS
eBay racing edition!

Default

Quote:
Originally Posted by 04.STI View Post
Hey guys,

2000 Impreza 2.2l

Well heres the problem im a bit confused, the other day i was driving and when i came to a stop my check engine light came on and my cars idle bounced from 1000 to 500 to 1500 to 500 to 1500... etc it keeps doing that .. today the light came off and its still doing that! does anyone know why? i hooked up OBD2 to it and nothing..
Any mods to the car? Throttle body coolant bypass?
IMPREZive 02 WRX is offline   Reply With Quote
Old 02-07-2007, 03:11 PM   #5
fluxcapacitor
Scooby Specialist
 
Member#: 93843
Join Date: Aug 2005
Chapter/Region: SCIC
Location: SOCAL - West Covina
Vehicle:
X Evo X
1.21 Gigawatts of Boost

Default

Quote:
Originally Posted by Subie Gal View Post
front 02 sensor is going out
i'll betcha.....


if you can check it with your scanner
see the amount of correction going on in the AF mixture
car is trying hard to keep within specs

based on my experiences
I'd have to go with a soon to be dead fron 02 Sensor...

same deal happened to me not too long ago.

Jamie
i got the same problem on my 04 wrx. Is there a way to fix the 02 sensor?
fluxcapacitor is offline   Reply With Quote
Old 02-07-2007, 03:31 PM   #6
SubaruGenuineParts
NASIOC Vendor
 
Member#: 82767
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Bellevue, WA
Default

Quote:
Originally Posted by fluxcapacitor View Post
i got the same problem on my 04 wrx. Is there a way to fix the 02 sensor?
REPLACE it....


there is no fixing....
SubaruGenuineParts is offline   Reply With Quote
Old 02-07-2007, 03:41 PM   #7
fluxcapacitor
Scooby Specialist
 
Member#: 93843
Join Date: Aug 2005
Chapter/Region: SCIC
Location: SOCAL - West Covina
Vehicle:
X Evo X
1.21 Gigawatts of Boost

Default

how much is it?
fluxcapacitor is offline   Reply With Quote
Old 02-07-2007, 03:58 PM   #8
04.STI
Scooby Specialist
 
Member#: 36812
Join Date: May 2003
Chapter/Region: Tri-State
Location: CNJ
Default

yeah i assumed that too... no just intake... thats all.. i guess i will have to replace the O2 sensoer
04.STI is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sad day in my garage.... my impreza's first wreck Koiracer Member's Car Gallery 21 03-05-2010 09:31 AM
My AF is running perfect...My EGT is bouncing like a child requiring ritalin... peepmina Factory 2.0L Turbo Powertrain 13 09-04-2009 03:56 PM
my megan coilovers = bounce drain bramage Brakes, Steering & Suspension 3 04-12-2006 05:46 AM
04 STi idle bouncing. Vtecready Factory 2.5L Turbo Powertrain 15 09-16-2005 05:12 PM
Are the LM-22s causing my car to bounce? MissMyStook Brakes, Steering & Suspension 10 12-09-2002 11:06 PM


All times are GMT -4. The time now is 05:37 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.