Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-15-2007, 09:40 PM   #1
molehill84
Scooby Newbie
 
Member#: 138423
Join Date: Jan 2007
Location: PA
Vehicle:
2005 Impreza WRX STi
CGM

Unhappy Windshield Wiper Problems

So I was on my way to work today and I tried to use my windshield wipers and they swung up the whole way and stopped...They wouldn't go back down, though they kept trying even after I turned them off...I went to the dealership, they tried to fix it...I have to take it in tomorrow and drop it off, they think it's the switch. They even pushed it back down and when I turned the car back on they would automatically go back up and stop...I've had the car for 2 weeks now and this is the 2nd time it's in the shop
* Registered users of the site do not see these ads.
molehill84 is offline   Reply With Quote
Old 02-16-2007, 11:35 AM   #2
Mavrik
Scooby Guru
 
Member#: 90347
Join Date: Jul 2005
Chapter/Region: AKIC
Location: Anchorage AK
Vehicle:
2013 BRZ & Imp 2.5RS
Yamaha FZ8

Default

Sounds like the wipers are out of index and stop at the top thinking they are parked down...
Mavrik is offline   Reply With Quote
Old 02-23-2007, 10:56 PM   #3
dibblejr
Scooby Guru
 
Member#: 94070
Join Date: Aug 2005
Chapter/Region: South East
Location: Dirty South
Vehicle:
05 LGT
PSM

Default

The problem with the dealer or anyone forcing them back down, they can screw up the threads on the al. arm insert, then they have to replace the entire arm and possibly motor.

Jay-R
dibblejr is offline   Reply With Quote
Old 02-24-2007, 02:41 PM   #4
Got Boost?
Scooby Specialist
 
Member#: 113096
Join Date: Apr 2006
Chapter/Region: SWIC
Location: vegas..
Vehicle:
06 sti

Default

sounds like a bad wiper motor
Got Boost? is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Windshield wiper problem shoodoggy Service & Maintenance 2 07-13-2009 05:17 PM
Problem w/ windshield wiper fluid thingy go0sebumpz Interior & Exterior Modification 3 12-30-2007 10:56 AM
Windshield Wiper Arms ( wipers arm ) FD777 Car Care & Detailing 16 12-21-2007 03:28 PM
Bizarre windshield wiper problem elijahwrx Service & Maintenance 7 04-03-2007 09:21 AM
('93-'01) Where can i find a faster Windshield Wiper motor??? Fast like the WRC cars! SRI Performance Impreza Forum 1 04-11-2001 11:19 AM


All times are GMT -4. The time now is 07:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.