Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-22-2011, 10:02 PM   #426
punkrockdave
Scooby Newbie
 
Member#: 125816
Join Date: Sep 2006
Chapter/Region: SCIC
Location: South Coast
Vehicle:
2006 wrx wagon
steel gray

Default

I just got the CEL for the air pump so I plan on removing the whole assembly, but is it really that easy to turn off the CEL's on the accessport.

Is there a tutorial somewhere out there?


Quote:
Originally Posted by EvileyeZ88 View Post
Accessport Race tuner allows you to turn off the CEL's
* Registered users of the site do not see these ads.
punkrockdave is offline   Reply With Quote
Old 07-22-2011, 10:43 PM   #427
WRX_02_227
Scooby Specialist
 
Member#: 12434
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: PA
Vehicle:
2002 WRX, 2015 WRX
2011 BMW 135i

Default

Quote:
Originally Posted by punkrockdave View Post
I just got the CEL for the air pump so I plan on removing the whole assembly, but is it really that easy to turn off the CEL's on the accessport.

Is there a tutorial somewhere out there?
Get AccessTuner Race from Cobb, install it on computer.

Open it then choose File, load map, browse to your map and open it.

Next click "Edit" then click "Advanced Parameters".

A box will pop up with a lot of check boxes and OBDII codes. Uncheck the boxes for the CELs you want to turn off, click OK. Then click File, save map, I suggest naming it a new name.

Finally you load the map onto the AccessPort and reflash the ECU. You have to do a full reflash for the CELs to turn off and not just switch to a realtime map.
WRX_02_227 is offline   Reply With Quote
Old 07-22-2011, 11:21 PM   #428
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

^you got it
EvileyeZ88 is offline   Reply With Quote
Old 07-23-2011, 03:58 AM   #429
punkrockdave
Scooby Newbie
 
Member#: 125816
Join Date: Sep 2006
Chapter/Region: SCIC
Location: South Coast
Vehicle:
2006 wrx wagon
steel gray

Default

do you have to have an AP, or can you just get a tactrix cable and do it on your own?

i did some research and for some reason, i can't find the software for mac.
is romraider/ecuflash PC only, for now?
punkrockdave is offline   Reply With Quote
Old 07-23-2011, 08:49 AM   #430
1 Lucky Texan
Scooby Specialist
 
Member#: 46320
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Outoftheblue&intotheblack
Vehicle:
06 WRX Sportwagon
Aspen White

Default

Quote:
Originally Posted by punkrockdave View Post
do you have to have an AP, or can you just get a tactrix cable and do it on your own?

i did some research and for some reason, i can't find the software for mac.
is romraider/ecuflash PC only, for now?

Tactric, RR, Eflsh is how I killed mine.
1 Lucky Texan is offline   Reply With Quote
Old 07-23-2011, 03:22 PM   #431
punkrockdave
Scooby Newbie
 
Member#: 125816
Join Date: Sep 2006
Chapter/Region: SCIC
Location: South Coast
Vehicle:
2006 wrx wagon
steel gray

Default

Doesn't seem like there are mac versions of this program, right?
Quote:
Originally Posted by 1 Lucky Texan

Tactric, RR, Eflsh is how I killed mine.
punkrockdave is offline   Reply With Quote
Old 07-23-2011, 03:47 PM   #432
Tuned200
Scooby Specialist
 
Member#: 127740
Join Date: Oct 2006
Chapter/Region: MWSOC
Location: Florence, KY
Vehicle:
2007 FSXT-Mine
2007 F-STI-Her's

Default

How much is the race tuner software?
Tuned200 is offline   Reply With Quote
Old 07-23-2011, 04:07 PM   #433
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

About free.99
EvileyeZ88 is offline   Reply With Quote
Old 07-24-2011, 01:04 AM   #434
1 Lucky Texan
Scooby Specialist
 
Member#: 46320
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Outoftheblue&intotheblack
Vehicle:
06 WRX Sportwagon
Aspen White

Default

Quote:
Originally Posted by punkrockdave View Post
Doesn't seem like there are mac versions of this program, right?
I admit I don't know. Perhaps you could borrow someone's PC compatible laptop for the operation. Unless you want to get into some tuning outside of just killing the 14-15 or so codes associated with the bad air pump system, it's a set and forget deal. It's outlined pretty well in one of these threads, try a search on my handle plus tactrix. I couldn't have done it without the advice and support here.
1 Lucky Texan is offline   Reply With Quote
Old 08-03-2011, 08:23 PM   #435
RedSpyder
Scooby Newbie
 
Member#: 220714
Join Date: Aug 2009
Default

Hi guys!

I have 07 WRX and I just got this damned CEL (P0140). Lets supose Im a lazy bastard, can I just leave the whole Air Pump Assembly crap there and just erase the code with "reflash"?

Like it wont hurt leaving the air pump there doing nothing?

Thanks in advance.
RedSpyder is offline   Reply With Quote
Old 08-03-2011, 11:49 PM   #436
WRX_02_227
Scooby Specialist
 
Member#: 12434
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: PA
Vehicle:
2002 WRX, 2015 WRX
2011 BMW 135i

Default

Quote:
Originally Posted by RedSpyder View Post
Hi guys!

I have 07 WRX and I just got this damned CEL (P0140). Lets supose Im a lazy bastard, can I just leave the whole Air Pump Assembly crap there and just erase the code with "reflash"?

Like it wont hurt leaving the air pump there doing nothing?

Thanks in advance.
Depends on if the valves are stuck closed or open. If they are closed you can pull the fuses and clear the codes with a reflash. That's what I did on my 08 Forester and haven't had any trouble. The very best idea though is to install block off plates and turn off the codes. I have the block off plates from KS Tech just waiting to be installed.
WRX_02_227 is offline   Reply With Quote
Old 08-15-2011, 09:46 PM   #437
juanvaldez
Scooby Newbie
 
Member#: 291569
Join Date: Aug 2011
Default Instructions for Removal 06 9-2X

Does anyone have a guide for the removal/replacement of the secondary air pump on an 06 WRX / 06 Saab 9-2x. My mechanic is a bit hesitant to do the repair seeing he can't find any info on the repair in his repair software. He said if I found some documentation on what needs to be done we could undertake the repair.

Mine is stuck closed with CEL and code p2441 Secondary air injection switching valve stuck shut.

I would do the re-flash but the rom raider appears to cost $500, anyone in MN metro area with experience?

Thanks!

Patrick
juanvaldez is offline   Reply With Quote
Old 08-16-2011, 12:56 AM   #438
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Well if they are stuck shut then just shut the codes off and forget it nothing wrong there, unless you want to remove the whole system.

I've taken a few of these bastardous systems out, if you got any questions please feel free to Pm me.
EvileyeZ88 is offline   Reply With Quote
Old 09-08-2011, 12:18 PM   #439
airplnmdls
Scooby Newbie
 
Member#: 218510
Join Date: Jul 2009
Default

Hey guys, well i got P4224...valve stuck open (Bank 2)...2007 WRX...after reading over this entire thing twice, I understand what I need to do but I have a couple of questions...

1) I want to check the fuses/relays first. Are the relays for the valves on the main fuse box under the hood, labeled something like A/C CUT 1 or A/C CUT 2?

2) If im doing the plate delete on passenger side, if I want to cut off the flange head instead of removing the piping, do I still need to remove the downpipe/uppipe, or can I just work around it?

3) While I'm trying to sort all this out the next few days, my valve is stuck open, is it bad to be driving to work with it?

4) Bank 2 is driver's side correct? Does that mean A/C CUT 2?

5) Does anyone have this bank 2 valve they are interested in selling (if it works)? thank you!!!

EDIT: The relays I'm looking at were actually AIR CUT 1 and AIR CUT 2, are these the correct ones that control the valves?

Last edited by airplnmdls; 09-08-2011 at 12:45 PM.
airplnmdls is offline   Reply With Quote
Old 09-08-2011, 12:46 PM   #440
1 Lucky Texan
Scooby Specialist
 
Member#: 46320
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Outoftheblue&intotheblack
Vehicle:
06 WRX Sportwagon
Aspen White

Default

I think they say AIR cut.

not confident to answer the other questions.

good luck.
1 Lucky Texan is offline   Reply With Quote
Old 09-08-2011, 01:56 PM   #441
T-dub
Scooby Specialist
 
Member#: 244480
Join Date: Apr 2010
Chapter/Region: TXIC
Location: Houston
Vehicle:
'07 WRX TR
CGM

Default

You will have to pull the up for sure. I did any way. One of the bolts wont come out with it on there.
T-dub is offline   Reply With Quote
Old 09-09-2011, 07:03 AM   #442
airplnmdls
Scooby Newbie
 
Member#: 218510
Join Date: Jul 2009
Default

Hmmm ok, not gonna be fun....I pulled the codes again last night and I had 3! P2442, P2443, and P1410...The first two contradict themselves, it says the bank two valve is stuck open and stuck closed. Then the third code seems to just say there's a general issue with the valve...I don't know what's happening...I switched the two relays just incase it was bad. We'll see in a couple of days...
airplnmdls is offline   Reply With Quote
Old 09-17-2011, 03:39 PM   #443
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

Quote:
Originally Posted by Bariga View Post
looks like no one has balls to do it, so i did it.





After i open it up i realize it was not necessary to cut anything, you can do it from top with sharp knife just cut and you set! Make sure you heat up the top of it for easy cutting!
So, I cut mine as well, what are the little leads showing on the bottom for, the air-pump motor? Should we worry about them shorting out? I'm gonna look at the factory service manual and hopefully find what pins the are the pull them out of the connector...

BeBop86 is offline   Reply With Quote
Old 09-17-2011, 08:46 PM   #444
Frank A
Scooby Specialist
 
Member#: 49979
Join Date: Dec 2003
Chapter/Region: MAIC
Location: MD, US
Vehicle:
11 dgm wrx hatch
08 black TA STI

Default

I think they are the power to open the solenoid and I don't think I did anything special to get rid of mine. I did cable-tie the unit in the engine bay in a way that any moisture would drain off.
Frank A is offline   Reply With Quote
Old 09-18-2011, 07:44 PM   #445
T-dub
Scooby Specialist
 
Member#: 244480
Join Date: Apr 2010
Chapter/Region: TXIC
Location: Houston
Vehicle:
'07 WRX TR
CGM

Default

Quote:
Originally Posted by BeBop86

So, I cut mine as well, what are the little leads showing on the bottom for, the air-pump motor? Should we worry about them shorting out? I'm gonna look at the factory service manual and hopefully find what pins the are the pull them out of the connector...
I just wrapped mine with a generous amount of electric tape and a zip tie. You don't need the manual. Just check continuity with a multimeter.

Last edited by T-dub; 09-18-2011 at 08:32 PM.
T-dub is offline   Reply With Quote
Old 09-18-2011, 08:53 PM   #446
BeBop86
Scooby Guru
 
Member#: 147776
Join Date: May 2007
Chapter/Region: NWIC
Location: Bellingham, WA
Vehicle:
'02 Impreza WRX
'85 Toyota Corolla

Default

Good point...
BeBop86 is offline   Reply With Quote
Old 09-19-2011, 10:26 AM   #447
lancelot86
Scooby Newbie
 
Member#: 240032
Join Date: Mar 2010
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
2010 FXT
DGM

Default

I took my 2007 WRX into the Subaru dealership today and was quoted $830 for parts and labor. The code mine is throwing is P2441. Outrageous. I'm not wasting my money. I've already ordered the block off plates and I'm planning on getting a CobbAP.

Oh, and on top of that already ridiculous price they quoted I had to pay $52 for them to tell me what I already knew. If you get this code thrown don't even waste your time taking it into the dealer.
lancelot86 is offline   Reply With Quote
Old 09-19-2011, 10:37 AM   #448
1 Lucky Texan
Scooby Specialist
 
Member#: 46320
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Outoftheblue&intotheblack
Vehicle:
06 WRX Sportwagon
Aspen White

Default

Quote:
Originally Posted by lancelot86 View Post
I took my 2007 WRX into the Subaru dealership today and was quoted $830 for parts and labor. The code mine is throwing is P2441. Outrageous. I'm not wasting my money. I've already ordered the block off plates and I'm planning on getting a CobbAP.

Oh, and on top of that already ridiculous price they quoted I had to pay $52 for them to tell me what I already knew. If you get this code thrown don't even waste your time taking it into the dealer.
Did they happen to mention if the parts have been redesigned and this won't happen again in 4 years?


yeah, I didn't think so.
1 Lucky Texan is offline   Reply With Quote
Old 09-20-2011, 05:54 PM   #449
lancelot86
Scooby Newbie
 
Member#: 240032
Join Date: Mar 2010
Chapter/Region: MWSOC
Location: Iowa
Vehicle:
2010 FXT
DGM

Default

Quote:
Originally Posted by 1 Lucky Texan View Post
Did they happen to mention if the parts have been redesigned and this won't happen again in 4 years?


yeah, I didn't think so.

Nope. The guy was adamant that no such thing as an "air pump" existed on my car. I told him the 06 WRXs had 2 and the 07s had 1. He thought I was crazy. Maybe they don't call it an air pump.

I told him I wasn't gonna spend close to $900 to have thing crap out again in 30k miles. I said I'd remove the POS and delete the codes using a CobbAP.

CORRECTION: 06 and 07 WRXs have 2 "valves" to block off.

Last edited by lancelot86; 09-28-2011 at 03:00 PM.
lancelot86 is offline   Reply With Quote
Old 09-30-2011, 09:05 PM   #450
some dude
Scooby Specialist
 
Member#: 100300
Join Date: Nov 2005
Chapter/Region: MWSOC
Location: MIC|-|IG/\N
Vehicle:
06 WRX
CGM

Default

Quote:
Originally Posted by 1 Lucky Texan View Post
I admit I don't know. Perhaps you could borrow someone's PC compatible laptop for the operation. Unless you want to get into some tuning outside of just killing the 14-15 or so codes associated with the bad air pump system, it's a set and forget deal. It's outlined pretty well in one of these threads, try a search on my handle plus tactrix. I couldn't have done it without the advice and support here.

I read this ENTIRE thread looking for detailed instructions on how to DELETE the CEL with OPENSOURCE tuning. I was unable to find the thread when searching your handle + tratrix ( I also tried tactrix). The last thing this thread could use is a detailed explanation of HOW TO DELETE CELs.
some dude is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Air pump removal + fail? 07 WRX. Badmunky Factory 2.5L Turbo Powertrain 13 04-29-2013 08:05 PM
WTB 06-07 Wrx AIR PUMP StageWrx Private 'Wanted' Classifieds 1 03-30-2009 10:44 PM
is it safe if i remove the restrictor on my wrx prlblkwrx02 Factory 2.0L Turbo Powertrain 44 03-24-2007 07:21 PM
Is it safe to switch to summer tires yet? It is March after all... Samirr76 Tri-State Area Forum 38 03-06-2003 09:25 PM


All times are GMT -4. The time now is 11:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.