Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-02-2007, 11:56 PM   #1
livinloud
Scooby Newbie
 
Member#: 139283
Join Date: Jan 2007
Location: BOOfaLow , NY
Vehicle:
02 wrx wagon
world rally blue

Default My WRX is knocking

i am a 2nd owner wrx wagon owner. the wagons is ALMOST bone stock minus the header and up pipe due to some factory problems.
02 wrx with 58k

here goes my story....

back in late december i had begun to experiance a CEL. my car knowledge only goes so far. I found i had misfire in ALL 4 cylinders. i changed the plugs, i changed the coil packs. now thinking maybe i have fuel issues i replaced the fuel filter. STILL NOTHING. my turbo ended up gettin FOD. i had to replace that. i thought maybe the turbo was on its way out and it was the cause to the entire issue. i bought a used turbo with 5k on it. about 4 hours later after swapping turbos the car ran better but still misfiring and boggy as all hell. i decide after 2 months to give up on my search on the forums, search on the car, and giving up on all the problems. i took the car to the dealer where i was prepared to be raped with my money. after the 100 doller diagnosis, they said my o2 was all messed up. when they went to replace it the end was severed off and the up pipe was welded shut almost. all sorts of what looks like honey comb was all lodged in there. the interior of the upipe was destroyed. i went on ebay just to deal with the issue and picked up a header and up pipe. i put it on today and WOW like brand new.. EXCEPT the noise. a noise which appears to be rod knock. on a car that is stock with little abuse it should not happen. I FULLY BLAME Subaru for the defective up pipe. all this has been doing is causing me money loss and stress. any idea if subaru will cover this DEFECT of the manufacturer even though im not under warrentee? It almost makes me wish i woulda bought another honda. ive had 3 hondas over the last multiple years and NEVER had an issue. gahhh. any advice or opinions about my situation?

this is my daily driver and i never planned to mod it. just keep it as my daily driver and make it through the winter season.

thanks
* Registered users of the site do not see these ads.
livinloud is offline   Reply With Quote
Old 03-03-2007, 12:08 AM   #2
ilnmcom
Scooby Specialist
 
Member#: 53557
Join Date: Jan 2004
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2003 WRX - SOLD!
WR Blue Pearl

Default

Did you get a read on the CEL? What code? Someone here may be able to help you better if the code helps them figure out the misfires. Just a thought.
ilnmcom is offline   Reply With Quote
Old 03-03-2007, 12:54 AM   #3
Hondaslayer
Purified Dick
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default

I would be willing to bet that the original owner had the three no no's of tuning a WRX.

BOV
CAI
MBC

Those will cause the damage that you mentioned if used improperly (like most kiddie rycers)
Hondaslayer is offline   Reply With Quote
Old 03-03-2007, 02:27 AM   #4
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

Quote:
Originally Posted by livinloud View Post
i am a 2nd owner wrx wagon owner. ...
02 wrx with 58k
... I FULLY BLAME Subaru for the defective up pipe. ...
Just to clarify: are you saying you are the 2nd owner of this car, or that this is your 2nd WRX (which you bought brand new)?
If the former, it's pretty hard to blame Subaru for the problem(s), because you have no idea what kind of mods/abuse the car was subjected to by the 1st owner.
armand1 is offline   Reply With Quote
Old 03-03-2007, 04:33 AM   #5
livinloud
Scooby Newbie
 
Member#: 139283
Join Date: Jan 2007
Location: BOOfaLow , NY
Vehicle:
02 wrx wagon
world rally blue

Default

it was an older guy with 2 toddlers and a wife. they wanted a bigger vehicle. and if you saw the way the pipe collapsed you would blame poor manufacturing as well. i will take pics and put them up.
livinloud is offline   Reply With Quote
Old 03-03-2007, 08:17 AM   #6
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

Quote:
Originally Posted by livinloud View Post
it was an older guy with 2 toddlers and a wife. ...
Age doesn't always cure stupidity.

But back to your ownership. How long did you "...go Open Atmosphere for a while..." (BOV?) before the CEL came on? Any other mods?

When you say "...the up pipe was welded shut almost. all sorts of what looks like honey comb was all lodged in there", could that be the result of a cat meltdown there?
armand1 is offline   Reply With Quote
Old 03-03-2007, 10:58 AM   #7
Hondaslayer
Purified Dick
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default

Quote:
Originally Posted by armand1 View Post

When you say "...the up pipe was welded shut almost. all sorts of what looks like honey comb was all lodged in there", could that be the result of a cat meltdown there?
That is exactly what it is.
Hondaslayer is offline   Reply With Quote
Old 03-04-2007, 11:57 AM   #8
livinloud
Scooby Newbie
 
Member#: 139283
Join Date: Jan 2007
Location: BOOfaLow , NY
Vehicle:
02 wrx wagon
world rally blue

Default

and i think due to the load of the exhaust not able to escape the pressure has caused all sorts of issues with the motor. any opinions if it was a factory defective part/?
livinloud is offline   Reply With Quote
Old 03-04-2007, 04:18 PM   #9
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

Quote:
Originally Posted by livinloud View Post
...any opinions if it was a factory defective part/?
It would help if you would answer the question from above:
Quote:
How long did you "...go Open Atmosphere for a while..." (BOV?) before the CEL came on? Any other mods?
armand1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My wrx is no more. It is an ex-wrx. No more for shore. Dynobyte Southern California Impreza Club Forum -- SCIC 66 07-26-2006 08:14 PM
It's 2am and my GF is knocked up! g0tb00st Off-Topic 49 01-22-2005 09:53 AM
Help With my MY00 WRX is Knocking fzturbo Factory 2.0L Turbo Powertrain 4 06-11-2004 09:42 PM
How bad is it if my car is knocking? myko011 Factory 2.0L Turbo Powertrain 7 09-13-2001 04:31 AM
I think my engine is knocking or something... JGard Normally Aspirated Powertrain 13 12-22-2000 12:45 AM


All times are GMT -4. The time now is 11:21 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.