Welcome to the North American Subaru Impreza Owners Club Wednesday January 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-09-2007, 08:01 PM   #1
evoxd
Scooby Specialist
 
Member#: 129745
Join Date: Oct 2006
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2014 Outback

Default Fuse keeps blowing

The fuse that runs my horn, crusie control, emergency flashers, and some other things, keeps going dead. I got a little thing of fuses for like 6 dollars, but its a pain in the butt to have to change it every 2 weeks or so. What do you think could be wrong???
* Registered users of the site do not see these ads.
evoxd is offline   Reply With Quote
Old 03-09-2007, 08:06 PM   #2
Tragedy
Scooby Specialist
 
Member#: 19011
Join Date: May 2002
Vehicle:
Y34 Gloria

Default

Tragedy is offline   Reply With Quote
Old 03-09-2007, 10:17 PM   #3
LastResort
Scooby Guru
 
Member#: 99289
Join Date: Oct 2005
Default

can you narrow it down to one particular action, or combination?
LastResort is offline   Reply With Quote
Old 03-10-2007, 12:36 AM   #4
evoxd
Scooby Specialist
 
Member#: 129745
Join Date: Oct 2006
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2014 Outback

Default

Nope, it worked just fine. Came back out to my car to go home and it stoped working.
evoxd is offline   Reply With Quote
Old 03-10-2007, 01:12 AM   #5
LastResort
Scooby Guru
 
Member#: 99289
Join Date: Oct 2005
Default

That actually will help a bit. It sounds like the short is in the switched portion of the electrical system. You might need a manual to start looking for probable causes. Do you have any aftermarket parts, include head units, turbo timers, gauges?
LastResort is offline   Reply With Quote
Old 03-10-2007, 02:18 AM   #6
evoxd
Scooby Specialist
 
Member#: 129745
Join Date: Oct 2006
Chapter/Region: NWIC
Location: Oregon
Vehicle:
2014 Outback

Default

Ya aftermarket gauges, no other electrical stuff. The gauges work just fine though when the fuse blows, so i dont know? Should i just take it to the dealer. The one in town is known to be a pain in the a**. Should somthing like this be under warrenty?
evoxd is offline   Reply With Quote
Old 03-11-2007, 12:08 AM   #7
LastResort
Scooby Guru
 
Member#: 99289
Join Date: Oct 2005
Default

Maybe, maybe not. Keep in mind, that if those gauges are even peripherally the cause, you will be charged for their work.
LastResort is offline   Reply With Quote
Old 03-26-2007, 04:55 PM   #8
circaisdashiat
Scooby Newbie
 
Member#: 96315
Join Date: Sep 2005
Chapter/Region: SWIC
Location: Tucson, AZ
Vehicle:
1995 STi V5 replica
World rally blue

Default

So the same thing is happening to my 95. With the horn, and my brake switch. no my horn doesnt work and my car doesntknow when im hitting the brakes so my taillights dont light up (possible ticket) and i can shift my car out of park without useing the override button. Possible causes\fixes? I dont want to take it in unless i have to, because my swap is almost done and i need the money for that.

BTW everytime i start my car the fuse blows.
circaisdashiat is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Illumination fuse keeps blowing DLUX WRX Electrical & Lighting 5 11-08-2006 01:21 AM
Speedometer/Window fuse keeps blowing Geoff Electrical & Lighting 0 05-31-2005 03:36 PM
*Urgent* Wiring some lights and fuse keeps blowing Subwoofer87 Electrical & Lighting 6 09-20-2004 12:23 PM
Radio Fuse Keeps Blowing Stilletto Electrical & Lighting 7 09-18-2003 01:12 AM
Main Fuse Keeps Blowing??? striklybidnis Electrical & Lighting 3 07-21-2003 12:36 AM


All times are GMT -4. The time now is 03:02 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.