Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-10-2007, 07:23 AM   #1
mar1asynger
Scooby Newbie
 
Member#: 45808
Join Date: Oct 2003
Chapter/Region: NESIC
Location: Pepperell, MA
Vehicle:
2003 WRX Wagon
JDM Sedan'd Sonic Yellow

Default Defi Control unit stopped working!

I have a Defi Link V2 Control unit with boost and EGT gauges. Yesterday I started my car, they did their self check sweep, everything working fine. They were working fine when I would glance at them. About half way home I looked over and they were off. I shut my car off at a red light in hopes of maybe restarting the unit, but they wouldnt turn back on. Has anyone heard of the control unit just crapping out like that? The thing has only been installed for 2 weeks and its not working! I will check my wiring to make sure none of the wires came loose or something, but I really doubt that happened.
* Registered users of the site do not see these ads.
mar1asynger is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Defi Boost Gauge and Defi control unit jrodriguezx Interior/Dressup/Audio & Security 3 05-14-2010 04:24 PM
Defi amber gauges with Defi pod and Defi control unit blksti042 Interior/Dressup/Audio & Security 26 04-05-2008 07:41 AM
FS|310: Defi Control Unit and BROKEN Defi Amber Boost Gauge Sanchez SCIC Private Classifieds 1 01-08-2008 03:53 AM
fs: defi bf series boost guage and defi control unit II WrexFactor36 SCIC Private Classifieds 2 08-17-2006 11:45 PM
Defi control unit question r5t2 Factory 2.0L Turbo Powertrain 8 05-01-2001 04:45 PM


All times are GMT -4. The time now is 08:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.