Welcome to the North American Subaru Impreza Owners Club Friday December 9, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-13-2007, 06:37 PM   #1
Logannz
Scooby Newbie
 
Member#: 142522
Join Date: Mar 2007
Default Ignition Issues - No spark, no timing?

Hi Everyone.

I'm fairly new here, So i am not sure if this is the right section of the forums.

anyways.

I have a 1993 Impreza, only a few mods..

Problems;

* No current to coils ( The coils are inbuilt into the attachment which connects up to the sparkplug )
*Engine is turning over, but no spark = no continuous running engine............
*Checked all fuses, looms. About to test the coil amplifier on my friends impreza.
*Removed turbo timer ( Featured an auto start... )
* No imobolizers., No alarm.

Any ideas?

Last time it didn't start was because of the fuel pump relay, now this...

It started perfectly, then all of a sudden it won't start. I have a feeling that it could be the amplifier, but i don't know yet....

If one coil fails, does all the rest fail as a consequence?

Any help is appreciated, Getting hardly any local support I don't exactly want to be paying for some monkey to come in and fix it in less than a few minutes.... and charge me huge amounts of dosh.

Regards,
Logan
* Registered users of the site do not see these ads.
Logannz is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 rs swapped ej205 no spark no fuel tscott915 Subaru Conversions 9 10-12-2009 09:41 PM
'95 Gran DAMN. :unamused: no spark, no fuel CosmoTheCat Off-Topic 39 08-28-2009 05:21 AM
No spark, No fuel injector pulse. AwdBoostCreep Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 02-12-2009 01:04 AM
EJ22 Swap - No Spark... no ground for fuel pump relay?? Subarutex Subaru Conversions 5 01-22-2007 01:14 PM
There's just no spark... no electricity... Hypernoodle Off-Topic 32 07-06-2006 03:14 PM

All times are GMT -4. The time now is 04:13 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.