Welcome to the North American Subaru Impreza Owners Club Wednesday April 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-07-2001, 01:02 AM   #1
keystone
Scooby Newbie
 
Member#: 9807
Join Date: Aug 2001
Location: Saint Louis, MO
Vehicle:
2002 WRX
BLUE

Default Why are so many people loosing boost pressure??

I dont understand why so many are loosing boost pressure. I dont loose like any. This is how my car runs:

in first gear i reach half boostat like 3400rpm, and by the time i get to 6000 it hits full.
2nd i hit full boost at around 3000-3200 and it stays there. I even went up to my rev-limiter just to see, and it didnt change, it stayed right at full boost.
3rd acts the same as second, agian full boost, it drops off a little at around 6500rpm.
4th is nearly the same as 3rd, but then starts comming back.
I didnt test 5th I was on some pricate streats and didnt feel like doin 130

but i hear soo much about loosing boost and boost spikes and falls whats going on? is my car just acting wierd?

I woul like to see your comments...
* Registered users of the site do not see these ads.
keystone is offline   Reply With Quote
Old 12-07-2001, 02:57 AM   #2
Eric SS
Sooby Guru
 
Member#: 1914
Join Date: Jul 2000
Chapter/Region: SWIC
Location: 2013 335i, 2011 G37 coupe
Vehicle:
2000 2.5RS w/ EJ22T
swap and N20. gone. : (

Default

The WRX is supposed to lose a couple PSI as it nears redline. It's designed that way for safetly to the engine I believe.

Eric
Eric SS is offline   Reply With Quote
Old 12-07-2001, 02:59 AM   #3
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

eric is right...the ECU is programmed to bleed boost as the engine RPM climbs to avoid things like detonation and fuel cut...maybe the hose to your boost controll solenoid is pinched or you have a manual boost controller...or now you have an MBC w/ a turbo back.

jeremy
HndaTch627 is offline   Reply With Quote
Old 12-07-2001, 10:17 AM   #4
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim spun rod bearing

Default

I seriously am starting to think that there was a batch of WRX's that have a larger wastegate or perhaps a wastegate that flows better. The reson why we get inconsistent boost an boost dropping off is because of the size of the wastgate. Even with my MBC, if I set it around factory, I only get a spike to 14 and solid 11-12 PSI in first. About the same that I was getting factory. I set 3rd at around 15.5 PSI max and get around 13-14 in first. This is all a factor of exhaust pressure versus the wastegate's ability to flow. A fellow owner who has a slightly newer WRX ran me from a light. Up to 80 we were dead even. He was stock though and I have a boost controller. It was set to 15.5. All the other stock WRX's I've ran I walk by easily. After some discussion, come to find out, he has one of the WRX's that boosts 1 Bar consistently. His is blue as well.

We may come to find out that all the newer WRX's being built boost 1 bar consistently. If that's the case, all of us with the ****ty wastgates need to complain to Subaru...

We get a mid 14 car when the newer ones are 14 flatters...

Also, Subaru may be feeling the need to back up that 5.4 sec 0-60 they advertise in the commercials...
gabedude is offline   Reply With Quote
Old 12-07-2001, 11:33 AM   #5
keystone
Scooby Newbie
 
Member#: 9807
Join Date: Aug 2001
Location: Saint Louis, MO
Vehicle:
2002 WRX
BLUE

Default

Yeah mine boosts one bar very consistantly.. I got mine in august, and was one of the lucky few who had to get my ecu re-programmed
keystone is offline   Reply With Quote
Old 12-07-2001, 11:38 AM   #6
Tronner
Scooby Newbie
 
Member#: 12845
Join Date: Nov 2001
Chapter/Region: RMIC
Location: Denver, CO
Vehicle:
2008 BMW 335xi
Sparkling Graphite

Default

gabedude,

What do you mean by "his is blue as well"? I'm just curious.
Tronner is offline   Reply With Quote
Old 12-07-2001, 11:40 AM   #7
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim spun rod bearing

Default

If they have changed the boost curve on the ECU boost maps, then I think we all should be entitled to an upgrade. If that's the case (the new ecu program fixes it), I'm taking off my MBC and getting the upgrade.

SOA, are you listening? What's the deal here?
gabedude is offline   Reply With Quote
Old 12-07-2001, 11:41 AM   #8
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim spun rod bearing

Default

Quote:
Originally posted by Tronner
gabedude,

What do you mean by "his is blue as well"? I'm just curious.
He has a blue WRX. Its possible that there were a batch (probably the same color) that got different turbos or turbos with a different sized wastegate. If its an isolated batch, they may be the same color if Subaru makes them in color batches...
gabedude is offline   Reply With Quote
Old 12-07-2001, 12:41 PM   #9
keystone
Scooby Newbie
 
Member#: 9807
Join Date: Aug 2001
Location: Saint Louis, MO
Vehicle:
2002 WRX
BLUE

Default

Yeah my boost maps could be different cause I did get my ECU re-programed. Before that My car started to dump fuel and I got about 8mpg. then i got it re-programmed... in october.
keystone is offline   Reply With Quote
Old 12-07-2001, 12:47 PM   #10
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

actually gabe i think they reason for the incosistent boost lays in the design of the exhaust itself....one of the guys in this area just put a turbo back on and he now seels full boost till redline when before he would spike between 13-14 in 1st & 2nd gear...3rd gear 16...4th and 5th he could easily overboost & 18...now that he has gotten the turbo back on he holds 16 thru all the gears no boost spikes or overboosts. I think that there is quite a bit of exahust turbulence in the factory exhaust not allowing hte wastegate to properly controll the turbo speed. OH he has a WRB WRX by the way. Factory turbo still.

jeremy
HndaTch627 is offline   Reply With Quote
Old 12-07-2001, 01:00 PM   #11
keystone
Scooby Newbie
 
Member#: 9807
Join Date: Aug 2001
Location: Saint Louis, MO
Vehicle:
2002 WRX
BLUE

Default

Well i dont have a "stock" exhaust per say , it was the optional one. SPT performance exhaust. So that could have something to do with it.

BTW - SPT exhaust sounds real nice
keystone is offline   Reply With Quote
Old 12-07-2001, 01:44 PM   #12
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim spun rod bearing

Default

Ahh makes sense. I be needin that up-pipe and turbo back soon!
gabedude is offline   Reply With Quote
Old 12-07-2001, 02:06 PM   #13
roadmaster
Scooby Newbie
 
Member#: 8563
Join Date: Jul 2001
Vehicle:
2002 WRX

Default

One cause of boost fall-off is drag in the intake tract even after the turbo. Smoothing out the rough transitions makes a big difference.
roadmaster is offline   Reply With Quote
Old 12-07-2001, 02:53 PM   #14
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by keystone
Well i dont have a "stock" exhaust per say , it was the optional one. SPT performance exhaust. So that could have something to do with it.

BTW - SPT exhaust sounds real nice
well IIRC the SPT exhaust flows more freely making it able to allow the turbo to hit full boost and stay there.

jeremy
HndaTch627 is offline   Reply With Quote
Old 12-08-2001, 09:05 AM   #15
GOT_WRX
Scooby Specialist
 
Member#: 7241
Join Date: Jun 2001
Default

Quote:
Originally posted by gabedude
I'm taking off my MBC and getting the upgrade.

SOA, are you listening? What's the deal here?
If SoA is listening, you are in trouble
GOT_WRX is offline   Reply With Quote
Old 12-08-2001, 12:45 PM   #16
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by GOT_WRX


If SoA is listening, you are in trouble
good point

Jeremy
HndaTch627 is offline   Reply With Quote
Old 12-08-2001, 02:35 PM   #17
gabedude
Scooby Guru
 
Member#: 10108
Join Date: Sep 2001
Chapter/Region: TXIC
Location: Lake Travis, Austin, TX
Vehicle:
07 STI
60Trim spun rod bearing

Default

They have to prove I did it, and besides, they can't even tell who I am. They don't know my VIN, etc. Plus the dealer I would take it to to get service is mod friendly...
gabedude is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Why are so many people on here such a-holes lately? 24 Off-Topic 2 01-05-2007 04:16 PM
why are so many people against parents buying their kids their own car? momolicious Off-Topic 146 11-14-2006 02:44 PM
Why are so many new Mid A guys so damn retarded?? VSM EXtasy Mid Atlantic Impreza Club -- MAIC 29 02-01-2005 10:41 AM
Why are so many people still up right now? jetfan8178 Tri-State Area Forum 12 12-25-2002 12:36 PM
why do so many people who drive hondas hate impreza bluesubie General Forum Archive 26 08-29-2000 08:29 AM


All times are GMT -4. The time now is 05:27 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.