Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-19-2007, 11:51 PM   #1
evoeater02[wrx]
Scooby Newbie
 
Member#: 70744
Join Date: Sep 2004
Chapter/Region: BAIC
Location: Tahoe
Vehicle:
02 WRX

Default Dash Illumination Control

Okay I know this has been asked before but I don't think anyone has ever posted an answer to this. Basically my dash lights went out after installing a CD player. (I know, stupid me forgot to disconnect the negative terminal first.) So basically the problem is not any of the fuses and I have come to the conclusion that it is the illumination control module/unit. My question is where is that relay? If anyone could give some direction/advice it would be greatly appreciated.
* Registered users of the site do not see these ads.
evoeater02[wrx] is offline   Reply With Quote
Old 03-20-2007, 02:37 AM   #2
100_Percent_Juice
Scooby Specialist
 
Member#: 126042
Join Date: Sep 2006
Chapter/Region: SWIC
Location: Reno, NV
Vehicle:
2004 W Ŕ X
PSM

Default

which dash lights went out? All of them, radio, clock pod...
100_Percent_Juice is offline   Reply With Quote
Old 03-20-2007, 02:48 AM   #3
evoeater02[wrx]
Scooby Newbie
 
Member#: 70744
Join Date: Sep 2004
Chapter/Region: BAIC
Location: Tahoe
Vehicle:
02 WRX

Default

oops forgot to mention that. its the hvac and the gauge cluster(like speedo and tach).
evoeater02[wrx] is offline   Reply With Quote
Old 04-11-2007, 10:25 AM   #4
djosrs
Scooby Specialist
 
Member#: 101730
Join Date: Nov 2005
Chapter/Region: South East
Location: Hoover, AL
Vehicle:
02 WRX
Stage III+ PPG Reppin!

Default

bump for this .... non of my dash lights work when I turn my headlights on ....
(dash, radio, HVAC)
i feel like the night rider :P

someone please help ... i cant tell how fast Im going @ night
djosrs is offline   Reply With Quote
Old 04-11-2007, 10:25 AM   #5
djosrs
Scooby Specialist
 
Member#: 101730
Join Date: Nov 2005
Chapter/Region: South East
Location: Hoover, AL
Vehicle:
02 WRX
Stage III+ PPG Reppin!

Default

ahh and my illumination fuse is NOT blown ... but my car does keep blowing all sorts of fuses grounding problem somewhere?
djosrs is offline   Reply With Quote
Old 04-11-2007, 10:59 AM   #6
Uncle Scotty
Scooby Guru
 
Member#: 16200
Join Date: Mar 2002
Vehicle:
OK Houston
we have an Uncle

Default

Quote:
Originally Posted by djosrs View Post
ahh and my illumination fuse is NOT blown ... but my car does keep blowing all sorts of fuses grounding problem somewhere?
...and yet ANOTHER reason, dearest kiddie readers, not to go screwin around with the wiring unless you know what you are doing....
Uncle Scotty is offline   Reply With Quote
Old 04-20-2007, 12:44 AM   #7
evoeater02[wrx]
Scooby Newbie
 
Member#: 70744
Join Date: Sep 2004
Chapter/Region: BAIC
Location: Tahoe
Vehicle:
02 WRX

Default

alright so just a little update here. my dash lights had been out for over a year when i first posted this thread and just yesterday my battery died and when i jumped it and started the car again my dash lights were on... it was so weird but i was so excited cause i hadnt had illumination for over a year. the only thing is the dimmer control on the stalk does not change the brightness of any of the lights so im a little confused on that one. however im just happy to have my dash lights again. the original reason the lights went out to begin with is i forgot/was too lazy to disconnect the negative terminal on the battery.
evoeater02[wrx] is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Dash/Climate Control/Radio display illumination problem!! TyR1 Electrical & Lighting 16 07-27-2006 12:32 PM
broken dash illumination and alarm NDconKG24 Car Audio, Video & Security 0 01-07-2002 10:33 PM
Lost my dash illumination.. doobie New England Impreza Club Forum -- NESIC 12 12-06-2001 08:21 PM
Color of the Dash Illumination vijay WRX Forum Archive 4 02-24-2001 09:52 AM
Blowing dash illumination fuse Del Car Audio, Video & Security 1 07-28-2000 11:53 AM


All times are GMT -4. The time now is 06:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.