Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-02-2007, 12:22 AM   #1
BooSTIn_StI
Scooby Newbie
 
Member#: 142723
Join Date: Mar 2007
Chapter/Region: SWIC
Location: Nevada..In a City
Vehicle:
2005 STI
Silver

Default Check engin light and cruise control light

Ok so i was drag racing at a track and when i got back into my car after letting it sit i noticed the check engine light is on as well as the cruise control light. I do have an AP Ver 1 on there. So i was told that there is a piece that i could put on the O2 housing to back the sensor away from the exhaust so it would n't do it again i also was told this happened due to the exhaust getting to hot? I was also told i can get this tuned out when i get a pro tune? So i read alot tonight and found out there was this little S@itty thing called boost creep so now i am wondering if its that. i just changed my cat back exhaust and before i did that i never got these lights so can you help me please like i said i was at the track and it didn't do it the first 10 runs so what could have made this happen.

Thank You in Advance...Sorry iof this has been answered i see the same question everywhere but the answers are always get fuel managment and i have that so i am clue less.

* Registered users of the site do not see these ads.
BooSTIn_StI is offline   Reply With Quote
Old 04-02-2007, 12:23 AM   #2
BooSTIn_StI
Scooby Newbie
 
Member#: 142723
Join Date: Mar 2007
Chapter/Region: SWIC
Location: Nevada..In a City
Vehicle:
2005 STI
Silver

Default

ohh by the way i hope i dind't damage my car after casue i ran it like 5 more times
BooSTIn_StI is offline   Reply With Quote
Old 04-02-2007, 09:06 AM   #3
BooSTIn_StI
Scooby Newbie
 
Member#: 142723
Join Date: Mar 2007
Chapter/Region: SWIC
Location: Nevada..In a City
Vehicle:
2005 STI
Silver

Default

t.t.t
BooSTIn_StI is offline   Reply With Quote
Old 04-02-2007, 09:46 AM   #4
conker69
Scooby Specialist
 
Member#: 59692
Join Date: Apr 2004
Location: Cincinnati
Vehicle:
2005 Impreza WRX STi
WRB-Gold

Default

Highly unlikely a catback would cause overboost. Get the code pulled to find out exactly which code it is. It would help if you filled out your profile as well as listing all your current mods.
conker69 is offline   Reply With Quote
Old 04-02-2007, 11:10 PM   #5
BooSTIn_StI
Scooby Newbie
 
Member#: 142723
Join Date: Mar 2007
Chapter/Region: SWIC
Location: Nevada..In a City
Vehicle:
2005 STI
Silver

Default

Thanks conker i will do that
BooSTIn_StI is offline   Reply With Quote
Old 04-02-2007, 11:18 PM   #6
di2co
Scooby Newbie
 
Member#: 105648
Join Date: Jan 2006
Vehicle:
2006 STI
wrb

Default

check your O2 sensor.... I've seen it get broken during hard launches. It won't throw a code right away but the results are just as you described. If you have an 06 it is very possible that a mount broke and the 02 sensor hit the frame rail when you launched.

Jacob
di2co is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Check engine light, VDC light is on, and cruise control light is flashing grimace09 Normally Aspirated Powertrain 7 08-09-2012 03:42 PM
Check engine and cruise control light?? autvincereautmori Service & Maintenance 14 05-09-2007 09:23 PM
Check engine and cruise control light on TENAZ Engine Management & Tuning 6 03-13-2007 01:16 PM
Help check engine light and cruise control blink islandboy78 North West Impreza Club Forum -- NWIC 16 10-31-2005 09:34 AM
Check engine light on and cruise control light flashing mpadovano Factory 2.5L Turbo Powertrain 6 01-23-2005 02:04 PM


All times are GMT -4. The time now is 04:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.