Welcome to the North American Subaru Impreza Owners Club Saturday January 31, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Miscellaneous > Grassroots Motorsports Magazine Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Closed Thread
 
Thread Tools Display Modes
Old 04-03-2007, 12:34 PM   #1
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default missing issue

Did anyone else get their April issue yet? Mine is still not here.
* Registered users of the site do not see these ads.
kpalena is offline  
Old 04-11-2007, 12:51 AM   #2
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default

Eight days later....still no April issue. If it is in news stands...why not my mailbox?
kpalena is offline  
Old 04-11-2007, 02:49 PM   #3
Ensi
Scooby Specialist
 
Member#: 90329
Join Date: Jul 2005
Chapter/Region: NWIC
Location: Lake Stevens, Wa
Vehicle:
05 Sti
Gray

Default

Dude, did you contact Subiesport? Call them at 425-458-4949, they will make sure everything is still up to date.
Ensi is offline  
Old 04-11-2007, 03:33 PM   #4
kpalena
Scooby Specialist
 
Member#: 82431
Join Date: Mar 2005
Chapter/Region: NWIC
Location: Battle Ground, WA
Vehicle:
2006 06 wrx limited
CGM

Default

Dude, yes I did, that's why I posted here to see if anoyne else has or is missing their April issue. Their response was to be patient and that the issues went out a little late. If someone else has their issue and I don't then there is a problem, if no one has it yet, then all is well.
kpalena is offline  
Old 04-11-2007, 05:21 PM   #5
ricochet
Driving Sports TV Staff
 
Member#: 15542
Join Date: Feb 2002
Location: Kirkland, WA
Vehicle:
1991 Legacy Sedan

Default

Quote:
Originally Posted by kpalena View Post
Dude, yes I did, that's why I posted here to see if anoyne else has or is missing their April issue. Their response was to be patient and that the issues went out a little late. If someone else has their issue and I don't then there is a problem, if no one has it yet, then all is well.
Everyone should have the April issue by now. We've all been away throwing Subiefest, so response is slower than usual if you called our main line.

For all subscription replacements/inquiries you should call 1-800-927-4344, that's our subscription department on the east coast.

We don't handle replacement issue concerns on the forum, since we don't monitor them daily. So, either call the above number, or email info@mediaspigot.com with your name, address, and the issue you missed.

Cheers,

Ryan
ricochet is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
axel issue maybe tranny issue? 04stinugget Transmission (AT/MT) & Driveline 2 06-04-2010 12:14 AM
axel issue maybe tranny issue? 04stinugget Brakes, Steering & Suspension 0 06-03-2010 09:44 PM
Missing a part! Need help. WRBlueByYou Newbies & FAQs 4 06-03-2010 05:37 PM
Missing issues!??... subeerex Grassroots Motorsports Magazine Forum 1 04-01-2009 10:13 PM
In case anyone missed it another HANS egress issue with a gas and oil soaked driver turboICE Motorsports 82 06-29-2006 08:13 PM


All times are GMT -4. The time now is 07:37 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.