Welcome to the North American Subaru Impreza Owners Club Monday October 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-07-2007, 05:28 PM   #1
Highway Drifter
Scooby Specialist
 
Member#: 81013
Join Date: Feb 2005
Chapter/Region: Tri-State
Location: North Bergen, NJ
Default Car keeps dying anyone have suggestions?

Hey guys, someone attempted to steal my car a couple of weeks ago and while i got all the parts together to fix it (fender, fender lining, front bumper, sideskirt) I had it sit there...Well while it sat there, I didnt start it at all. So yesterday I goto start the car, realize its dead...jump it, starts up runs, no problem...figure I let the alternator recharge the battery, move the car out of its spot...park it, put the alarm no problem...about 1/2 hour later, check on it, starts up no problem...an hour later its dead. I looked under the driver side fender to see if there was any frayed wiring from when the autolock tore thru the lining but nothing obvious that I can see. I'm thinking about just replacing the battery and see if its that, but does anyone have any other suggestions that they have that it could be? Oh and another weird thing is that my radio doesn't turn on...for ANYTHING. No volume, not even as much as static out of the speakers...could it be some type of ground that came loose? Thanks for the help guys.
* Registered users of the site do not see these ads.
Highway Drifter is offline   Reply With Quote
Old 04-08-2007, 01:32 PM   #2
Highway Drifter
Scooby Specialist
 
Member#: 81013
Join Date: Feb 2005
Chapter/Region: Tri-State
Location: North Bergen, NJ
Default

bummmmmp
Highway Drifter is offline   Reply With Quote
Old 04-09-2007, 10:48 AM   #3
12sechatch
Scooby Guru
 
Member#: 132458
Join Date: Nov 2006
Chapter/Region: NWIC
Location: Kent, Wa
Vehicle:
Okie Dokie Fine

Default

i would say first off, check your radio fuse. its obvious i know but that is more often then not the problem. as for starting issue, it sounds like a dead battery to me. good luck
12sechatch is offline   Reply With Quote
Old 04-10-2007, 08:32 PM   #4
michael_wrx
Scooby Newbie
 
Member#: 130041
Join Date: Oct 2006
Chapter/Region: NWIC
Vehicle:
2004 WRX
Java Black

Default

You might try giving your battery a full charge from a real battery charger. If the battery was significantly drained it could take a long time for the alternator to give it a good charge. If it still gives you trouble, make sure your battery terminals are clean as well.
michael_wrx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Car keeps dying when I come to a stop. speed_freak27 Normally Aspirated with bolt-on Forced Induction Powertrain 9 03-04-2005 04:05 AM
Greddy Type-s BOV...My car keeps dying??? WRX8U82 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 05-06-2004 09:25 AM
My car keeps dying MattDell Mid Atlantic Impreza Club -- MAIC 9 12-03-2002 09:37 PM
My car keeps dying MattDell Normally Aspirated Powertrain 2 12-01-2002 12:34 AM
Ok, my car keeps dying on me...what's up? Sauginius Southern California Impreza Club Forum -- SCIC 6 11-07-2000 12:01 AM


All times are GMT -4. The time now is 08:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.