Welcome to the North American Subaru Impreza Owners Club Saturday April 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-09-2007, 07:18 PM   #1
beauhawk
Scooby Newbie
 
Member#: 71019
Join Date: Sep 2004
Chapter/Region: South East
Vehicle:
2002 WRX
silver

Default Help with misfires

So my car was running terrible, bogging, sputtering,and missing as soon as I got on it. I couldn't even rev freely. Then it would clean up when boost came on. I noticed it was running very lean on low boost/hard throttle. I had a feeling it was the utec's fueling crossover, because the car ran fine at all other times. I also pulled misfire codes on all 4 cylinders. So I messed the the OL crossover, and cleared the ECU. The car runs MUCH smoother now, however I got misfires today on boost/upper rpm's, whereas before it was down low. I was wondering if anyone has any ideas to what this could be besides my utec being crapped out.
* Registered users of the site do not see these ads.
beauhawk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Any bored web designers out there want to help with a fun (quick turnaround) project? Asinine Off-Topic 16 06-04-2010 12:53 PM
Help with a Pioneer Navigation Unit joffre17 Vancouver Impreza Club Forum -- VIC 1 06-03-2010 05:54 PM
Anyone need help with an install? RubbleDTD Mid Atlantic Impreza Club -- MAIC 0 06-03-2010 05:23 AM
help with misfires near Plattsburgh NY? foxboroxt Tri-State Area Forum 7 06-07-2009 12:54 AM
Help me with misfires at idle rak328 Factory 2.0L Turbo Powertrain 4 10-29-2002 07:38 PM


All times are GMT -4. The time now is 06:30 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.