Welcome to the North American Subaru Impreza Owners Club Thursday May 5, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-10-2007, 12:24 PM   #1
mummer43
Scooby Specialist
 
Member#: 113985
Join Date: May 2006
Location: Alburtis, PA
Vehicle:
2006 Outback Sport
Steel Grey Metallic

Default Audible clicking when I turn on my lights

I just took my headlight bulbs out because there was some condensation inside the housing and after replacing them, there is an audible clicking when I turn my headlights on and when I engage the high beams. I comes from the area of the glove box, and it wasn't there prior.

Any ideas?

Edit: I just did a search and it seems as though this is normal? I never really noticed it before.
* Registered users of the site do not see these ads.
mummer43 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-10-2007, 12:31 PM   #2
SoobATV
Scooby Specialist
 
Member#: 6883
Join Date: May 2001
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
MY04 Foz XS
MY02 Imp TS

Default

Sounds like it's just a relay. You should be safe.
SoobATV is offline   Reply With Quote
Old 04-10-2007, 01:36 PM   #3
shadyrex
Scooby Specialist
 
Member#: 24540
Join Date: Sep 2002
Chapter/Region: Tri-State
Vehicle:
2015 WRX

Default

That's your headlight relay under the dash.
shadyrex is offline   Reply With Quote
Old 04-10-2007, 06:34 PM   #4
supernootz
Scooby Newbie
 
Member#: 138869
Join Date: Jan 2007
Location: Orange County, NY
Vehicle:
2007 Impreza Outback

Default

Yeah, man that thing is LOUD. I thought something might be wrong, too.
supernootz is offline   Reply With Quote
Old 04-11-2007, 05:22 PM   #5
mighty_hank
Scooby Newbie
 
Member#: 42473
Join Date: Aug 2003
Vehicle:
2004 WRX Wagon
WR Blue

Default Same here

I also get a noise sometimes when I turn on my headlights. It's a relay clicking sound from behind the glovebox. It also happens when I push my blinker stem to signal lane changes, and causes my headlights to flicker. I can cause the clicking by slowly turning on/off the headlight knob. The phenomenon is intermittent, and only happens for a short time every other month or so. Anyone know of or suspect a root cause?
mighty_hank is offline   Reply With Quote
Old 04-11-2007, 05:26 PM   #6
harrison88
Scooby Specialist
 
Member#: 127639
Join Date: Sep 2006
Chapter/Region: Tri-State
Location: washing the salt off my
Vehicle:
06 T REX No Rear
Cupholder :(

Default

i also get this click noise, i'm pretty sure it's just the headlight relay
nothing to worry about
harrison88 is offline   Reply With Quote
Old 04-11-2007, 10:36 PM   #7
Hank3
Scooby Guru
 
Member#: 16157
Join Date: Mar 2002
Chapter/Region: South East
Location: Tallahassee, FL
Vehicle:
'03 Mazda P5 <><
'02 WRX & '08 MS3 SOLD!!!

Default

It is the relay - no need to worry. It's perfectly normal for the Subarus.
Hank3 is offline   Reply With Quote
Old 04-12-2007, 12:46 PM   #8
mighty_hank
Scooby Newbie
 
Member#: 42473
Join Date: Aug 2003
Vehicle:
2004 WRX Wagon
WR Blue

Default

Well, mine is not so normal. It's triggers the relay like quick machine gun bursts, and the relay switching is visible as my headlights flick on and off. When I change lanes at night and signal with my blinker (pushing down the turn signal stalk also causes the flickering), the car in front of me gets to experience the headlight flashing in their rear view mirror. Again, this only happens for a brief period every couple months, and actually hasn't happened for a long time. The only normal thing about it is it always comes back.
mighty_hank is offline   Reply With Quote
Old 04-12-2007, 11:52 PM   #9
Handsdown
Scooby Guru
 
Member#: 29355
Join Date: Nov 2002
Chapter/Region: NWIC
Location: seattle
Default

i hear two relays go off with my harness. it's loud
Handsdown is offline   Reply With Quote
Old 04-13-2007, 12:30 PM   #10
SoobATV
Scooby Specialist
 
Member#: 6883
Join Date: May 2001
Chapter/Region: NESIC
Location: Manchester, NH
Vehicle:
MY04 Foz XS
MY02 Imp TS

Default

Quote:
Originally Posted by mighty_hank View Post
Well, mine is not so normal. It's triggers the relay like quick machine gun bursts, and the relay switching is visible as my headlights flick on and off. When I change lanes at night and signal with my blinker (pushing down the turn signal stalk also causes the flickering), the car in front of me gets to experience the headlight flashing in their rear view mirror. Again, this only happens for a brief period every couple months, and actually hasn't happened for a long time. The only normal thing about it is it always comes back.
You *may* have a bum headlight/signal switch. Happened to me with a few older cars.
SoobATV is offline   Reply With Quote
Old 04-13-2007, 05:59 PM   #11
mighty_hank
Scooby Newbie
 
Member#: 42473
Join Date: Aug 2003
Vehicle:
2004 WRX Wagon
WR Blue

Default

Yeah, I highly suspect it's the switch b/c when the phenomena is occurring, I can agitate it by slowly turning the headlight knob on and off, so the switch seems to be the trigger. Hasn't happened in a while, so I'm not too bugged out about it. It's got to be the first quality concern I've found with my Subie.
mighty_hank is offline   Reply With Quote
Old 07-21-2007, 02:27 AM   #12
Daggah
Scooby Newbie
 
Member#: 152077
Join Date: Jun 2007
Chapter/Region: International
Location: Incirlik AB, Turkey
Vehicle:
2002 Integra Type R
Championship White

Default

I'm having this issue as well. Is there an easy fix, or will Subaru fix it under warranty (mine's an '04 with less than 36,000 miles on it.)
Daggah is offline   Reply With Quote
Old 07-21-2007, 05:49 AM   #13
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Quote:
Originally Posted by Daggah View Post
I'm having this issue as well. Is there an easy fix, or will Subaru fix it under warranty (mine's an '04 with less than 36,000 miles on it.)
If your car is under warranty and the combination switch is bad, it should be covered unless you have modified your lights.
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clicking Noise when I turn on my heater. AK*WRX*2004 Electrical & Lighting 2 03-05-2005 02:45 PM
I smell gas when I turn on my heater DetroitWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 37 02-13-2004 03:11 AM
Kow how to keep the Instrament Cluster Clock from dimming when I turn on the Lights? Turk Interior & Exterior Modification 3 12-13-2000 05:57 PM

All times are GMT -4. The time now is 01:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.