Welcome to the North American Subaru Impreza Owners Club Thursday October 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-13-2007, 10:56 AM   #1
turboscooby13
Scooby Specialist
 
Member#: 56280
Join Date: Mar 2004
Chapter/Region: South East
Location: Mississippi
Vehicle:
2003 M3
Silver

Default vf34 and low idle

A week ago I swapped in a vf34, inj, and fp (thanks John!) and now I'm noticing that I'm idling a little low. I'm pretty sure I read on here that normal idle is around 750 (with a td04), but wasn't sure how a vf34 affected idle. Right now, I'm idling around 500 or just a knick below and the car is slightly shaking like it wants to cut out when standing still. Any suggestions as to what I need to do? Alternator? Pulley? Thanks for any help.

FWIW, engine mods include Cobb vf34 map, gutted uppipe, and Invidia turboback. Car has about 58000 miles and uses Mobil 1 10W30.
* Registered users of the site do not see these ads.
turboscooby13 is offline   Reply With Quote
Old 04-13-2007, 11:14 AM   #2
marcymarc
Scooby Specialist
 
Member#: 112861
Join Date: Apr 2006
Location: VA
Vehicle:
2013 STi sedan
SWP

Default

mine also idles right @ 500.. no biggie.
but also mine does not feel like its gonna stall, just a nice smooth idle. low, but smooth.
marcymarc is offline   Reply With Quote
Old 04-13-2007, 11:19 AM   #3
WRX Shenanigans
Scooby Specialist
 
Member#: 101378
Join Date: Nov 2005
Chapter/Region: MAIC
Location: VA
Vehicle:
2011 Sonata
Harbor Gray Metallic

Default

I'll bet with a degree of certainty you both are reading the gauge wrong....

It's common to think that middle line is 500rpm when really its 750rpm...

WRX Shenanigans is offline   Reply With Quote
Old 04-13-2007, 11:43 AM   #4
turboscooby13
Scooby Specialist
 
Member#: 56280
Join Date: Mar 2004
Chapter/Region: South East
Location: Mississippi
Vehicle:
2003 M3
Silver

Default

Quote:
Originally Posted by WRX Shenanigans View Post
I'll bet with a degree of certainty you both are reading the gauge wrong....

It's common to think that middle line is 500rpm when really its 750rpm...


I was reading that wrong. So if I am idling right at 750, what else might it be causing it to shake/ shimmy/ feel like its gonna stall?
turboscooby13 is offline   Reply With Quote
Old 04-13-2007, 12:02 PM   #5
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

your accesswhore.
sidewayz is offline   Reply With Quote
Old 04-13-2007, 12:09 PM   #6
turboscooby13
Scooby Specialist
 
Member#: 56280
Join Date: Mar 2004
Chapter/Region: South East
Location: Mississippi
Vehicle:
2003 M3
Silver

Default

What exactly does that mean?
turboscooby13 is offline   Reply With Quote
Old 04-13-2007, 12:13 PM   #7
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

lol.. 86 the Cobb crap. or if you must stick with it get it tuned.. the base maps suck hardcore
sidewayz is offline   Reply With Quote
Old 04-13-2007, 12:44 PM   #8
marcymarc
Scooby Specialist
 
Member#: 112861
Join Date: Apr 2006
Location: VA
Vehicle:
2013 STi sedan
SWP

Default

WoW.. good to know.. i guess that answers my Q about that one line being SOO low...
and yea, i read it wrong

and def get a protune.. when i had my 2.0, i was dynod at 242 with the OTS map.. pfff..
marcymarc is offline   Reply With Quote
Old 04-13-2007, 01:21 PM   #9
turboscooby13
Scooby Specialist
 
Member#: 56280
Join Date: Mar 2004
Chapter/Region: South East
Location: Mississippi
Vehicle:
2003 M3
Silver

Default

What's the closest place to Mississippi to get a protune and what is involved?
turboscooby13 is offline   Reply With Quote
Old 04-13-2007, 04:40 PM   #10
turboscooby13
Scooby Specialist
 
Member#: 56280
Join Date: Mar 2004
Chapter/Region: South East
Location: Mississippi
Vehicle:
2003 M3
Silver

Default

Just for anyone interested....

I had a problem with my injector leaking after the swap, so I undid some connections to make it easier to get to. After looking, I realized that I didn't attach the ground back in (the one just above the fuel rail on the drivers side that attaches to the manifold.) After re-attaching it, I cranked it and everything seems smooth now.

So to make a long story short: I'm a dolt who can install a turbo, injectors, and fuel pump, but can't remember to put the grounds back in.

Thanks for everybody's help, and I AM going to look into a ProTune.
turboscooby13 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Low idle while coming to a stop, ruff idle and plug install mishap??? Clzay Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 11 11-27-2006 09:03 AM
low idle and hesitation WTB coil pack flvimpreza Bay Area Impreza Club Forum -- BAIC 2 08-13-2005 07:54 PM
help me with my Start-up and low idle WRXskeet Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 06-14-2005 07:41 PM
Low Idle after FMIC and Intake install.. elsanto Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 12-15-2004 10:39 PM
low idle and car sputtering soobyfan Service & Maintenance 8 04-30-2004 09:47 AM


All times are GMT -4. The time now is 09:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.