Welcome to the North American Subaru Impreza Owners Club Friday October 9, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 12-16-2001, 12:57 PM   #1
Scooby Specialist
Member#: 2362
Join Date: Sep 2000
Location: South Carolina, USA
1999 Legacy Outback
Blue w/ Paint Chips & Mud

Default Need help fixing a ATF leak (xpost)

Sorry for the crosspost (I rarely do this). I'll have pictures up later but I would love to have some suggestions on what to do. I'd really like to fix this myself, but I may end up taking it to the dealer and spending a fortune in time and energy getting them to fix it properly.

* Registered users of the site do not see these ads.
remarcable is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
anyone want to help fix an uppipe leak? gingertooth Tri-State Area Forum 17 03-12-2007 06:19 PM
help just got a wrx need help fixing it up tsubaru02 Newbies & FAQs 9 02-14-2005 02:56 PM
Need helping fixing Espelir Exhaust leak. 4EVO2NV Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 10 10-12-2004 10:08 AM
Need help fixing TXS uppipe leak Blair Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 02-11-2004 07:05 PM
AC drain clogged....need help fixing jinx Legacy Forum 0 07-16-2001 01:30 PM

All times are GMT -4. The time now is 04:24 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.