Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-13-2007, 10:56 PM   #1
goldenej20child
Scooby Newbie
 
Member#: 90901
Join Date: Jul 2005
Chapter/Region: NWIC
Location: Washington State
Vehicle:
2002 Subaru WRX
Aspen White

Question Front Right Turning Signal Acting Up

Hey all,

Got a problem and wanted to see if anyone has some answers Anyways, here's the situation. Both my headlights work fine. When I signal left, the turn signal works and the in-cabin indicator blinks at normal speed. However, when I signal right, the in-cabin indicator blinks rapidly and the signal does not work. Weird thing is on the outside, instead of the turn signal blinking, the running light blinks instead. You would think it would be a burnt bulb but I replaced it and to no luck, same problem. Checked all the fuses, same problem. However, I swapped my right headlight with my left headlight and it still has the same problem on the same side but the other side works fine so I don't think it's the headlight assembly. Any ideas? Any help would be appreciated, thanks!
* Registered users of the site do not see these ads.
goldenej20child is offline   Reply With Quote
Old 05-14-2007, 12:21 AM   #2
goldenej20child
Scooby Newbie
 
Member#: 90901
Join Date: Jul 2005
Chapter/Region: NWIC
Location: Washington State
Vehicle:
2002 Subaru WRX
Aspen White

Default

Update, so I got a test light on the sockets, everything seems correct but the weird thing is if the bulbs aren't in the sockets, the blink like they are suppose to and the driving lights lights up and doesn't blink but once I put the driving light bulb in, it starts blinking, I have no idea, any help would be appreciated, thanks!
goldenej20child is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weak, slow right turn signal H2OSB Electrical & Lighting 1 03-11-2005 01:21 AM
Help: Right turn signal flashing twice as fast... Silver04DE Electrical & Lighting 10 09-09-2004 09:06 AM
impreza front right turn signal lamp White 2.5rs Private 'For Sale' Classifieds 0 07-30-2003 02:28 PM
Do your turn signals light up? bjteel Interior & Exterior Modification 3 04-15-2002 01:58 PM
Ugh...anyone have an extra front left turn signal? RallyGuy2k Texas Impreza Club Forum -- TXIC 8 02-17-2001 12:56 AM


All times are GMT -4. The time now is 08:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.