Welcome to the North American Subaru Impreza Owners Club Saturday November 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Canada Region Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Canada Region Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-19-2000, 08:18 PM   #1
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Burnaby, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Post Clutch in summer weather/heat

Ok, are you guys all experiencing similar to this:

My clutch felt very "light" today, compared to spring time say. Today was a rare ~17C deg. sunny all day. It felt like the clutch would only engage when the pedal was released almost all the way. The clutch is still good as new with only 23k km's on it.

Same thing goes for my stock shifter. Before I was getting pissed cause it felt too notchy I though my synchros were going but today it's as smooth as butta. Can anyone else relate? I just think my car is moody as hell.

K
* Registered users of the site do not see these ads.
Ken is offline   Reply With Quote
Old 06-20-2000, 01:47 AM   #2
Black TS
Scooby Newbie
 
Member#: 1296
Join Date: Apr 2000
Location: West Vancouver, BC, Canada
Post

Oh yeah Ken, I can relate to u. Mine does the exact samething. The clutch feels really lite on days that its really warm out and shifter feels really smooth too. yep mine does the exact same thing. I have only 15000 km my car. I'm wondering the samething too, is it normal that our cars do that?
hey does your clutch chatters too when its cold? cuz mine does. =(
going to go complain to the dealer about my clutch problem soon, but gotta find time to do it though. =(
Black TS is offline   Reply With Quote
Old 06-20-2000, 12:17 PM   #3
Ken
NASIOC Supporter
 
Member#: 34
Join Date: Jun 1999
Chapter/Region: VIC
Location: Burnaby, BC Canada
Vehicle:
2005 WRX STi
World Rally Blue

Post

Only chatters once in a blue moon, only when I start off in the morning, and I hardly give it any gas; sometimes I get it in reverse too, but again I don't give it a lot of gas. So I don't think I have that "serious" chatter problem. It would be nice if you could get the newest part# for the clutch which was supposed to help fix the chatter. Otherwise, can you say ACT?
Ken is offline   Reply With Quote
Old 06-21-2000, 05:26 PM   #4
Dave DD
Scooby Newbie
 
Member#: 686
Join Date: Dec 1999
Location: Ottawa
Vehicle:
2002 wrx
blue/black

Question

Mine does the same thing only 18000km.Also my timing belt tensioner needs to be replaced its making some loud knocking noise when the engine is cold,i thought i had a sticky valve.Dealer said that the check engine light would have come on which it did'nt so he said that it had to be the tensioner bcs he's seen the problem before.
18000km
Dave DD is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake and Clutch Pedal Sticking in Cold Weather alexk243 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 01-31-2008 10:52 AM
Stuck clutch pedal in cold weather? ASpec818 Transmission (AT/MT) & Driveline 4 12-26-2007 09:30 PM
clutch chatter more often in warmer weather six1five Transmission (AT/MT) & Driveline 1 04-02-2004 12:06 AM
('93-'01) Clutch "sticking" in cold weather Seeing StaRS Impreza Forum 11 02-11-2004 01:38 PM
Stiff brake and clutch feel in cold weather? banman Service & Maintenance 3 01-08-2004 04:37 AM


All times are GMT -4. The time now is 01:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.