Welcome to the North American Subaru Impreza Owners Club Monday July 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Proven Power Bragging

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-19-2007, 03:56 PM   #1
need2boost
Scooby Newbie
 
Member#: 118163
Join Date: Jun 2006
Location: 12.2@114MPH
Vehicle:
2006 EWG vf39 WRX
RA TRANNY

Default just got back from the track with my2006 TR

UPDATE!!!
the other night i ran at the track and was alot more happy with my results, I ran a 12.2@114 with a 1.89 60'

I used a little better launch by slipping until all the slack was out of the drivetrain then letting out on the clutch, not quite a drop.

My mods are
2006 Subaru TR
weighs in @3240 with me and a half tank of gas
vf39 turbo ported EWG with Tial 38mm and dump tube
XS power TMIC
Tsudo downpipe
HKS Hi-power Exhaust
APS 3" turbo inlet with Cobb SF intake
Cobb AcessPort tuned by PDX (mail-in tune)
Walbro 255
Vodoo III MBC @20psi
TGV deletes
ported and coated headers
* Registered users of the site do not see these ads.

Last edited by need2boost; 06-23-2007 at 07:23 PM. Reason: updated track times
need2boost is offline   Reply With Quote
Old 05-19-2007, 04:32 PM   #2
bren wrx
Scooby Guru
 
Member#: 59454
Join Date: Apr 2004
Chapter/Region: NESIC
Location: Worcester
Vehicle:
'10 E92 M3 M-DCT
brentuning.com/blog

Default

looks nice but that mail in tune probably doesnt liek some of your mods....like tgv delete and mbc at ptfb
bren wrx is offline   Reply With Quote
Old 05-19-2007, 04:46 PM   #3
06blksubwrx
Scooby Specialist
 
Member#: 109084
Join Date: Mar 2006
Chapter/Region: South East
Location: Oviedo, Fl
Vehicle:
06 VF39 WRX
12.50 @109.1 Sleeper

Default

Nice trap speed, good for mid to low 12's.
06blksubwrx is offline   Reply With Quote
Old 05-19-2007, 04:53 PM   #4
V6TurboTA
Scooby Guru
 
Member#: 9090
Join Date: Aug 2001
Location: < of Boston
Vehicle:
09 Forester Gump
02WRX->04STi->09Gump

Default

yeah the car is running great power wise. Once you get your 60' sorted out the car should be flying.

~v6
V6TurboTA is offline   Reply With Quote
Old 05-19-2007, 06:12 PM   #5
PaulRex
Scooby Guru
 
Member#: 12454
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: Vermont
Vehicle:
10 Toyota Taco
K8 SV650SF

Default

ACT or an Exedy clutch.. You dont need anything crazy as far as clutch discs go, but I know the exedy clutches like the organic one I have come with an uprated pressure plate and thats really whats going to help you.

Its possible you glazed your clutch launching it on the very first try and that ruined it for the whole night
PaulRex is offline   Reply With Quote
Old 05-19-2007, 07:04 PM   #6
need2boost
Scooby Newbie
 
Member#: 118163
Join Date: Jun 2006
Location: 12.2@114MPH
Vehicle:
2006 EWG vf39 WRX
RA TRANNY

Default

yeah my buddy in a 2006 EVO IX ran a 13.5@104 with just a MBC,Intake and cat-back exhaust, he also had a bad 60' time, his first run was a 13.88@67mph he hit his brakes bad, before the last cone
need2boost is offline   Reply With Quote
Old 05-19-2007, 09:02 PM   #7
reddevil
Scooby Guru
 
Member#: 64673
Join Date: Jun 2004
Chapter/Region: NWIC
Location: portland
Vehicle:
1990 Legacy wagon
goes 12.387 @ 116.5

Default

110 traps get me 12.6xx
reddevil is offline   Reply With Quote
Old 05-20-2007, 03:42 PM   #8
Phatron
Scooby Guru
 
Member#: 36033
Join Date: Apr 2003
Chapter/Region: SCIC
Location: Tuning Lab
Vehicle:
CEO PhatBottiTuning
2006 STi GTX3582 + Meth

Default

pump or race gas?

seems fast for pump.
Phatron is offline   Reply With Quote
Old 05-20-2007, 05:22 PM   #9
mcwop23
Scooby Newbie
 
Member#: 24589
Join Date: Sep 2002
Location: Jacksonville, FL
Vehicle:
1995 Mazda RX7
11.8@125 w/ LS2

Default

a good launch will put you at 12.3-12.4
mcwop23 is offline   Reply With Quote
Old 05-20-2007, 05:33 PM   #10
Sypher
Scooby Specialist
 
Member#: 106366
Join Date: Jan 2006
Chapter/Region: MAIC
Location: VA
Vehicle:
2006 WRX
Blue

Default

damn dude nice trapspeed with a better 60FT youde be running very low 12's
Sypher is offline   Reply With Quote
Old 05-21-2007, 11:30 AM   #11
need2boost
Scooby Newbie
 
Member#: 118163
Join Date: Jun 2006
Location: 12.2@114MPH
Vehicle:
2006 EWG vf39 WRX
RA TRANNY

Default

this was on pump 93oct,
my main problem right now is the top of 4th in my car is at 110@6700rpms+/- my rev limiter is at that so i need to raise that to about 7400rpms to trap higher. I don't see a problem with that since its the same motor that the 07 sti has.
The Trap is really what i care about " the beauty of the top end"
need2boost is offline   Reply With Quote
Old 05-21-2007, 12:09 PM   #12
kn0bby8
Scooby Specialist
 
Member#: 97644
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Back In NY
Vehicle:
2006 WRX
Black

Default

I have similar mods and trap anywhere from 109 to 111.6. Just like you I can't get a decent 60ft. The last time I was at the track my clutch glazed over pretty bad. I havn't been back since cause I can't afford to put a clutch in the car. I run into the same problems you are having clutch slips hard when trying to launch high in the rpms or the tires spin. When I launch a little lower in the rpms I bog. I got about 20 or so launches on the clutch and around 18000 on the clock.
kn0bby8 is offline   Reply With Quote
Old 05-21-2007, 12:54 PM   #13
06blksubwrx
Scooby Specialist
 
Member#: 109084
Join Date: Mar 2006
Chapter/Region: South East
Location: Oviedo, Fl
Vehicle:
06 VF39 WRX
12.50 @109.1 Sleeper

Default

Quote:
Originally Posted by kn0bby8 View Post
I have similar mods and trap anywhere from 109 to 111.6. Just like you I can't get a decent 60ft. The last time I was at the track my clutch glazed over pretty bad. I havn't been back since cause I can't afford to put a clutch in the car. I run into the same problems you are having clutch slips hard when trying to launch high in the rpms or the tires spin. When I launch a little lower in the rpms I bog. I got about 20 or so launches on the clutch and around 18000 on the clock.
I have the same exact problem, I glazed my clutch on the first run and it ruined the rest of the night. I can't get a good launch, my 60's are anywhere from 1.8 to 2.0, where they use to be 1.69 to 1.7.
06blksubwrx is offline   Reply With Quote
Old 05-21-2007, 01:19 PM   #14
PaulRex
Scooby Guru
 
Member#: 12454
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: Vermont
Vehicle:
10 Toyota Taco
K8 SV650SF

Default

Quote:
Originally Posted by kn0bby8 View Post
I have similar mods and trap anywhere from 109 to 111.6. Just like you I can't get a decent 60ft. The last time I was at the track my clutch glazed over pretty bad. I havn't been back since cause I can't afford to put a clutch in the car. I run into the same problems you are having clutch slips hard when trying to launch high in the rpms or the tires spin. When I launch a little lower in the rpms I bog. I got about 20 or so launches on the clutch and around 18000 on the clock.
ouch only 18,000miles.. if your on the stock clutch thats probably why. If you put in an Exedy Stage1 clutch, or comparable uprated clutch disc/pressure plate you'll probably get at least 25-30k out of it even if you do 50 passes at the track from my experience. Plus, if thats your first clutch and your first AWD car you've ever launched you are probably just better at doing it now and thats going to make it last longer anyway..
PaulRex is offline   Reply With Quote
Old 05-22-2007, 10:39 AM   #15
kn0bby8
Scooby Specialist
 
Member#: 97644
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Back In NY
Vehicle:
2006 WRX
Black

Default

Quote:
Originally Posted by PaulRex View Post
ouch only 18,000miles.. if your on the stock clutch thats probably why. If you put in an Exedy Stage1 clutch, or comparable uprated clutch disc/pressure plate you'll probably get at least 25-30k out of it even if you do 50 passes at the track from my experience. Plus, if thats your first clutch and your first AWD car you've ever launched you are probably just better at doing it now and thats going to make it last longer anyway..
To the OP sorry for the highjack...I aint sure if my clutch is shot but it glazed over pretty good the last time i went to the track...so i am afraid to take it back casue i can't afford to do a clutch now.
kn0bby8 is offline   Reply With Quote
Old 05-22-2007, 10:40 AM   #16
kn0bby8
Scooby Specialist
 
Member#: 97644
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Back In NY
Vehicle:
2006 WRX
Black

Default

Quote:
Originally Posted by 06blksubwrx View Post
I have the same exact problem, I glazed my clutch on the first run and it ruined the rest of the night. I can't get a good launch, my 60's are anywhere from 1.8 to 2.0, where they use to be 1.69 to 1.7.

I would be happy with a 1.8. It would put me in the 12.5 range on most of my passes.
kn0bby8 is offline   Reply With Quote
Old 05-22-2007, 01:32 PM   #17
need2boost
Scooby Newbie
 
Member#: 118163
Join Date: Jun 2006
Location: 12.2@114MPH
Vehicle:
2006 EWG vf39 WRX
RA TRANNY

Default

Quote:
Originally Posted by kn0bby8 View Post
To the OP sorry for the highjack...I aint sure if my clutch is shot but it glazed over pretty good the last time i went to the track...so i am afraid to take it back casue i can't afford to do a clutch now.
yeah my last run of the night i slipped the clutch out and when i released the clutch pedal the clutch kept slipping all the way in first, It Glazed over pretty bad and when i take off normal it jerks a little in first, not sure if it's going to be toasted or not. I've got 16000 miles on the clock and have had this setup for about 10,000 miles except for the PDX tune.
need2boost is offline   Reply With Quote
Old 05-22-2007, 01:37 PM   #18
kn0bby8
Scooby Specialist
 
Member#: 97644
Join Date: Oct 2005
Chapter/Region: Tri-State
Location: Back In NY
Vehicle:
2006 WRX
Black

Default

Quote:
Originally Posted by need2boost View Post
yeah my last run of the night i slipped the clutch out and when i released the clutch pedal the clutch kept slipping all the way in first, It Glazed over pretty bad and when i take off normal it jerks a little in first, not sure if it's going to be toasted or not. I've got 16000 miles on the clock and have had this setup for about 10,000 miles except for the PDX tune.
Shoot me a PM if you ever make it back to the track. I am dying to go back but am in fear that I will toast the clutch. The symptoms you are having are exactly the same as mine. If you track the car again and it is fine I am definatly heading back!
kn0bby8 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got back from the track -04 STi Stage2 or So!! Benchmark Tuning Proven Power Bragging 50 10-10-2008 05:15 PM
just got back from the track royalking87 Newbies & FAQs 6 08-20-2006 12:05 AM
just got back from the track... LatentWagen Tri-State Area Forum 12 05-30-2004 09:07 PM
Just got back from the track... sdogg3kgt Off-Topic 3 05-15-2004 10:45 PM
Just got back from the track Big Turkey Texas Impreza Club Forum -- TXIC 5 09-19-2003 03:29 PM


All times are GMT -4. The time now is 07:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.