Welcome to the North American Subaru Impreza Owners Club Friday July 11, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
North West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > North West Impreza Club Forum -- NWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-19-2001, 09:25 PM   #1
knight
Scooby Newbie
 
Member#: 11093
Join Date: Oct 2001
Location: Bellevue, WA
Vehicle:
2002 WRX Sedan
Platinum Silver

Default DMS on the way - but need help with install

Hello all -

I've been wondering if anyone can recommend a good shop that takes care of our aftermarket Subaru installs. I've got a couple mods coming up, namely the DMS golds and I'm not confident nor do I have the tools to install them.

Or if anyone does work themselves - I'd love to hear about it.

Thanks.

Knight
* Registered users of the site do not see these ads.
knight is offline   Reply With Quote
Old 12-19-2001, 10:03 PM   #2
david2z4
Scooby Specialist
 
Member#: 1838
Join Date: Jul 2000
Chapter/Region: NWIC
Location: WA
Vehicle:
2000 Impreza RS BRP
Vishnu Turbo/Tec3

Default

I've installed 5 sets now maybe I can help.

give me a pm.
david2z4 is offline   Reply With Quote
Old 12-19-2001, 11:46 PM   #3
cfwdfw
Scooby Specialist
 
Member#: 5046
Join Date: Mar 2001
Location: Olympia, WA, USA
Vehicle:
'97 Legacy gt 5 spd
Deep Saphire Blue Sedan

Default

Hi Knight,

If you ordered them through Dave Clark ... his shop is just south of SouthCenter ... I would suggest you consider working with him on the install ... course ... it might take a while to catch him depending upon his schedule ... ... but he knows what he's doing !!!!

I'm sure you would learn a lot from working with him on the install ... and be prepared for the test drive afterwards ... ... depending of course upon time of day and his schedule ...

I certianly learned a few things when we did my legacy ... and suffice it to say ... I'm very pleased with my DMS golds ... and STi top mounts ...

course if David is willing ... that would work too ...


Charlie
cfwdfw is offline   Reply With Quote
Old 12-20-2001, 12:06 AM   #4
Austin
Scooby Guru
 
Member#: 7089
Join Date: May 2001
Chapter/Region: NWIC
Location: Western Wa
Default

Hey Dave, being that you're such a pro...

I installed my DMS Golds with cusco camber plates front and rear. I know camber plates are supposed to make some noise, but my rear passenger coilover makes a *monster* clank... not just the click click of pillow ball mounts, but a big clank, and it's only the rear passenger side. The other three corners make noise, but it's more the metal on metal sound of pillow ball mounts, and not very loud... I've not contacted Dave about this yet... This sound normal to you?
Austin is offline   Reply With Quote
Old 12-20-2001, 12:20 AM   #5
david2z4
Scooby Specialist
 
Member#: 1838
Join Date: Jul 2000
Chapter/Region: NWIC
Location: WA
Vehicle:
2000 Impreza RS BRP
Vishnu Turbo/Tec3

Default

Austin, Could be all the parts were not seated and after a drive they are now loose.

Also the one side could be at a different angle and the top perch is hitting the top mount. Don't know how much clearance there is with the cusco mounts.

I PM'ed you.
david2z4 is offline   Reply With Quote
Old 12-20-2001, 01:09 AM   #6
knight
Scooby Newbie
 
Member#: 11093
Join Date: Oct 2001
Location: Bellevue, WA
Vehicle:
2002 WRX Sedan
Platinum Silver

Default

Dave - I pm'd you.

Charlie - Thanks for the info....
knight is offline   Reply With Quote
Old 12-20-2001, 12:44 PM   #7
Austin
Scooby Guru
 
Member#: 7089
Join Date: May 2001
Chapter/Region: NWIC
Location: Western Wa
Default

Quote:
Originally posted by david2z4
Don't know how much clearance there is with the cusco mounts.
There *should* be ample clearance... I'll take the back seat out and retorque everything again once I get back to Washington. I need to get it done before the 27th, I've got an appt at Fordahl for four wheel alignment/weight balancing.
Austin is offline   Reply With Quote
Old 12-20-2001, 01:32 PM   #8
david2z4
Scooby Specialist
 
Member#: 1838
Join Date: Jul 2000
Chapter/Region: NWIC
Location: WA
Vehicle:
2000 Impreza RS BRP
Vishnu Turbo/Tec3

Default

Austin, also make shure the spacer washer that goes between the pearch and top mount is the correct size and that there is no movement in the top mount center hole. Mine was sent with the wrong ones. At the DMS factory there are two "spacer" bins side by side and they just grabbed into the wrong bin when they packed my kit. The two almost look identical, one just has a different diameter.

who knows there may be 10 bins with different sizes. Also maybe the WRX setup doesn't use the same spacer due to the different top mount configuration.
david2z4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need help with install on 09 wrx last lemming alive AccessPort 3 01-04-2010 08:55 PM
Planning on running 300+ WHP, but need help with supporting mods! DJS_02_WRX Newbies & FAQs 77 10-18-2009 12:39 PM
Need help with installing replacement OEM rear springs on '99 OBS Ski4Ever Impreza Forum 0 06-26-2009 04:36 PM
Need help with installing gauges on A-pillar maxpower_454 Interior & Exterior Modification 1 07-06-2005 01:08 AM
Need help with install on used aps tmic hybrid gti 2 Factory 2.0L Turbo Powertrain 5 06-14-2005 09:36 PM


All times are GMT -4. The time now is 02:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.