Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-25-2001, 10:02 AM   #1
Heavy Fuji
Scooby Newbie
 
Member#: 5536
Join Date: Apr 2001
Location: Fingerlakes
Vehicle:
'11 Tundra

Default odd sensation at 2500 rpm

This might belong in "Factory Forced Induction" but here goes...

When decelerating, specifically engine braking (ie no application of the brakes) I notice that at around 2,500 rpms I experience this weird feeling like something is disengaging in the driveline. It isn't a violent phenomenon; rather like an overdrive kicking in-- except I have a manual! It almost feels like the engine cuts out momentarily but that's not really accurate...any thoughts/ similar findings? Probably falls under the larger heading of driveline lash...
* Registered users of the site do not see these ads.
Heavy Fuji is offline   Reply With Quote
Old 12-25-2001, 11:50 AM   #2
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

my RS does it, especially in first gear...
I say its normal

Jay McDade
Subaru Tech
www.hometown.aol.com/impreza25rs2000
munkis is offline   Reply With Quote
Old 12-25-2001, 01:59 PM   #3
Shizz-nida
Scooby Newbie
 
Member#: 11491
Join Date: Oct 2001
Location: Aurora, IL
Vehicle:
1992 Plymouth Laser
Burned Clearcoat Black

Default

Mine does this as well. Its been into the shop for another non-related problem and they drove it and didn't mention anything out of sorts. I'd imagine its normal.

Yoshi
Shizz-nida is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine vibration at 2500 RPM flatlander4510 Normally Aspirated Powertrain 4 11-20-2007 09:49 AM
HELP! Car stumbling at 2500 RPMS (STi)! Optimus Prime Factory 2.5L Turbo Powertrain 9 02-03-2005 10:02 AM
Whining or Spooling Noise at 2500 RPM in fourth gear? ImportVenom Newbies & FAQs 12 05-22-2003 10:58 PM
Boost at 2500 RPMs ?? Rally Punx Factory 2.0L Turbo Powertrain 12 05-22-2003 12:25 AM
car bogs at 2500 rpm KINGSKY Subaru Conversions 20 05-20-2003 06:43 PM


All times are GMT -4. The time now is 10:38 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.