Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-06-2007, 06:05 AM   #1
SubieRX
Scooby Specialist
 
Member#: 16611
Join Date: Mar 2002
Chapter/Region: SCIC
Location: Irvine, CA
Vehicle:
05' STi w/ meth inj
Tuned By Harman Motive

Default Trouble starting car...

Just a few days ago, I started having trouble starting the car. I doubt it has anything to do with the battery because the car turns over just fine when it does decide to start. Its never NOT started before... yet. Its just that it seems like I have to push the clutch alllll the way down to the floor before it will turn over. Before I only had to push the clutch in a little bit to get the car to start.

Anyone else have this problem or have any insight into what this could be? I haven't done any recent electrical mods so I'm at a loss to explain where this issue could have arisen from. TIA.
* Registered users of the site do not see these ads.
SubieRX is offline   Reply With Quote
Old 06-06-2007, 08:04 PM   #2
jflexe99
Scooby Specialist
 
Member#: 145303
Join Date: Apr 2007
Chapter/Region: Tri-State
Location: PA
Vehicle:
2007 WRX TR
Crystal Metalic

Default

Bring it to the dealer if you can...
jflexe99 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble Starting car!!!! Zondacl2 Factory 2.5L Turbo Powertrain 12 11-01-2008 05:23 PM
Having trouble starting car scoobyimprza Subaru Conversions 16 02-04-2006 07:46 PM
trouble starting car yuletak Service & Maintenance 1 01-23-2006 04:34 PM
Trouble starting car crazy_sherm Newbies & FAQs 11 08-12-2003 03:26 PM
TecII Installed. Trouble starting Car Revision Normally Aspirated with bolt-on Forced Induction Powertrain 21 04-10-2003 08:51 AM


All times are GMT -4. The time now is 02:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.