Welcome to the North American Subaru Impreza Owners Club Thursday July 10, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-25-2007, 01:44 PM   #1
Okeyd57
Scooby Newbie
 
Member#: 113271
Join Date: Apr 2006
Chapter/Region: MAIC
Location: Beaver, W.V.
Vehicle:
2006 STi
Obsidian Black Pearl

Default Hard to fuel up after fuel pump upgrade ! Any ideas ?

I had a Walbro fuel pump installed in my 06 STi last fall. Ever since then I have had to pump fuel at a slow rate. It's worse when it's hot out. Could I have a vent line pinched ? Has anyone ever seen this happen before ?

Thanks for any ideas ! Okey


I just realized this is in the 2.0 forum instead of the 2.5 forum ! Please move it for me. Thanks
* Registered users of the site do not see these ads.
Okeyd57 is offline   Reply With Quote
Old 06-25-2007, 08:45 PM   #2
Okeyd57
Scooby Newbie
 
Member#: 113271
Join Date: Apr 2006
Chapter/Region: MAIC
Location: Beaver, W.V.
Vehicle:
2006 STi
Obsidian Black Pearl

Default

Bump. Anybody ?
Okeyd57 is offline   Reply With Quote
Old 06-26-2007, 10:42 AM   #3
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

what do you mean you have to pump at a slow rate?

what happens if you pump at a fast rate?
ride5000 is offline   Reply With Quote
Old 06-26-2007, 12:47 PM   #4
marcymarc
Scooby Specialist
 
Member#: 112861
Join Date: Apr 2006
Location: VA
Vehicle:
2013 STi sedan
SWP

Default

Quote:
Originally Posted by ride5000 View Post
what do you mean you have to pump at a slow rate?

what happens if you pump at a fast rate?
2nd that does it overflow?
marcymarc is offline   Reply With Quote
Old 06-26-2007, 12:55 PM   #5
Okeyd57
Scooby Newbie
 
Member#: 113271
Join Date: Apr 2006
Chapter/Region: MAIC
Location: Beaver, W.V.
Vehicle:
2006 STi
Obsidian Black Pearl

Default

Quote:
Originally Posted by ride5000 View Post
what do you mean you have to pump at a slow rate?

what happens if you pump at a fast rate?
I mean I have to pump the fuel slowly. If I try to pump it fast it cuts off. It will not take fuel from the pump with the lever squeezed all the way ! I have to barely squeeze the lever to keep it from cutting off. Is that any plainer ?
Okeyd57 is offline   Reply With Quote
Old 06-26-2007, 01:03 PM   #6
ride5000
Scooby Guru
 
Member#: 32792
Join Date: Feb 2003
Chapter/Region: NESIC
Location: lincoln, ri
Vehicle:
2003 GGA MBP
12.9 / 105+

Default

what happens if you lift the nozzle partially out of the filler neck before triggering? don't pull it out past the trapdoor in the filler, though.
ride5000 is offline   Reply With Quote
Old 06-26-2007, 01:25 PM   #7
99subi
Scooby Guru
 
Member#: 78118
Join Date: Dec 2004
Chapter/Region: Tri-State
Location: Westchester NY
Vehicle:
2002 Corvette coupe
05 Legacy

Default

Quote:
Originally Posted by Okeyd57 View Post
I mean I have to pump the fuel slowly. If I try to pump it fast it cuts off. It will not take fuel from the pump with the lever squeezed all the way ! I have to barely squeeze the lever to keep it from cutting off. Is that any plainer ?
everynow and then i get that.
99subi is offline   Reply With Quote
Old 06-26-2007, 01:34 PM   #8
marcymarc
Scooby Specialist
 
Member#: 112861
Join Date: Apr 2006
Location: VA
Vehicle:
2013 STi sedan
SWP

Default

that happens to me ALOT.. but i notice its only at 1 of the pumps i use.
i think its the gas station's actual pump, and not your car.

or does it do this at EVERY pump you go to?
marcymarc is offline   Reply With Quote
Old 06-26-2007, 01:43 PM   #9
jargon
Scooby Newbie
 
Member#: 107150
Join Date: Feb 2006
Chapter/Region: TXIC
Default

Quote:
Originally Posted by marcymarc View Post
that happens to me ALOT.. but i notice its only at 1 of the pumps i use.
i think its the gas station's actual pump, and not your car.

or does it do this at EVERY pump you go to?
It's the gas station's pump and has nothing to do with your car. Certain gas pumps are set up to cut off if you don't use quite a bit of downforce on the nozzle. Yes, it's retarded. Some stations don't have it; these are the ones that I like to frequent. Filling up a motorcycle tank is a b*tch using some new style pumps.
jargon is offline   Reply With Quote
Old 06-26-2007, 03:56 PM   #10
Okeyd57
Scooby Newbie
 
Member#: 113271
Join Date: Apr 2006
Chapter/Region: MAIC
Location: Beaver, W.V.
Vehicle:
2006 STi
Obsidian Black Pearl

Default

Quote:
Originally Posted by kwright69_02 View Post
It's the gas station's pump and has nothing to do with your car. Certain gas pumps are set up to cut off if you don't use quite a bit of downforce on the nozzle. Yes, it's retarded. Some stations don't have it; these are the ones that I like to frequent. Filling up a motorcycle tank is a b*tch using some new style pumps.
Mine does it at EVERY pump I use. I never had any problem so to speak of, before the fuel pump upgrade. Isn't there a vent somewhere that allows the air to escape while fueling ? I'm convinced that's where my problem lies, but I need to know how to repair it.

It's hard to believe I'm the only person that this ever happened to when changing fuel pumps, but then again, that would be just my luck ! It's just a matter of the right person reading this to help me out ! Thanks again, Okey
Okeyd57 is offline   Reply With Quote
Old 06-26-2007, 04:43 PM   #11
StarDogChampion
Scooby Specialist
 
Member#: 10276
Join Date: Sep 2001
Vehicle:
2001 Impreza RS
2002 WRX, 2012 535i

Default

the fuel pump its self is not to blame. go in your trunk and remove the fuel pump cover to see if anything is pinched if you want, but that should not affect filling up the tank. might just be coincidence..
StarDogChampion is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
fuel starvation after new pump install jlam86 Factory 2.0L Turbo Powertrain 22 06-07-2008 06:18 AM
anyone in Marlyand area know how to wire up a fuel pump controller? simprezl25 Mid Atlantic Impreza Club -- MAIC 8 06-25-2006 05:15 PM
Very strange noise after shutting car off... any ideas? OttawaSTi Factory 2.5L Turbo Powertrain 3 01-14-2005 09:16 PM
car smokes after driving a while, any ideas? verc Factory 2.0L Turbo Powertrain 15 07-02-2004 12:41 PM
Turbo upgrading.. any ideas??? k_thaosta Newbies & FAQs 1 07-18-2002 09:34 AM


All times are GMT -4. The time now is 10:59 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.