Welcome to the North American Subaru Impreza Owners Club Saturday March 28, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-11-2007, 08:43 PM   #1
Aspenbullet
Scooby Newbie
 
Member#: 71240
Join Date: Sep 2004
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2002 WRX Cobb Stg II
Aspen White w/Yakima Rack

Question Headlights flicker when turn signal is applied

As the the title of the thread says, my headlights flicker when I engage the turn signals. I've found that there is a little bit of play in the switch used to turn on the headlights so when I use my turn signals, the headlight switch jiggles and the lights flicker. When the lights flicker I notice a clicking from the glove box area too.

This is on a 2002 WRX where the headlight switch is a knob at the end of the turn signal arm that you twist and there is just a bit of play when the lights are on. I can also get the lights to flicker if I turn on the lights and then rotate the switch that little extra movement that the switch has.

Sorry for the long story...I hope this is kind of clear.

Anyone have this experience or know how to fix it? Would I just need to replace the turn signal arm or does this sound like an electrical problem?

Thanks for any help.
* Registered users of the site do not see these ads.
Aspenbullet is offline   Reply With Quote
Old 07-11-2007, 09:02 PM   #2
silver2004impreza
Scooby Newbie
 
Member#: 127878
Join Date: Oct 2006
Chapter/Region: MAIC
Location: Front Royal
Vehicle:
2004 Impreza 2.5TS
2004 Outback sedan H6

Default

It's possible that it's an electrical problem, although it's unlikely. You should be able to simply replace the turn signal/headlight multi-function switch and be good to go.

Your best bet would be to take it to a dealer and have them diagnose it for you. Just because you bring your car there doesn't mean that they have to do the repair work. It's actually not that difficult a job to do yourself.
silver2004impreza is offline   Reply With Quote
Old 07-12-2007, 10:21 PM   #3
SUBYS R US
Scooby Specialist
 
Member#: 99591
Join Date: Oct 2005
Chapter/Region: RMIC
Location: Layton,UT
Vehicle:
2003 18g w/38EWG
PSM(siver)

Default

Mine does the same thing but i have no idea what it is. Did you figure it out?
MIke
SUBYS R US is offline   Reply With Quote
Old 07-12-2007, 11:00 PM   #4
CGM/WRX
Scooby Newbie
 
Member#: 87133
Join Date: May 2005
Chapter/Region: SCIC
Location: SoCal
Vehicle:
2005 M7760/V-Mount
Crystal Grey Metallic

Default

I agree with silver2004impreza I used to work at a dealership and the multi-function switches would always go out just from age and use. good luck
CGM/WRX is offline   Reply With Quote
Old 07-14-2007, 08:02 PM   #5
Aspenbullet
Scooby Newbie
 
Member#: 71240
Join Date: Sep 2004
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2002 WRX Cobb Stg II
Aspen White w/Yakima Rack

Default

I haven't figured it out yet but then again I haven't had time. I'm guessing I'll need a new turn signal "wand" with a new light switch.
Aspenbullet is offline   Reply With Quote
Old 07-14-2007, 08:24 PM   #6
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

It's the "combination switch".
Mulder is offline   Reply With Quote
Old 07-16-2007, 03:46 AM   #7
jc54 wrc
Scooby Newbie
 
Member#: 154119
Join Date: Jul 2007
Chapter/Region: South East
Location: Gulf Coast, US
Vehicle:
2002 WRX Wagon
WR Blue/mud

Default

My '02 Wagon was doing the same thing. It got to the point where they flickered when I indicated a turn, and everytime I would tap the brakes. Eventually, after trying everything else, I replaced the connections on the battery. I replaced them with brass connections for marine use, and the problem was solved. Looking at the stock connections, they were pretty corroded and there's only a small bit that actually touches the battery anyway. Try that and see if it helps.
jc54 wrc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
headlight flicker when turn signal used STIckySTIfee Electrical & Lighting 13 07-10-2010 02:04 PM
Headlights cut out when turn signal engaged..? STIckySTIfee Electrical & Lighting 2 08-17-2009 11:47 PM
Headlights flickering when using turn signals Honest Bob Electrical & Lighting 0 04-05-2009 08:10 PM
lights flicker with turn signals JBravo920 Electrical & Lighting 18 03-27-2006 01:41 PM
needle on gauge moves when turn signal is on Rickyh Electrical & Lighting 2 11-23-2003 11:22 PM


All times are GMT -4. The time now is 07:10 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.