Welcome to the North American Subaru Impreza Owners Club Tuesday June 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-12-2007, 02:14 PM   #1
bradal
Scooby Newbie
 
Member#: 109522
Join Date: Mar 2006
Chapter/Region: W. Canada
Location: EDMONTON, alberta
Vehicle:
2005 2.5rs
metallic gray

Default CEL and cruise not working/ now speedo

Hello All,

I have a 2005 impreza 2.5rs. Driving down the highway and the CEL comes on and the cruise kicks out. I have read the cruise will kick out whenever there is a CEL condition. Well I have left this for a while, and now the speedometer quit. I can't get into the service department as they are super busy, and not for another week. Any ideas???
* Registered users of the site do not see these ads.
bradal is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-12-2007, 06:11 PM   #2
Hondaslayer
think you
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default

Quote:
Originally Posted by bradal View Post
Hello All,

I have a 2005 impreza 2.5rs. Driving down the highway and the CEL comes on and the cruise kicks out. I have read the cruise will kick out whenever there is a CEL condition. Well I have left this for a while, and now the speedometer quit. I can't get into the service department as they are super busy, and not for another week. Any ideas???
Probably a speed sensor 2 code.

Speed sensor 2 is in the speedo head and will trigger an engine light, and obviously the speedo ain't gonna work.

-Ben
Hondaslayer is offline   Reply With Quote
Old 07-12-2007, 06:13 PM   #3
bradal
Scooby Newbie
 
Member#: 109522
Join Date: Mar 2006
Chapter/Region: W. Canada
Location: EDMONTON, alberta
Vehicle:
2005 2.5rs
metallic gray

Default

Wouldn't that cause all of this to happen at once?
bradal is offline   Reply With Quote
Old 07-12-2007, 06:24 PM   #4
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

Very good possibility
blackfang is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Did a little work, CEL and cruise flashing some dude Newbies & FAQs 6 03-01-2010 06:46 AM
96 Legacy Cruise not working pmaryan Transmission (AT/MT) & Driveline 2 09-24-2008 08:39 PM
cruise not working, will I be able to see why with enginuity or ecuflash? shipjumper Open Source Reflashes 3 01-05-2008 06:35 PM
Cruise not working! bfodle Electrical & Lighting 4 10-11-2004 02:29 PM
Help STi cel and cruise light Wagonboy STi Forum Archive 1 06-07-2003 01:06 AM


All times are GMT -4. The time now is 02:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.