Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-13-2007, 11:13 AM   #1
2000GTB
Scooby Newbie
 
Member#: 20800
Join Date: Jul 2002
Location: NJ
Vehicle:
2000 Legacy GT Wagon
White

Default TPS % on a STI swap?

I have a STI swap in my BH5 and when I checked the TPS on scanner.. at Idle it is at 14% and at full throttle, it does not pass 78.8%... anybody has experience with this or know a quick fix... Ive already done the obvious (adjusted the TPS, pedal etc.)

Also P1446, emission control CEL.. what do I have to do to fix it. If its replacing parts, where is this located..

Thanks in Advance

Kahlee
* Registered users of the site do not see these ads.
2000GTB is offline   Reply With Quote
Old 07-13-2007, 12:56 PM   #2
Chav
Scooby Specialist
 
Member#: 3269
Join Date: Dec 2000
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2001 2.5RS Sedan STM
RSTi

Default

I noticed the same thing in a regular obd2 reader, but when i used ECUexplorer it read all the way up to %99.67.

You can use an openport cable with ECUflash to download your ECU's rom. Then edit it with Enginuity to turn off the CEL for p1446 and then reflash it to the ECU.

-Chav
Chav is offline   Reply With Quote
Old 07-13-2007, 01:04 PM   #3
2000GTB
Scooby Newbie
 
Member#: 20800
Join Date: Jul 2002
Location: NJ
Vehicle:
2000 Legacy GT Wagon
White

Default

thanks, alot... the cel, do you know who can do this...

Kahlee
2000GTB is offline   Reply With Quote
Old 07-13-2007, 02:24 PM   #4
Chav
Scooby Specialist
 
Member#: 3269
Join Date: Dec 2000
Chapter/Region: SCIC
Location: San Diego
Vehicle:
2001 2.5RS Sedan STM
RSTi

Default

You can do it with some research.

cable can be bought here.
http://www.tactrix.com/

and you can google ECUflash, and Enginuity.

As far as tuners that can do it. Anybody that tunes using the OpenECU method will be able to.

-Chav
Chav is offline   Reply With Quote
Old 07-13-2007, 10:17 PM   #5
SubeSTIle
Scooby Specialist
 
Member#: 80736
Join Date: Feb 2005
Chapter/Region: SWIC
Location: West Valley, AZ
Vehicle:
1999 FXT White
E85 is for girls

Default

pm treefrogaz he tunes here in phoenix.
SubeSTIle is offline   Reply With Quote
Old 07-14-2007, 02:21 AM   #6
subbyspeed
Scooby Specialist
 
Member#: 16274
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Columbus,OH
Vehicle:
2001 GM6 2.0L vf30
e30 black/rust

Default

I've got a thread on how to get rid of the 1446 code. It does work. Although you have to interpret the wiring for your own setup.

As far as the TPS percentages.. Thats totally normal. A car @ idle will typically be between 10-15%, and full throttle is usually below 85%. The numbers you put up are absolutely on par with just about every car i've seen.
subbyspeed is offline   Reply With Quote
Old 07-15-2007, 03:56 AM   #7
2000GTB
Scooby Newbie
 
Member#: 20800
Join Date: Jul 2002
Location: NJ
Vehicle:
2000 Legacy GT Wagon
White

Default

You guys have been very helpful.... thanks and ill try to do all this on my own... but if anyone close to Jersey could do it let me know... Dont have that much spare time anymore...

Kahlee
2000GTB is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help with Cruise Control on an STI swap pezcore Interior & Exterior Modification 20 05-10-2010 02:17 PM
I've decided on an STI swap... Dirty D Newbies & FAQs 4 10-01-2007 07:20 PM
TGV sensor the same as TPS sensor on 04 STi?? Clark Kent Factory 2.5L Turbo Powertrain 7 10-20-2006 10:25 PM
Which wire for TPS signal on 04 STI B136 17 or 18 roybfr Factory 2.5L Turbo Powertrain 1 06-25-2006 09:34 PM
Gauging interest on V7 STi Swap in 02WRX Pepo New England Impreza Club Forum -- NESIC 7 08-08-2005 10:40 AM


All times are GMT -4. The time now is 05:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.