Welcome to the North American Subaru Impreza Owners Club Monday July 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-02-2002, 01:29 PM   #1
outback bosco
Scooby Newbie
 
Member#: 12075
Join Date: Nov 2001
Location: Garage, messing w/the XTs
Vehicle:
2K OBS blue/silver
Lobotomized 86 & 87 XT

Lightbulb headlights flickering

I am having a problem with my headlights on my 2k OBS

When I use the turn signals or hit the high beam, the lights sometimes turn off. Happened while I was driving back from the mountains on a really twisty road. Good thing I had driving lights on too.

But anyone ever have this happen to them? Is the turn signal/light switch messed up?

BW
* Registered users of the site do not see these ads.
outback bosco is offline   Reply With Quote
Old 01-02-2002, 08:19 PM   #2
stikboy
Scooby Newbie
 
Member#: 6697
Join Date: May 2001
Chapter/Region: MWSOC
Location: Cowpie, WI
Vehicle:
2011 WRX 5-door
Look-At-Me Red

Default not a problem

my car did this at first when i got it. you probably are just accidentally rotating the light switch when you use the brights or turn signal. you just have to be careful when you do either. if you are sure that this isn't it. get your car in immediately, this is a dangerous problem.

stikboy
stikboy is offline   Reply With Quote
Old 10-18-2005, 02:05 AM   #3
Impreza_RX
Scooby Newbie
 
Member#: 68015
Join Date: Aug 2004
Chapter/Region: NWIC
Location: WA
Vehicle:
2006 WRX TR
Steel Gray Metallic

Default

I know this is a very old post, but has anyone else experienced this problem as well? I'm getting the same problem and just want to know if there are others that are having the same issue. Thanks
Impreza_RX is offline   Reply With Quote
Old 10-18-2005, 02:27 PM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

This is usually caused by a bad combination switch.
Mulder is offline   Reply With Quote
Old 10-19-2005, 07:38 AM   #5
robsgotit
Scooby Newbie
 
Member#: 59674
Join Date: Apr 2004
Chapter/Region: Tri-State
Location: hudson valley ny
Vehicle:
06 06/2.5i 03/1.8t
there silver

Default

my 01 forester does that constantly, as were my 02 rs doesnt evr do it,
i think my switch is just worn, but if your car is new its probly just driver error, (no offence) its a dumb design
robsgotit is offline   Reply With Quote
Old 10-20-2005, 10:58 AM   #6
blackie
Scooby Specialist
 
Member#: 42979
Join Date: Sep 2003
Location: houston tx
Vehicle:
03 wrx
blizzzack stage IV

Default

my 03 wrx does that too!! it seems like their is a bad conection in the blinker stalk switch. but other times it will be fine, so im still confused on what it can be, i can hear the relay clicking louding behind the glove box whenever its acting up. any ideas??
blackie is offline   Reply With Quote
Old 12-06-2005, 08:54 PM   #7
japakazol
Scooby Specialist
 
Member#: 67831
Join Date: Aug 2004
Chapter/Region: SCIC
Location: Van Nuys, CA 91405
Vehicle:
2010 WRX Sedan
Spark Silver

Default Wiring issues.

Someone please answer this thread. I've looked around and can't find a fix and I am out of warranty.
japakazol is offline   Reply With Quote
Old 12-07-2005, 03:13 AM   #8
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally Posted by Mulder
This is usually caused by a bad combination switch.
yup, 99 times out of 100 it is a faulty combination switch. They definitely aren't marvels of modern science...that's why i keep a spare around just in case.

jeremy
HndaTch627 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Headlight flicker? Subie_Sleeper68 Baja Forum 25 12-19-2010 01:37 AM
Headlights flickering when using turn signals Honest Bob Electrical & Lighting 0 04-05-2009 08:10 PM
Headlights flicker when turn signal is applied Aspenbullet Electrical & Lighting 6 07-16-2007 03:46 AM
headlights flicker with left turn signal EPskate Electrical & Lighting 1 03-26-2007 09:42 PM
My signals make my headlights flicker! squeech Electrical & Lighting 10 05-23-2005 12:23 AM


All times are GMT -4. The time now is 12:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.