Welcome to the North American Subaru Impreza Owners Club Tuesday September 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Miscellaneous > Off-Topic

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-19-2007, 06:55 PM   #1
bigislandracing
Scooby Newbie
 
Member#: 153403
Join Date: Jul 2007
Chapter/Region: HIIC
Location: hawaii
Vehicle:
2004 wrx sti
sti blue

Default chek engine light at high rpm

Since everyone is giving so much info let me ask one more question.The check engine light is triggered on my civic between 7000rpm&8000rpm I've changed the o2 sensor and it was fine for awhile then it started again I don't want to replace the o2 sensor it's like 250 bucks and my money is in my sube right now.My question is it won't hurt the motor by leting it go for a little while right.It still runs fine I just don't like seeing that damn light
* Registered users of the site do not see these ads.

Last edited by bigislandracing; 07-19-2007 at 07:06 PM.
bigislandracing is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-19-2007, 06:55 PM   #2
05wrxmatt
Scooby Specialist
 
Member#: 87169
Join Date: May 2005
Chapter/Region: NESIC
Location: Mooresville, NC
Vehicle:
2007 STI Limited
SWP

Default

Don't drive 100 mph.
05wrxmatt is offline   Reply With Quote
Old 07-19-2007, 06:57 PM   #3
J e r e m y
*** Banned ***
 
Member#: 147770
Join Date: May 2007
Chapter/Region: SWIC
Location: Phoenix, AZ
Default

Quote:
Originally Posted by bigislandracing View Post
Since everyone is giving so much info let me ask one more question.The check engine light is triggered on my civic between 7000rpm&8000rpm around 100mph I've changed the o2 sensor and it was fine for awhile then it started again I don't want to replace the o2 sensor it's like 250 bucks and my money is in my sube right now.My question is it won't hurt the motor by leting it go for a little while right.It still runs fine I just don't like seeing that damn light
Thanks
QFP
This wont end well.
J e r e m y is offline   Reply With Quote
Old 07-19-2007, 06:57 PM   #4
Big Nasty
Scooby Specialist
 
Member#: 4740
Join Date: Mar 2001
Chapter/Region: BAIC
Location: USA/Asia
Vehicle:
2012 FX35
Black

Default

I heard if you drive it up to 150 mph it will go away.
Big Nasty is offline   Reply With Quote
Old 07-19-2007, 06:58 PM   #5
bigislandracing
Scooby Newbie
 
Member#: 153403
Join Date: Jul 2007
Chapter/Region: HIIC
Location: hawaii
Vehicle:
2004 wrx sti
sti blue

Default

rarely do I reach that speed only when I pass or on the mountain road I live on a island where I can reach that speed
bigislandracing is offline   Reply With Quote
Old 07-19-2007, 06:59 PM   #6
Jard
In the silly seat
Moderator
 
Member#: 34935
Join Date: Apr 2003
Chapter/Region: MAIC
Location: Silver Spring, MD
Vehicle:
SPB- 2002 ****ing
WRX again

Default

How is there even enough road in Hawaii to get a Civic up to 100?
Jard is offline   Reply With Quote
Old 07-19-2007, 06:59 PM   #7
Reflex-Arc
Lord of the Gilf
 
Member#: 1703
Join Date: Jun 2000
Chapter/Region: NWIC
Location: I recommended the Sanchez.
Vehicle:
2012 Fiat 500 Sport
Copper

Default

Sudden and abrupt stops are the only know fix for this. Try it.
Reflex-Arc is online now   Reply With Quote
Old 07-19-2007, 06:59 PM   #8
bigislandracing
Scooby Newbie
 
Member#: 153403
Join Date: Jul 2007
Chapter/Region: HIIC
Location: hawaii
Vehicle:
2004 wrx sti
sti blue

Default

ha ha
bigislandracing is offline   Reply With Quote
Old 07-19-2007, 07:00 PM   #9
J e r e m y
*** Banned ***
 
Member#: 147770
Join Date: May 2007
Chapter/Region: SWIC
Location: Phoenix, AZ
Default

Punctuation MUTHA ****A!! DO YOU USE IT?
J e r e m y is offline   Reply With Quote
Old 07-19-2007, 07:04 PM   #10
Star*Child
Scooby Specialist
 
Member#: 5659
Join Date: Apr 2001
Chapter/Region: NWIC
Location: 127.0.0.1
Default

Orchid pollen.

-*
Star*Child is offline   Reply With Quote
Old 07-19-2007, 07:04 PM   #11
Reflex-Arc
Lord of the Gilf
 
Member#: 1703
Join Date: Jun 2000
Chapter/Region: NWIC
Location: I recommended the Sanchez.
Vehicle:
2012 Fiat 500 Sport
Copper

Default

Quote:
Originally Posted by Star*Child View Post
Orchid pollen.

-*
It's a helluva drug.
Reflex-Arc is online now   Reply With Quote
Old 07-19-2007, 07:05 PM   #12
bigislandracing
Scooby Newbie
 
Member#: 153403
Join Date: Jul 2007
Chapter/Region: HIIC
Location: hawaii
Vehicle:
2004 wrx sti
sti blue

Default

what's that
bigislandracing is offline   Reply With Quote
Old 07-19-2007, 07:12 PM   #13
Pyr0
Scooby Newbie
 
Member#: 90552
Join Date: Jul 2005
Chapter/Region: South East
Location: NC
Vehicle:
2005 STi
2008 Bandit 1250S

Default

put a piece of electrical tape over the light. problem solved.
Pyr0 is offline   Reply With Quote
Old 07-19-2007, 07:16 PM   #14
alacrity024
Review Crew
 
Member#: 49476
Join Date: Nov 2003
Chapter/Region: NESIC
Location: Out of the car, long-hair!!
Default

is your car OBDII? take it to autozone (or the aloha-state equivilent) and get the code pulled for free... that's yer first step.
alacrity024 is offline   Reply With Quote
Old 07-19-2007, 07:17 PM   #15
rallyedan
Scooby Newbie
 
Member#: 106631
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: the far right lane
Vehicle:
98 wagon
gringo green

Default

Just use E-85 from now on.
rallyedan is offline   Reply With Quote
Old 07-19-2007, 07:17 PM   #16
BGPunk2001
Scooby Specialist
 
Member#: 46134
Join Date: Oct 2003
Chapter/Region: TXIC
Location: Welcome to Flavor Town
Default

Screw that, you have to get it up to 175 on mountain roads. Thats when it gets fun. retard.
BGPunk2001 is offline   Reply With Quote
Old 07-19-2007, 07:18 PM   #17
Captain TinklePee
Scooby Specialist
 
Member#: 99138
Join Date: Oct 2005
Location: CaptainTinklePeeFartBOOBIES
Vehicle:
1954 Lvl1 Trauma Ctr
Mayor of OT.

Default

"check"

"letting"
Captain TinklePee is online now   Reply With Quote
Old 07-19-2007, 07:18 PM   #18
Mad06STi
Scooby Newbie
 
Member#: 123324
Join Date: Aug 2006
Chapter/Region: MWSOC
Location: Madison, WI
Vehicle:
2006 STi
07 Daytona 675

Default

"cel"
Mad06STi is offline   Reply With Quote
Old 07-19-2007, 07:22 PM   #19
GLwagon
Scooby Specialist
 
Member#: 16696
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Baraboo, WI
Vehicle:
2002 WRX Sedan Stg2
2013 OBW roll'n at 30+mpg

Default

Hmmmm, lights on?
Try the switch on the top of the steering column...
GLwagon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine "stutters" at high rpm and after corners? Help please masterpickle Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 28 09-03-2008 02:57 PM
engine hesitates at high rpm tsukuba speed Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 9 12-24-2007 05:36 AM
2.2l Engine whistle at high RPM boyleia1 Normally Aspirated Powertrain 11 10-24-2007 04:37 PM
Check engine light and cruise blinking at high rpm.. ORACLESTI Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 22 09-25-2006 10:19 PM
Engine sputter at high RPM? kenithzs Normally Aspirated Powertrain 4 06-29-2006 06:40 PM


All times are GMT -4. The time now is 11:16 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.