Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-02-2002, 07:32 PM   #1
minx
Scooby Newbie
 
Member#: 13279
Join Date: Dec 2001
Location: Eastside, WA & www.rs25.com
Vehicle:
1999 Impreza 2.5 RS
Silverthorn Metallic

Default Erratic Idle??

I have been experiencing some strange things lately. While idleing or driving my car will occasionally have a small dump in power. I have watched the RPM gauge and notice little or no change to the level when this 'dump' happens. I have not taken it to the dealer yet cause I wanted to see what I could come up with from ya'll. I have a MY99 2.5RS, no mods. (yet!)

My questions are:

1. What could be causing this?
2. Has anyone else experienced this?
3. I know the dealer would check it out for free under my Powertrain warranty (i think?) But would they fix it for free too?

I searched under several items here but found nothing to assist me.

Thanks!

Brandee
* Registered users of the site do not see these ads.
minx is offline   Reply With Quote
Old 01-02-2002, 08:13 PM   #2
stikboy
Scooby Newbie
 
Member#: 6697
Join Date: May 2001
Chapter/Region: MWSOC
Location: Cowpie, WI
Vehicle:
2011 WRX 5-door
Look-At-Me Red

Default Power loss

If it is still under warranty, have it checked out. It will be an engine problem. Second, it may be a clogged fuel injector, clogged fuel filter or a poor air filter. Dump some cleaner into your tank and check your air filter and fuel filter. Your problem should turn up there.

stikboy:monkey:
stikboy is offline   Reply With Quote
Old 01-02-2002, 08:46 PM   #3
Keith99RS
Scooby Specialist
 
Member#: 9243
Join Date: Aug 2001
Chapter/Region: NESIC
Location: Suffield, CT
Vehicle:
05 Nissan Titan
06 B9 (hers)

Default

My 99 RS started to idle and act a little wierd when my spark plugs were getting really worn. How many miles are on your car? If you are near 30K, the plugs might be the problem. I bought the NGK plugs specified in the owners manual and my car ran better than new! Also check the things in the previous posts. The injector cleaner and a fresh tank of gas couldn't hurt. Hope I was of some help!!
Keith99RS is offline   Reply With Quote
Old 01-02-2002, 10:23 PM   #4
minx
Scooby Newbie
 
Member#: 13279
Join Date: Dec 2001
Location: Eastside, WA & www.rs25.com
Vehicle:
1999 Impreza 2.5 RS
Silverthorn Metallic

Default

Will do! Thanks gang.

I am outside my regular warranty, (powertrain is all I've got) so I think I'll call the dealer and see what they can do. If they act funny I'll go through the things you mentioned.

Hell, I might just take care of it by myself, I love to tinker.

B
minx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Erratic idle @..... idle. SilverBullet2.5RS Normally Aspirated Powertrain 7 06-24-2006 03:07 AM
Erratic Idling GM02WRX Warranty Issues & SOA Problems 4 03-30-2002 01:54 AM
Erratic Idling?....? wrx182 Factory 2.0L Turbo Powertrain 3 10-15-2001 04:00 PM
91 legacy = erratic idle moyama Legacy Forum 2 08-26-2001 12:02 AM
Erratic idle when cold Peaty Normally Aspirated Powertrain 3 05-21-2001 08:41 PM


All times are GMT -4. The time now is 10:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.