Welcome to the North American Subaru Impreza Owners Club Thursday December 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > International Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-27-2008, 05:36 AM   #26
LIUK
*** Banned ***
 
Member#: 154922
Join Date: Jul 2007
Location: Bologna - Italy
Vehicle:
2007 STI
Black

Default

Ciao ragazzi, come state?
Sorry for my absence but I was out of Italy for work. Unfurtunately I had some problem on my STI (07) , the fourth piston! . Now my tuner is changing them with forged. I don't know why I had this problem. The tuner said bad petrol but , sincerely, I don't beleive him. I always used 100 octane petrol. In my opinion the ecutek setting is too hard(?) .

Anyway, we will see with the new pistons. I'am worried that happen again.

Liuk
* Registered users of the site do not see these ads.
LIUK is offline   Reply With Quote
Old 02-27-2008, 05:42 AM   #27
LIUK
*** Banned ***
 
Member#: 154922
Join Date: Jul 2007
Location: Bologna - Italy
Vehicle:
2007 STI
Black

Default

I take the opportunity to put a pic of my car when I went at the Nurburgring in the Aug 07.


Here is in mugello last oct 07 during a track day

LIUK is offline   Reply With Quote
Old 04-24-2008, 01:01 PM   #28
gonzo009
Scooby Specialist
 
Member#: 135372
Join Date: Dec 2006
Chapter/Region: SCIC
Location: SoCal Inland Empire
Vehicle:
2007 Impreza STI
Rally Blue

Default

welcome to the forums
gonzo009 is offline   Reply With Quote
Old 06-16-2008, 09:12 AM   #29
Italiano
Scooby Specialist
 
Member#: 2137
Join Date: Aug 2000
Chapter/Region: NESIC
Location: CT, USA -what am I doing here?
Vehicle:
a 6spd Manual
Acura

Default

Liuk, come vanno le cose~

problema risolto con il motore?
Italiano is offline   Reply With Quote
Old 07-27-2008, 08:15 AM   #30
justchillax808
Scooby Newbie
 
Member#: 177287
Join Date: Apr 2008
Chapter/Region: HIIC
Location: Brugnera, Italy
Vehicle:
2006 STi
steel gray

Default

whats up everyone i new to Italy I live near Aviano My Sti will be here next week just looking for others in the area
justchillax808 is offline   Reply With Quote
Old 05-13-2009, 08:19 AM   #31
ricchiRock
Scooby Newbie
 
Member#: 193119
Join Date: Oct 2008
Location: Italy
Vehicle:
2002 Impreza Sti
Grey Mouse

Default

I'm from Italy too!
ricchiRock is offline   Reply With Quote
Old 06-02-2009, 07:04 AM   #32
Texsar32
Scooby Newbie
 
Member#: 135097
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Hampton, VA (from Texas)
Vehicle:
2007 WRX Limited
UGM

Default

Ciao tutti da Napoli!! Tis my second time here and unfortunately I could not bring my Beast. Would have loved to take her up and down the Amalfi Coast! I have spotted an 04-05 CGM STI with an aftermarket wing around Capodicchino - tis the only Impreza I have encountered!
Texsar32 is offline   Reply With Quote
Old 06-02-2009, 07:08 AM   #33
Texsar32
Scooby Newbie
 
Member#: 135097
Join Date: Dec 2006
Chapter/Region: MAIC
Location: Hampton, VA (from Texas)
Vehicle:
2007 WRX Limited
UGM

Default

Quote:
Originally Posted by LIUK View Post
The tuner said bad petrol but , sincerely, I don't beleive him. I always used 100 octane petrol. In my opinion the ecutek setting is too hard(?) .
Does he specialize in tuning with ecutek?

-Marcus
Texsar32 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hi from Italy GRS3 Newbies & FAQs 30 06-10-2010 12:22 PM
Hi everyone from Italy Snip3rita Newbies & FAQs 3 01-31-2010 02:56 PM
Pics from the Two Guys from Italy Dinner G-force Southern California Impreza Club Forum -- SCIC 22 12-09-2002 07:14 PM
bodyparts WRX from Italy dutch555 Interior & Exterior Modification 20 09-06-2001 05:16 AM
Just got back from Italy! Italiano New England Impreza Club Forum -- NESIC 4 08-31-2001 06:21 PM


All times are GMT -4. The time now is 03:45 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.