Welcome to the North American Subaru Impreza Owners Club Sunday July 13, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Commercial ECU Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-05-2007, 12:01 AM   #1
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default Laptop can't open ROM image to flash

It has been working fine, but made some changes to my map and went to upload it to ECUFlash but then it keeps saying "Can't Open Image File". I can connect and read my current ROM in the car w/o any problems, just cant seem to open new ROMs to flash whats goin on?

And yes i do have the latested version and have tried unstalling/reinstalling and redownloading over and over.

Any one care to help me ?
* Registered users of the site do not see these ads.
o2sys is offline   Reply With Quote
Old 08-05-2007, 11:44 AM   #2
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

It would be easier if you could upload the rom in question somewhere and link to it so we could take a look at it. Or do you get this error message no matter which rom you open, even an unmodified one?
Tea cups is offline   Reply With Quote
Old 08-05-2007, 11:53 AM   #3
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

Yea any roms won't open...even the rom I read from my ecu once I download it I can't reopen it...
o2sys is offline   Reply With Quote
Old 08-05-2007, 12:03 PM   #4
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Just to be clear, your procedure for opening a rom is ecuflash is:
1. Run Ecuflash
2. File -> Open Rom

And what is the exact error message? It would be helpful if you could post the error log (File -> Save Log As). Or does Ecuflash give you a fatal error and quits?
Tea cups is offline   Reply With Quote
Old 08-05-2007, 08:21 PM   #5
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

There is no special error message number or anything. When I go to open rom and click on the rom in my directory folder a message pops up saying "unable to read rom image file" then all I can do is click ok...
o2sys is offline   Reply With Quote
Old 08-05-2007, 09:32 PM   #6
Tea cups
Scooby Specialist
 
Member#: 103136
Join Date: Dec 2005
Default

Even though you said you reinstalled, I would uninstall and then make sure you don't have multiplie installs under different directories and delete all ecuflash shortcuts. Then reinstall.
Tea cups is offline   Reply With Quote
Old 08-06-2007, 01:13 AM   #7
Nuke209
Scooby Specialist
 
Member#: 108089
Join Date: Feb 2006
Chapter/Region: MWSOC
Location: Minnesota
Vehicle:
2003 WRX
NF Performance

Default

get another copy of the same rom
sometimes they get corrupted while downloading them
Nuke209 is offline   Reply With Quote
Old 08-11-2007, 07:37 PM   #8
Hyper
Scooby Guru
 
Member#: 15822
Join Date: Feb 2002
Location: MOCKBA
Vehicle:
1999 WRB GM6
2.12cc V9 Type RA

Default

similar problem
plus I can't even save the rom that I pull out of the ECU
Hyper is offline   Reply With Quote
Old 08-14-2007, 08:25 PM   #9
waktasz
Scooby Guru
 
Member#: 86356
Join Date: May 2005
Chapter/Region: Tri-State
Default

Missing ECU defs?
waktasz is offline   Reply With Quote
Old 08-15-2007, 11:20 AM   #10
o2sys
Scooby Guru
 
Member#: 43842
Join Date: Sep 2003
Chapter/Region: Tri-State
Location: NYC
Vehicle:
200? WRX STI
Aspen White

Default

Quote:
Originally Posted by waktasz View Post
Missing ECU defs?
no it has all the definitions and is rev 1.30
o2sys is offline   Reply With Quote
Old 08-16-2007, 01:13 PM   #11
EdWRX
Scooby Specialist
 
Member#: 108068
Join Date: Feb 2006
Location: Caracas, Venezuela
Vehicle:
05 WRX Enginuity'd
WRB Stg II y00!

Default

Maybe the map is internally changed the Def name in the hex file, might wanna DL tiny hexer and look into it in line 2000 and close to the bottom line is the name of your def, for example, mine is: A4RM200K. Change the name for the map for your ecu accordingly, and check and re-check for defs.

Hope it helps, pm for any trouble.

Most people change the name if their custom maps to avoid some sort of "copying"
EdWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing the Opening Screen Image to Subaru Logo on Eclipse DVD Navi JASWRX Car Audio, Video & Security 11 08-24-2010 06:04 PM
Odd problem on spare laptop with ECUFLASH - Can't open image file Hyper Open Source Reflashes 4 02-03-2010 07:23 AM
Reinstalled WinXP Pro on my laptop, can't get USB ports to work at 2.0 speeds edkwon Off-Topic 8 06-20-2008 10:11 AM
ecuFlash help - Unknown Rom Image eggeegg Commercial ECU Reflashes 1 02-10-2007 07:56 PM
Need help looking for laptop CDRW/DVD ROM driver edkwon Off-Topic 4 12-06-2004 08:15 PM


All times are GMT -4. The time now is 07:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.