Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Alaskan Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Alaskan Impreza Club Forum -- AKIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-06-2007, 01:45 PM   #1
spike589
Scooby Newbie
 
Member#: 122837
Join Date: Aug 2006
Chapter/Region: AKIC
Location: anchorage,alaska
Vehicle:
2008 speed3
red

Unhappy weird overheating issues

I have 04 sti

about a week ago i noticed while seating at a light that my car temp started to rise, I turned on my heater to try to drop the temp but it blew cold air at first then to warm then hot. So i pulled over as soon as i could to see if i blew a hose or a radiator cap, no leak noticed. My overflow reservoir was full to the top, when i got back in the car to see if the temp kept rising but the temp somehow dropped to normal operating temp,i let cool down and popped the radiator cap off to refill with fluid.After that i drove around and then home and i didnt have a problem, almost like a fluck.

the next day i was driving normal and notice the temp come up again and i was on the highway this time , but before i can move over to pull over the temp just dropped back to normal like the gauge was going or somethign. but i pulled over anyways and my reservouir was overserviced again

it just been consistently doing that for the next few days it will rise then drop to normal

I spoke to bunch of subbie owners and they all aggred that the thermostat is the cause of the problem. so i replaced it yesterday burpped the system for 6 minutes at 3500rpm's all bubble are out ( i forgot to mention i tested the old thermostat and it checked good-open properlly and at right temp) took it for a test drive and same thing happen , temp got high then cam back down. got home let cool check oil levels -good- check for milkiness or traces of coolant for blown head gasket-good- psi check both radiator caps -good- ( on radiator and reservoir for turbo) so im up s%^t creek with no answers. Fans do come on but dont know what the duty cycle is or if their coming on properlly or at the right time but they do come on both of them. help!!!!!

thanks for any help in advance
907-350-5783-omar
* Registered users of the site do not see these ads.
spike589 is offline   Reply With Quote
Old 08-06-2007, 02:05 PM   #2
Getagrip
Scooby Specialist
 
Member#: 2045
Join Date: Aug 2000
Chapter/Region: South East
Location: Palm Harbor
Vehicle:
BRZ

Default

Sounds like you checked most obvious things. Maybe a Conti tech could have a look at the vehicle.
Call me for a reservation
Jake 261-0632
Getagrip is offline   Reply With Quote
Old 08-06-2007, 05:39 PM   #3
spike589
Scooby Newbie
 
Member#: 122837
Join Date: Aug 2006
Chapter/Region: AKIC
Location: anchorage,alaska
Vehicle:
2008 speed3
red

Default

how would fan relays make a difference in cooling
spike589 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Overheating Issues... MrWicked Service & Maintenance 1 06-04-2010 12:23 AM
Thermostat / overheating issues Sort of odd issue psychoskip Factory 2.5L Turbo Powertrain 6 12-15-2009 08:18 PM
Weird fueling issue. Not enough fuel, add a pump now insanely rich???A/F weirdness. Defiant Autospeed Factory 2.5L Turbo Powertrain 21 11-19-2007 04:30 AM
weird overheating issue spike589 Service & Maintenance 3 08-08-2007 01:52 AM
weird overheating issue spike589 Factory 2.5L Turbo Powertrain 1 08-06-2007 05:47 PM


All times are GMT -4. The time now is 12:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.