Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-15-2007, 02:37 PM   #1
stant093@
Scooby Newbie
 
Member#: 28830
Join Date: Nov 2002
Chapter/Region: NESIC
Location: N. E. VT
Vehicle:
6807 RIP Colin McRae
97 OBW Limited

Default 94 Legacy Sport Sedan - 4eat Tranny blink codes/Shifting hard

My 1994 Legacy Sport sedan starting shifting poorly yesterday and im wondering if anyone here would know the trouble codes for the automatic transmissions. My "power" light is blinking 14 times when i start off, when stopped at a traffic light the green "power" light is on constantly, when i start to take off, it shuts off. the transmission seems to be shifting very loosely to describe it. It seems to be slipping, but when in gear, goes fine and holds the gear well enough to climb hills and drive normally. also down shifts fine...

Any insight as to how long the tranny might last, or a trouble code readout?

Thanks!
Sam
* Registered users of the site do not see these ads.
stant093@ is offline   Reply With Quote
Old 08-15-2007, 03:27 PM   #2
shemoves
Scooby Guru
 
Member#: 80663
Join Date: Jan 2005
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
1997 Outback

Default

Could be the TCU, but very likely just the tranny on it's way out. PM 'blackbart' and he should be able to get you a good price on a replacement tranny and/or TCU. In fact, might as well just do both.
shemoves is offline   Reply With Quote
Old 08-15-2007, 03:34 PM   #3
stant093@
Scooby Newbie
 
Member#: 28830
Join Date: Nov 2002
Chapter/Region: NESIC
Location: N. E. VT
Vehicle:
6807 RIP Colin McRae
97 OBW Limited

Default

well i actually bought a 97 outback, but it wont be on the road for another 10 days, thats kind of why i was also asking what kind of life it might have left. If she didn't have any rust it would be worth it, but shes too rusty, besides i sold my good ss tranny to BB about two years ago, i really don't want to have to buy it back! If its the TCU, no prob, i have one...
stant093@ is offline   Reply With Quote
Old 08-15-2007, 09:05 PM   #4
Huffer
Scooby Specialist
 
Member#: 36735
Join Date: May 2003
Chapter/Region: MWSOC
Location: Wellington,NZ / Willoughby,OH
Vehicle:
99 GF8 Impreza 2.0
2= 1998 BD + BK Legacy GT

Default

Sounds like the torque converter is giving up the ghost? You could try checking your fluid levels...?
Huffer is offline   Reply With Quote
Old 08-16-2007, 06:46 AM   #5
stant093@
Scooby Newbie
 
Member#: 28830
Join Date: Nov 2002
Chapter/Region: NESIC
Location: N. E. VT
Vehicle:
6807 RIP Colin McRae
97 OBW Limited

Default

Quote:
Originally Posted by Huffer View Post
Sounds like the torque converter is giving up the ghost? You could try checking your fluid levels...?

torque converter would be fine, at least then i know the tranny is still good. And all fluid levels check out perfectly, even though it smells a little burnt. it looks like the outback will be ready a little quicker than i thought after some fancy footwork with the mechanics. So hopefully it'll last until next Tuesday. Thankfully i work only about 3 miles away from home.
stant093@ is offline   Reply With Quote
Old 08-16-2007, 12:29 PM   #6
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

Check the codes in the TCU.

Instructions are on my site. The 14 blinks is a standard blinking.

http://www.surrealmirage.com/subaru/trans.html
Legacy777 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: 94 Legacy Sport Sedan (turbo) buggy18 RMIC Private Classifieds 19 07-24-2009 04:56 PM
WTB: 91-94 Legacy Sport Sedan EsubaruJ RMIC Private Classifieds 12 04-28-2009 10:08 AM
94 Legacy Sport Sedan - 4eat Tranny blink codes/Shifting hard stant093@ Drivetrain 0 08-15-2007 12:47 PM
WTB: 91-94 legacy sport sedan (Portland, OREGON area) shatowz Private 'Wanted' Classifieds 1 03-25-2004 12:42 AM
Looking for 91-94 Legacy Sport Sedan Fernely South East Region Forum 6 12-31-2002 12:01 PM


All times are GMT -4. The time now is 04:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.