Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-17-2007, 09:58 AM   #1
turbobird14
Scooby Newbie
 
Member#: 147780
Join Date: May 2007
Chapter/Region: MWSOC
Location: Monroe, MI
Vehicle:
2002 Bugeye WRX
Flippin Awesome

Default WRX Oil Pressure???

ok... i just got the car and maybe i have the "new car paranoia" but there is an autometer sport comp oil pressure gauge installed and i was wondering what is the oil pressure supposed to be at? at idle and while driving..... the reason for the question is that the needle is bouncing around 25-40 psi at idle while warmed up but right when you start the car its pegged past 100 psi....and when im accelerating its at anywhere beetween 80 psi and past 100psi not boosting at all ( 0 vac boost... between 14.4-15.2 wideband O2) do you think there is something wrong with the gauge.... like a line is pinched or restricted....or what about the oil pressure sending unit?? im starting to freek out a little but i cant think of what would cause high oil pressure.... or if its normal? i dont know so help me out
* Registered users of the site do not see these ads.
turbobird14 is offline   Reply With Quote
Old 08-17-2007, 10:17 AM   #2
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

.....readings will vary depending on the gauge and it's accuracy. However, the pressures you are seeing seem to be in line with what most will see (myself included). The needle will be ~100 PSI at start up and eventually settle to ~25-30 @ idle and ~75-80 @ speed once the engine is fully warm. A search will reveal several threads on the subject......
Kean is offline   Reply With Quote
Old 08-17-2007, 11:58 AM   #3
turbobird14
Scooby Newbie
 
Member#: 147780
Join Date: May 2007
Chapter/Region: MWSOC
Location: Monroe, MI
Vehicle:
2002 Bugeye WRX
Flippin Awesome

Default

hey thanks i noticed today on the way to work on highway it was steady at 80 psi and idle at about 35 psi... just wondering because gauge is maxed out at 100.... like i said i still have paranoia setting in...thanks alot
turbobird14 is offline   Reply With Quote
Old 08-17-2007, 01:14 PM   #4
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

....no problem.
Kean is offline   Reply With Quote
Old 08-17-2007, 02:35 PM   #5
woody06967
Scooby Specialist
 
Member#: 110330
Join Date: Mar 2006
Chapter/Region: Tri-State
Location: Canandaigua, NY
Vehicle:
2007 STI Limited
2012 MDX & Golf TDI

Default

Oil pressure has nothing to do with vacuum/boost, it's driven by engine speed. It should be 90+ cold and drop as it warms up to about 30 at idle. Numbers all look normal.
woody06967 is offline   Reply With Quote
Old 08-17-2007, 04:25 PM   #6
Feign
Scooby Specialist
 
Member#: 68604
Join Date: Aug 2004
Chapter/Region: MWSOC
Location: http://www.indianaimpreza.com
Vehicle:
06 STi
OBP

Default

Yep, you're fine. When they are anywhere other than what you're used to seeing in the future then your paranoia can kick into high gear.
Feign is offline   Reply With Quote
Old 08-18-2007, 12:18 PM   #7
turbobird14
Scooby Newbie
 
Member#: 147780
Join Date: May 2007
Chapter/Region: MWSOC
Location: Monroe, MI
Vehicle:
2002 Bugeye WRX
Flippin Awesome

Default

haha...and if it happens im sure it will
turbobird14 is offline   Reply With Quote
Old 08-30-2007, 12:47 PM   #8
LewisWORX
Scooby Newbie
 
Member#: 63001
Join Date: May 2004
Chapter/Region: MWSOC
Location: Lexington KY
Vehicle:
02 WRX Stg. II PnP
WRB

Default

I see ~75 psi cold, 25psi at warm idle and around 75 psi when warm as rpms build. Is there some reason that I wouldn't see 100 psi when cold?? My oil level is fine. Sender relocated from block plug using a kit. Any ideas? I use Mobil 1 high milage 10w40.
LewisWORX is offline   Reply With Quote
Old 08-30-2007, 10:42 PM   #9
Newbuggy
Scooby Specialist
 
Member#: 152042
Join Date: Jun 2007
Chapter/Region: NWIC
Location: Lynden, WA
Vehicle:
2002 WRX
WRB

Unhappy

i think i may have just finished off my motor i got my car a week ago and i was reading 10 psi at idle 25 psi at cuise and under aceleration. so could these numbers be the reason why my motor may have blew?
Newbuggy is offline   Reply With Quote
Old 08-31-2007, 12:17 AM   #10
MasterKwan
Scooby Guru
 
Member#: 98961
Join Date: Oct 2005
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2003 WRX
Black

Default

Did it have any oil in it? I'd say yes to the question. It probably means the engine was done before you even bought it. Was that the pressure it was running when you bought it? Is so, that should have been a HUGE red flag.
MasterKwan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
02 WRX Oil Pressure Problem. HVAAJA21 Newbies & FAQs 5 12-06-2011 06:13 PM
WTB: Door trigger and wrx oil pressur sensor ImprezaRSfan! Private 'Wanted' Classifieds 0 07-27-2005 10:41 PM
WRX oil pressure? SJwrx Factory 2.0L Turbo Powertrain 26 01-19-2004 05:11 PM
Rs vs wrx oil pressure DJIMPREZA Normally Aspirated with bolt-on Forced Induction Powertrain 7 07-09-2002 02:21 AM


All times are GMT -4. The time now is 07:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.