Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-19-2007, 05:41 PM   #1
untx3
Scooby Newbie
 
Member#: 61035
Join Date: May 2004
Location: Los Angeles, CA
Vehicle:
2004 Subaru WRX STI
Black

Default Disabling Valet Mode. Help!

Hey everyone.

About three months ago, I had my home broken into and all my keys and alarms which happened to be in my safe were stolen.

I went to the dealership and had a key made and bought a factory alarm remote.

Problem is I can't program the alarm. The guys at the dealership said that the alarm will not program because it's in valet mode.

Question is how do you disable the valet mode without a remote?

Can anyone help me out?

I heard theres a phone number for Subaru technical assistance. Anyone know that number?
* Registered users of the site do not see these ads.
untx3 is offline   Reply With Quote
Old 08-19-2007, 11:31 PM   #2
thedaddyb
Scooby Specialist
 
Member#: 64374
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Baltimore, MD
Vehicle:
07 WRX SWP *SOLD
03 2.5ts BRP long gone

Default

i'm not too familiar with the factory alarms, but I'm pretty positive disconnecting the battery for about 20 minutes will reset the unit and more than likely take it out of valet mode for you.

there might be another way, but I'm sure this will work as well.
thedaddyb is offline   Reply With Quote
Old 08-20-2007, 01:21 AM   #3
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

That won't work for aftermarket alarms, and my guess is it won't for the factory alarm either (one reason to have the alarm put into valet mode is to have the shop work on the car, where it's likely they'll disconnect the battery as part of the work. You don't want the alarm arming itself then!).

I think the number is 800 SUBARU3

Since you probably paid a fair amount for that remote and key, I'd have hoped the dealership would at least tell you how to get out of valet mode.
armand1 is offline   Reply With Quote
Old 08-20-2007, 02:02 AM   #4
scooby_Larz
Scooby Newbie
 
Member#: 149383
Join Date: May 2007
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
2002 RS
BRP

Default

Check the owner's manual. There should be an entire section about the factory alarm and keyless entry; at least there is for the MY02.
scooby_Larz is offline   Reply With Quote
Old 08-20-2007, 11:52 AM   #5
untx3
Scooby Newbie
 
Member#: 61035
Join Date: May 2004
Location: Los Angeles, CA
Vehicle:
2004 Subaru WRX STI
Black

Default

yeah, I tried disconnecting the battery. It didn't work.

Armand1. thanks for that number. I'll try it out and see if I can get some help.

As for the owners manual, already tried that, but they only show how to turn off the valet mode if you've already got a remote. Problem is I don't have a remote thats programmed.

Thanks for your help guys.

I'll try your suggestions, but if there are any others please help.

Thanks!
untx3 is offline   Reply With Quote
Old 08-20-2007, 04:45 PM   #6
joecerv
Scooby Specialist
 
Member#: 110459
Join Date: Mar 2006
Location: Somewhere in the DFW area
Vehicle:
2006 Impreza 2.5i
Steel gray metallic

Default

Out of curiosity, are you sure your car is in valet mode ?.
Valet mode or alarm off: alarm light (red dot center dashboard display) rapidly flashing 3 times means the alarm is in "Valet" mode and is not setable.
The light will stop flashing when you start the car.

Is this how you are trying to program the remote ?
- Unlock all doors, foot on brake, all doors closed. Cycle key quickly but carefully on-off appr 10 times until the car honks one time.
Do not turn the key far enough to start the car, just to the 'on' position so the dashboard lights up.
- When the horn honks, open and close the driver's door, press any remote button and that's it.
Program another remote? Quickly open and close the driver's door again and push a button on the 2nd remote. That's it.
- When you're done, remove the key and the horn should honk 3 times. You're all set.
Sometime it takes more than 10 on-offs to set program mode. Open/close the door, lock/unlock etc, wait 10 minutes, then try again.

Taken from:
http://www.cars101.com/subaru/keyless.html#alpine



I hope this helps.
joecerv is offline   Reply With Quote
Old 08-20-2007, 05:00 PM   #7
untx3
Scooby Newbie
 
Member#: 61035
Join Date: May 2004
Location: Los Angeles, CA
Vehicle:
2004 Subaru WRX STI
Black

Default

Quote:
Originally Posted by joecerv View Post
Out of curiosity, are you sure your car is in valet mode ?.
Valet mode or alarm off: alarm light (red dot center dashboard display) rapidly flashing 3 times means the alarm is in "Valet" mode and is not setable.
The light will stop flashing when you start the car.

Is this how you are trying to program the remote ?
- Unlock all doors, foot on brake, all doors closed. Cycle key quickly but carefully on-off appr 10 times until the car honks one time.
Do not turn the key far enough to start the car, just to the 'on' position so the dashboard lights up.
- When the horn honks, open and close the driver's door, press any remote button and that's it.
Program another remote? Quickly open and close the driver's door again and push a button on the 2nd remote. That's it.
- When you're done, remove the key and the horn should honk 3 times. You're all set.
Sometime it takes more than 10 on-offs to set program mode. Open/close the door, lock/unlock etc, wait 10 minutes, then try again.

Taken from:
http://www.cars101.com/subaru/keyless.html#alpine



I hope this helps.

I'm positive it's in valet mode. I think my security light flashes twice, not three times, but yes it is in valet mode.

Also tried to program remote using the insturctions above, minus the foot on the brake. It's possible that may be the missing factor.
I'll have to try it again with the foot on the brake.

However, I was also told that you cannot program the remote while the car is in valet mode. Porblem is I can't get out of valet mode without an existing remote.

I tried calling Subaru, no help there.

Anyone have a service manual that might describe how to exit valet mode without a remote?
untx3 is offline   Reply With Quote
Old 08-21-2007, 02:42 PM   #8
untx3
Scooby Newbie
 
Member#: 61035
Join Date: May 2004
Location: Los Angeles, CA
Vehicle:
2004 Subaru WRX STI
Black

Default

Anyone have a service manual that might describe how to exit valet mode without a remote?
untx3 is offline   Reply With Quote
Old 08-27-2007, 04:57 PM   #9
untx3
Scooby Newbie
 
Member#: 61035
Join Date: May 2004
Location: Los Angeles, CA
Vehicle:
2004 Subaru WRX STI
Black

Default

So I went to two dealerships and they can't figure it out.

What to do at this point? What a burn!!
untx3 is offline   Reply With Quote
Old 02-16-2008, 09:39 PM   #10
liquix
Scooby Newbie
 
Member#: 171986
Join Date: Feb 2008
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2003 Impreza WRX
Sedona Red Pearl

Default

I am dealing with the exact issue as the poster, and have found it impossible to get the car out of valet without a remote. Pretty ridiculous feeling, any help?
liquix is offline   Reply With Quote
Old 02-16-2008, 11:41 PM   #11
liquix
Scooby Newbie
 
Member#: 171986
Join Date: Feb 2008
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2003 Impreza WRX
Sedona Red Pearl

Default

bump, really need help
liquix is offline   Reply With Quote
Old 03-04-2008, 09:18 AM   #12
misterSTi
Scooby Newbie
 
Member#: 173548
Join Date: Mar 2008
Default

doing all the steps that joecerv said, should work. if you turn your key on/off ten times, it puts it on bypass mode. under you steering wheel panel, there should be a switch (there's also one where your windshield meets your engine). press the one under the steering wheel and you will hear you car chirp. this should make it exit valet mode
misterSTi is offline   Reply With Quote
Old 03-04-2008, 10:56 PM   #13
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

It does not matter if your car is in valet mode or not when you try to program a remote.

If the chirp/horn is off, though, you will not know when the programming begins, as it is signaled by the horn beeping once.

Also, make sure you are using the master key, not the valet key. (does it open the glovebox/trunk?)

It can sometimes be tricky to program a remote. For the inexperienced, it may take a few tries:

Try this...

Lock the doors with the switch.

Disconnect the battery for a few minutes, the reconnect

Open the door with the key. If the alarm goes off (or if it goes off when connecting the battery), turn the key in the ignition 3 times fast to shut it off. Remove key from ignition

Get inside and close the door.

Turn key in ignition 10 times within 15 seconds, or until the horn sounds. (sometimes takes 11 or 12 turns)

Open and close the door.

Press one of the buttons on the remote. The horn should sound.

Open and close the door

Repeat (last 2 steps) if you have other remotes.

Remove key from ignition. The horn will sound again.

Test remote.
RexyGirl is offline   Reply With Quote
Old 03-05-2008, 06:15 PM   #14
Harp
Scooby Newbie
 
Member#: 173383
Join Date: Mar 2008
Chapter/Region: MAIC
Location: Virginia
Vehicle:
2008 Impreza
The Dark Grey

Default

Shouldnt they have told you what to do?
Harp is offline   Reply With Quote
Old 03-05-2008, 06:22 PM   #15
lovemylegacy
Scooby Newbie
 
Member#: 84084
Join Date: Mar 2005
Chapter/Region: MWSOC
Location: West Lafayette, IN
Vehicle:
1992 Legacy
Gold

Default

That is REDICULOUS that Subaru won’t help you with this. I would be sending an angry letter. Totally unacceptable. I really like the cars, but that seems like terrible service. Sorry I don’t know how to help. Best of luck…
lovemylegacy is offline   Reply With Quote
Old 03-05-2008, 11:09 PM   #16
lowranger
Scooby Specialist
 
Member#: 124370
Join Date: Aug 2006
Chapter/Region: TXIC
Location: coppell TX. College Station
Vehicle:
03 wrx stg 2.34159
Pro tuned by Cobb Tooning

Default

i did the big 3 the other day and no my lights wont flash and valet mode wont turn off. i tried allt he steps above and now my key fob wont even work. dubya tee effff
lowranger is offline   Reply With Quote
Old 03-05-2008, 11:30 PM   #17
RexyGirl
Scooby Specialist
 
Member#: 63616
Join Date: Jun 2004
Chapter/Region: South East
Location: Mastro Subaru, Sanford FL
Vehicle:
1996 Volvo 850 Turbo
with mods :)

Default

Quote:
Originally Posted by lowranger View Post
i did the big 3 the other day and no my lights wont flash and valet mode wont turn off. i tried allt he steps above and now my key fob wont even work. dubya tee effff
What were you trying to do?

the above steps are for programming a remote, not turning valet on/off

to turn valet on/off, open the drivers side door and press and hold unlock on the remote until the security light on the dash flashes. This will also make the lights work again.

If you tried to program your remote, and it didn't work, you need to do it again...you missed something
RexyGirl is offline   Reply With Quote
Old 03-06-2008, 08:35 AM   #18
martinty
Scooby Newbie
 
Member#: 173437
Join Date: Mar 2008
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2004 WRX wagon
silver

Default Stock alarm

I had an aftermarket alarm/remote start put in and the installer had to place the stock alarm in vallet mode in order to only use the aftermarket remote. otherwise I would have to carry both the stock and aftermarket remotes. Is there another way to set up the aftermarket alarm and not have the stock alarm in vallet mode all the time?
Also has anyone heard of the wiring of the remote start to the ignition causing the car not to rev of 4500 rpms or throwing a cel?
martinty is offline   Reply With Quote
Old 03-06-2008, 10:55 PM   #19
lowranger
Scooby Specialist
 
Member#: 124370
Join Date: Aug 2006
Chapter/Region: TXIC
Location: coppell TX. College Station
Vehicle:
03 wrx stg 2.34159
Pro tuned by Cobb Tooning

Default

hmmm i misread not gonna lie. now i cant even reprogram the remote AHHHhaha
lowranger is offline   Reply With Quote
Old 03-07-2008, 07:25 AM   #20
Sonnyblk
Scooby Newbie
 
Member#: 164505
Join Date: Nov 2007
Chapter/Region: South East
Location: FL
Vehicle:
06 WRX TR
CGM

Default

I have question my car alarm over the past week has been getting quieter when lock or unlock the car with the remote. Now this morning i cant hear it at all. Its still locking the car the lights still flash just there is no sound anymore but the alarm will still go off and you can hear it. Any sugestions on what is causing this and how to fix it.

Last edited by Sonnyblk; 03-07-2008 at 07:51 AM.
Sonnyblk is offline   Reply With Quote
Old 02-17-2012, 08:04 PM   #21
radbeligion
Scooby Newbie
 
Member#: 170816
Join Date: Feb 2008
Chapter/Region: TXIC
Location: Dallas, TX
Vehicle:
2002 WRX-GDA chassis
Midnight Black Pearl-MBP

Default

i lost my remote that came with the car back in 2002 and they've updated it since then and now i can't exit valet mode either. i was able to successfully program the remote, and i can even tell the car to honk every time i lock and unlock the car, but i can't exit valet mode. i know this post isn't helpful, but then again, none of these posts have been. im somewhat convinced its the new style remote, or there's some error in the control module.
radbeligion is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Experiences where immobile or valet mode has helped protect your car? chimchimm5 AccessPort 3 03-26-2009 07:08 PM
you guys get better gas mileage in valet mode? SpeedShift Engine Management & Tuning 5 06-20-2003 10:59 AM
how do i disengage the valet mode?? stache Newbies & FAQs 4 07-01-2002 06:47 PM
make sure its not in valet mode bahboy20 Car Audio, Video & Security 3 08-16-2001 01:46 PM
Security System stuck in Valet Mode??? cincyRS Technical Forum Archive 2 07-21-2000 09:24 AM


All times are GMT -4. The time now is 12:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.