Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-31-2007, 01:15 PM   #1
greysave
Scooby Specialist
 
Member#: 62395
Join Date: May 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2005 STI
Black

Default 04 STI throttle problem

I have a fully built motor, cams, ported heads, reworked crank, pistons, rods, ect. I am using hydra for my ems solution. When I step on the gas pedal nothing happens. I checked the hydra and it is getting 0 feedback. I had Phil check out the ems and it checked out ok. I am running a magnus intake manifold and I have the wiring harness grounds grounded on the intake manifold flange, and I have good voltage. I am running out of ideas here, the car has been down for a long time and I absolutely need it back up, anyone who has any idea please help.
* Registered users of the site do not see these ads.
greysave is offline   Reply With Quote
Old 08-31-2007, 02:55 PM   #2
greysave
Scooby Specialist
 
Member#: 62395
Join Date: May 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2005 STI
Black

Default

t.t.t.
greysave is offline   Reply With Quote
Old 08-31-2007, 09:55 PM   #3
Spec_C
Scooby Newbie
 
Member#: 91423
Join Date: Jul 2005
Chapter/Region: HIIC
Location: Big Island of Hawaii
Vehicle:
2004 PSM STi on Meth
Tuned by Chris Black@AMS

Default

so is it that the car starts up fine, but just has no throttle response?
Spec_C is online now   Reply With Quote
Old 09-01-2007, 03:14 AM   #4
xXSTi-lynXx
Scooby Newbie
 
Member#: 131762
Join Date: Nov 2006
Chapter/Region: International
Location: KC/phoenix back and forth
Vehicle:
2005 STi-"casper"
white on white !

Default

igniton problems???? check coils is my bet.
does it burn oil??
smoke??=
xXSTi-lynXx is offline   Reply With Quote
Old 09-01-2007, 11:20 AM   #5
greysave
Scooby Specialist
 
Member#: 62395
Join Date: May 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2005 STI
Black

Default

Quote:
Originally Posted by Spec_C View Post
so is it that the car starts up fine, but just has no throttle response?
Exactly.


Quote:
Originally Posted by xXSTi-lynXx View Post
igniton problems???? check coils is my bet.
does it burn oil??
smoke??=
No ignition problems, just throttle problems. No throttle response.
greysave is offline   Reply With Quote
Old 09-01-2007, 12:21 PM   #6
MrTransAm
Scooby Newbie
 
Member#: 80744
Join Date: Feb 2005
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2005 Subaru STI
Aspen White

Default

I'm thinking of going to Hydra,.did the car run fine on initial setup or have issues from the start of the Hydra setup? I'm just curious if it could be EM issue.
Also I'm just trying to see if you can pinpoint the start of your problem more.
MrTransAm is offline   Reply With Quote
Old 09-01-2007, 12:35 PM   #7
greysave
Scooby Specialist
 
Member#: 62395
Join Date: May 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2005 STI
Black

Default

The hydra went in at the same exact time that I did my rebuild. I have subsequently sold my stock ecu since then. I could not have used my stock ecu any way, because of my fuel system modifications. It did give throttle feedback before the hydra though before a reputable tuner spun a rod bearing in it on the initial break in, but that was on the stock ecu before these major fuel modifications. I did send the hydra back to phil who said that it ran good on his car. He did mention sending my wiring harness back to hydra, but I haven't been able to get in contact with him on the later half of the week so I guess that will have to wait until tuesday. Is there any chance of a bad tps?

Greg
greysave is offline   Reply With Quote
Old 09-01-2007, 01:07 PM   #8
jays05
Scooby Specialist
 
Member#: 78165
Join Date: Dec 2004
Chapter/Region: South East
Location: SC
Vehicle:
05 STI 35r + e85

Default

Can you measure the voltage right off the TPS?
jays05 is offline   Reply With Quote
Old 09-01-2007, 03:26 PM   #9
greysave
Scooby Specialist
 
Member#: 62395
Join Date: May 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2005 STI
Black

Default

Quote:
Originally Posted by jays05 View Post
Can you measure the voltage right off the TPS?

Thats a good idea, I will try that.
greysave is offline   Reply With Quote
Old 09-11-2007, 10:27 PM   #10
greysave
Scooby Specialist
 
Member#: 62395
Join Date: May 2004
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2005 STI
Black

Default

It was the wiring harness. Damn Finally.
greysave is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Westchester ny 04 sti throttle body & fogt light covers 04aspenwrx Tri-State Area Private Classifieds 6 08-23-2009 11:19 AM
04 sti throttle body F/S in westchester!!! 04aspenwrx Tri-State Area Private Classifieds 0 07-10-2008 06:42 PM
06 STi Motor into and 04 STi, what problems will I run into? stillillmatic7 General Community 1 05-01-2007 07:52 PM
FS: 04 Sti Throttle Body Sap12687 Private 'For Sale' Classifieds 2 05-19-2006 09:16 AM
04 STi throttle body, TGV's, injectors, coils, harness Hondaslayer Private 'For Sale' Classifieds 19 07-30-2005 11:30 AM


All times are GMT -4. The time now is 07:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.