Welcome to the North American Subaru Impreza Owners Club Thursday October 8, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Thread Tools Display Modes
Old 09-01-2007, 03:40 PM   #1
Scooby Newbie
Member#: 158124
Join Date: Sep 2007
Default Legacy Stereo Wiring

Sorry, I'm a noob i didn't know if I should put this in the stereo forum, or not. I took out the HU in my 1998 Legacy GT wagon and I am putting in a cutsom JVC headunit. I couldn't get ahold of a scosche wiring harness or similar so I am wiring myself. I am using JVCs wiring diagram and I have all the doors off so I am hooking the correct speakers up to the correct wires. But I still have like 3 left over pins, what do they go to? Also when I reconnect the negative lead on the battery the turnsignals flash, and when I start the car the headunit just comes on temporarily. I put the stock headunit in, and the turn signals still flash but I did not try to turn it on. I checked all the fuses. Is it because I have the door panels off? I doubt it is the left over wires becuase I plugged the stock wiring harness into the stock HU and they still did it. Thanks, I need help fast, my car is all apart and I am running out of day light.
* Registered users of the site do not see these ads.
NotoriousPMP is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-01-2007, 05:33 PM   #2
Scooby Newbie
Member#: 152710
Join Date: Jun 2007

The lights are flashing because of the security system. There should be a yellow sticker under the hood to tell you how to deactivate it if you don't have the keyless entry transmitters. Two of your left over wires will be for the dash illumination.

White/Green - Illumination
Red/Yellow - RF Speaker
Brown/White - LF Speaker
Blue/Yellow - RR Speaker
White/Red - LR Speaker
Blue/Red - B+ Constant
Yellow/Blue - Illumination
White/Black - RF Speaker
Green - LF Speaker
Yellow - Switched B+
Black - Ground
Red/White - RR Speaker
Red/Black - LR Speaker
Green/Orange - Power Antennae
brandoncrone is offline   Reply With Quote
Old 09-01-2007, 06:20 PM   #3
Scooby Specialist
Member#: 65823
Join Date: Jul 2004
Chapter/Region: NWIC
Location: Hillsboro, OR
1996 Impreza L


man, hacking your stock wires is a bad idea. shoulda just waited till you found a harness... 2day shipping from crutchfield...
spdracr00 is offline   Reply With Quote
Old 09-01-2007, 09:20 PM   #4
Scooby Newbie
Member#: 146513
Join Date: Apr 2007
Chapter/Region: NWIC
Location: Cornelius OR
01 Legacy GT
forest green


Originally Posted by spdracr00 View Post
man, hacking your stock wires is a bad idea. shoulda just waited till you found a harness... 2day shipping from crutchfield...

Only time I ever hacked into the factory wiring on a car was when i was replacing the stock AM radio in a 82 ford truck that I got when I was 15. Since then I have seen how easy it is and will never do that again unless I have to. This keeps my advil bill down.
slapnuts is offline   Reply With Quote
Old 09-01-2007, 10:46 PM   #5
Scooby Guru
Member#: 115154
Join Date: May 2006
Chapter/Region: MWSOC
Location: NYC
2005 Outback XT
White on grey


FWIW, there's an adapter harness someone's selling for like $10 shipped here on the forums as we speak.
rougeben83 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FREE '86 Honda stereo wiring harness scotty305 Southern California Impreza Club Forum -- SCIC 0 01-05-2003 05:50 PM
Factory Stereo Wiring Help!!! ResQDawg3 Car Audio, Video & Security 1 08-12-2002 06:47 PM
stereo wire harness jejiv Car Audio, Video & Security 3 06-02-2002 08:36 PM
Stereo wiring question COBBTUNEDTX Car Audio, Video & Security 6 03-13-2002 10:22 PM
WRX stereo wiring harness WRX Power Car Audio, Video & Security 18 11-12-2001 12:32 PM

All times are GMT -4. The time now is 01:04 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.