Welcome to the North American Subaru Impreza Owners Club Sunday December 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-02-2007, 01:41 PM   #1
Rapid_Roo
Scooby Guru
 
Member#: 31511
Join Date: Jan 2003
Chapter/Region: SCIC
Location: W|LA. Ca.
Vehicle:
03 GD2 95 GM4
www.ITNRally.org

Question How to test HID Ballast or Bulbs?

I recently ran into a problem with HID lights that have been working for the last three years without fail. I had some Brightstar HID retrofits. They had been working fine, but one night the driver's side light went dead and then in the morning the passenger side went dead.

I dug around in my spares box and installed another kit (bulbs and ballasts) from another manufacturer (they look like Philips units), I just hooked them into the existing harness as they had the same connector for power but not for the bulbs.

I was wondering what was the best way to go about testing the dead kit to findo out what was actually broken, the bulbs or the ballasts?

Thank for any help with this,
RR
* Registered users of the site do not see these ads.
Rapid_Roo is offline   Reply With Quote
Old 09-02-2007, 01:59 PM   #2
EdHilario
Scooby Specialist
 
Member#: 137398
Join Date: Jan 2007
Chapter/Region: E. Canada
Location: Toronto
Vehicle:
2004 Impreza 2.5RS
Platinum Silver Metallic

Default

Try the supposedly "dead" bulb in the other headlight and try the working bulb on the "dead" ballast.

If the dead bulb lit up on the working ballast then the other ballast failed. If the working bulb lit up on the supposedly dead ballast then it's the bulb.
EdHilario is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to test HID ballast while off of car? kharris4 Electrical & Lighting 3 03-02-2010 12:19 PM
Trying to find absolute brightest dome light bulb---how to test bulb? lennyTR Electrical & Lighting 54 03-13-2009 03:56 PM
HID light went out: Ballast or Bulb Fatguy1069 Electrical & Lighting 6 12-10-2008 04:04 PM
Any one know how to get HID ballasts apart? Nivekt Electrical & Lighting 2 06-14-2006 12:06 PM
ca f/s sti HID ballast and bulbs 949 Private 'For Sale' Classifieds 10 02-20-2005 03:52 AM


All times are GMT -4. The time now is 01:54 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.