Welcome to the North American Subaru Impreza Owners Club Thursday July 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-02-2007, 05:29 PM   #1
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'02 WRX, '01 YZF-R1
'85 VW Westy- Subie Power

Default Another sunroof problem

I just got an '98 LGT that had one of those sunroof deflector things, but my kayak racks didn't fit on with the deflector, so I took it off. The previous owner had the sunroof unplugged because it wasn't sliding on the track right. I plugged it in, and moved it back about 4" or so to get the deflector off. Got it off no problem, but now the sunroof won't go back up all the way. I got it to move back forward, but it won't go back up to be even with the roof. I tried the motor and I tried the allen wrench to get it back, but it must be off the track or something. Now I can't get it to move much at all. I just want to get it back up even with the roof so it will be watertight. Does anyone know what I might have to do to move it up 1/2" in the back? Thanks in advance...
* Registered users of the site do not see these ads.
WhiteH2O is offline   Reply With Quote
Old 09-02-2007, 06:58 PM   #2
Bakergtt
Scooby Specialist
 
Member#: 59207
Join Date: Apr 2004
Chapter/Region: NWIC
Location: Oregon's OC
Vehicle:
'05 X was 98 LGTT

Default

So its all the way forward just not slid up to mate with the roof? have you tried helping it with a little muscle and using the switch at the same time?
Bakergtt is offline   Reply With Quote
Old 09-02-2007, 07:09 PM   #3
Frogsthatmoo
Scooby Specialist
 
Member#: 153374
Join Date: Jul 2007
Chapter/Region: South East
Location: Ocala, FL
Vehicle:
2001 Outback Wagon
White

Default

Sorry for this not being helpful. But my car did the same thing. I just brought it to the shop and they fixed it in under an hour.
Frogsthatmoo is offline   Reply With Quote
Old 09-02-2007, 08:50 PM   #4
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'02 WRX, '01 YZF-R1
'85 VW Westy- Subie Power

Default

Quote:
Originally Posted by Bakergtt View Post
So its all the way forward just not slid up to mate with the roof? have you tried helping it with a little muscle and using the switch at the same time?
Yes, and yes.

I can see what is supposed to happen when it works. There is a part on the back of the sunroof on the tracks that pushes the rear of it up to mate with the roof, and it doesn't move. I can push it up to where it should be, but it won't stay. If anyplace was open today, I would probably just take it in and see if they could do it really quickly, but everyone is closed for the next few days.
WhiteH2O is offline   Reply With Quote
Old 05-24-2008, 10:44 AM   #5
Christopher UK
Scooby Newbie
 
Member#: 100588
Join Date: Nov 2005
Default

That happened to mine also. That back track ended up getting bend and i had to pull it out. I'm hoping that i can just buy that one piece and not the whole track.
Christopher UK is offline   Reply With Quote
Old 10-13-2008, 06:36 PM   #6
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'02 WRX, '01 YZF-R1
'85 VW Westy- Subie Power

Default

Bump this old thread back up.

I got my sunroof to somewhat stay in place and unplugged the stupid thing and forgot it was there. Lately, it has been opening up a little and making noise. Also, because winter is coming, I don't want it to be leaking. Started messing with it again, and it is worse than it was. Came to see if there is anything helpful on here, and ran into this:

http://www.scoobymods.com/forums/showthread.php?t=3709

Has anyone tried this, and does anyone have an idea how long it takes, how hard it is, and are there any better pictures out there?
WhiteH2O is offline   Reply With Quote
Old 10-14-2008, 08:47 AM   #7
legacy1907
Scooby Specialist
 
Member#: 94024
Join Date: Aug 2005
Chapter/Region: South East
Location: Raleigh, NC
Vehicle:
05 WRX CGM
95 YJ Flat black

Default

i saw that a few years ago and was going to attempt to fix mine, but ended up not doing it. let us know if you do it how well it goes as it would be a great fix for many
legacy1907 is offline   Reply With Quote
Old 10-14-2008, 10:57 AM   #8
Huffer
Scooby Specialist
 
Member#: 36735
Join Date: May 2003
Chapter/Region: MWSOC
Location: Wellington,NZ / Willoughby,OH
Vehicle:
99 GF8 Impreza 2.0
2= 1998 BD + BK Legacy GT

Default

I would do it just to see if it fixes the seal.
All I know is that when my sunroof stops working I'll be removing the entire thing and having a welded plate installed. I hardly ever use it. I could have a lexan window installed too I suppose.

At least removing it I'll be saving about 100lbs in weight.
Huffer is offline   Reply With Quote
Old 10-14-2008, 11:41 AM   #9
WhiteH2O
NASIOC Supporter
 
Member#: 452
Join Date: Oct 1999
Chapter/Region: NWIC
Location: Gig Harbor, WA
Vehicle:
'02 WRX, '01 YZF-R1
'85 VW Westy- Subie Power

Default

I got lazy and ended up with another temp fix yesterday. I cut a metal bar (3/4" by 1/4" by a few feet) and shoved it in under the mechanism that lifts the sunroof so that it holds it in place. Then I shut the opaque cover thingie under it. Good enough for government work.

I am wanting to get my car painted in a year or so, and at that time, I am going to try to do something drastic about it. I like the big weight saving of removing 90% of it, might leave the window, but it won't be able to move afterwards.
WhiteH2O is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help: sunroof problem Gil Legacy Forum 4 07-12-2006 12:43 PM
sunroof problems? kokepelli Forester Forum 5 03-10-2004 04:46 PM
Sunroof problems WRC1 General Community 14 02-05-2004 09:47 PM
Sunroof problems prelude/2.5rs Newbies & FAQs 4 03-28-2002 03:59 PM
('93-'01) Sunroof Problem SubyBean Impreza Forum 2 04-18-2001 08:09 PM


All times are GMT -4. The time now is 04:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.