Welcome to the North American Subaru Impreza Owners Club Sunday August 2, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-05-2007, 04:37 PM   #1
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default Time for a new tranny

Okay, I think the transmission is finally toast on the wagon. Its seeping at the seals, feels as if its slipping in second, and the A/T light is blinking every now and then when I turn the car on.
Anyone with a 2.2 A/T have their transmission replaced?
I know I'll probably have the rear main seal replaced as well while they are back there. I'm bringing it in tomorrow for an estimate, kind of afraid what it is going to total up to though. I can't say it isn't time for a newer one, 218k miles on this one, I figured it was only a matter of time.
* Registered users of the site do not see these ads.
runninstrong is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-07-2007, 01:49 PM   #2
blueb3
Scooby Newbie
 
Member#: 108471
Join Date: Feb 2006
Default

Lemme know how it turns out, I'm kinda in the same boat (except mine doesn't work at all)
blueb3 is offline   Reply With Quote
Old 09-07-2007, 09:14 PM   #3
Blue98leg
Scooby Newbie
 
Member#: 65036
Join Date: Jun 2004
Vehicle:
2013 WRX

Default

hmm 218 you say? Anything else failed yet?
Blue98leg is offline   Reply With Quote
Old 09-08-2007, 12:56 PM   #4
runninstrong
Scooby Specialist
 
Member#: 121474
Join Date: Jul 2006
Chapter/Region: NESIC
Location: Middle East of CT
Vehicle:
1991 SS & 2013 STi
Red & Blue

Default

No, not really. The thermostat went a couple years ago, and front axles needed to be replaced. All in all, just regular maintence for a 13 y/o vehicle. Car still gets 28mpg easily.
runninstrong is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got bored, decided time for a new photo shoot with the new things... sti.2005.blk Alaskan Impreza Club Forum -- AKIC 36 08-31-2007 01:04 AM
Got 4 new parts...so it was time for some new photos. jpsimon Member's Car Gallery 20 05-13-2007 01:07 PM
Need to find part # for Subaru's new tranny fluid MINO Transmission (AT/MT) & Driveline 9 03-19-2004 12:27 PM
tranny ratios/ time for a new rear diff? slowlegacy Transmission (AT/MT) & Driveline 5 10-02-2003 08:45 AM


All times are GMT -4. The time now is 11:34 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.