Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 09-06-2007, 09:42 PM   #1
IDAFC21
Scooby Newbie
 
Member#: 60471
Join Date: Apr 2004
Chapter/Region: SWIC
Location: Avondale, AZ
Vehicle:
2004 GTO
QSM

Default just got my registration renewel

....and i need to be emission tested. noes!
* Registered users of the site do not see these ads.
IDAFC21 is offline   Reply With Quote
Old 09-06-2007, 10:10 PM   #2
enigma94
Scooby Newbie
 
Member#: 143254
Join Date: Mar 2007
Chapter/Region: SWIC
Location: East Mesa
Vehicle:
2007 STi
UGM

Default

Time to try and find a buddy who lives out of the city, or has a cabin up north, thats how I register my civic. No emissions wooohoo!
enigma94 is offline   Reply With Quote
Old 09-06-2007, 10:16 PM   #3
IDAFC21
Scooby Newbie
 
Member#: 60471
Join Date: Apr 2004
Chapter/Region: SWIC
Location: Avondale, AZ
Vehicle:
2004 GTO
QSM

Default

i SHOULD be alright. as long as they just plug in their little scanner...and ignore my exhaust
IDAFC21 is offline   Reply With Quote
Old 09-07-2007, 12:24 AM   #4
shemoves
Scooby Guru
 
Member#: 80663
Join Date: Jan 2005
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
1997 Outback

Default

Subarus get the OBD, visual, and the idle sniff test, but not run on the dyno. Do not let them run the car on the dyno.

If you are catless, you will likely fail the visual, but would prolly still pass the idle sniff (assuming the car isn't modded crazy and is running right).
shemoves is offline   Reply With Quote
Old 09-07-2007, 02:47 AM   #5
enigma94
Scooby Newbie
 
Member#: 143254
Join Date: Mar 2007
Chapter/Region: SWIC
Location: East Mesa
Vehicle:
2007 STi
UGM

Default

hahaha yea, last time i was at the emissions place they tried to dyno a old vw bug with the front wheels on the rollers

They're definately not the brightest bunch of people....
enigma94 is offline   Reply With Quote
Old 09-07-2007, 12:16 PM   #6
borkjam
Scooby Newbie
 
Member#: 56774
Join Date: Mar 2004
Chapter/Region: SWIC
Location: Gilbert, AZ
Vehicle:
2002 WRX Sedan
WRB

Default

I was there with my 02 WRX a couple 2 weeks ago. All they did was plug in the OBD2 and inspect the gas cap. No visual, no popping the hood, nothing.

Makes me glad I didn't bother with swapping out the TBE and ECU.

They didn't even try to put my car on the rollers.
borkjam is offline   Reply With Quote
Old 09-07-2007, 03:24 PM   #7
Silver Ra
Scooby Specialist
 
Member#: 123143
Join Date: Aug 2006
Chapter/Region: SWIC
Location: Chandler ,Az
Vehicle:
03 wrx 08 forester
98civic k24/k20 02 Rsx

Default

i need a homie that i can payoff .!!>!
Silver Ra is offline   Reply With Quote
Old 09-07-2007, 03:40 PM   #8
#522
Scooby Specialist
 
Member#: 2185
Join Date: Aug 2000
Chapter/Region: SWIC
Location: AZ
Vehicle:
01 RS
swirly blue

Default

The visual test varies a lot. Sometimes they look, sometimes they don't.

My Subaru (01RS) just got the gas cap test and OBD2. Technically, if everything is working and your car is meeting emissions standards, your OBD2 should show no CELs and should be in a state of readiness. Even with a high flow, or other exhaust mods.
#522 is offline   Reply With Quote
Old 09-07-2007, 03:48 PM   #9
gringocl
Scooby Newbie
 
Member#: 131728
Join Date: Nov 2006
Chapter/Region: SWIC
Location: Carefree, AZ
Vehicle:
MY02 RA Wagon
White (F.A.T.)

Default

I got mine done 2 months ago, no visual just ODB2 and the gas cap....
gringocl is offline   Reply With Quote
Old 09-07-2007, 05:54 PM   #10
05BluePearlGT
Scooby Newbie
 
Member#: 111760
Join Date: Apr 2006
Chapter/Region: SWIC
Vehicle:
1993 Impreza L
Java Black Pearl

Default

My 93 got the hood popped, mirrors under the car to check for leaks/cats, and idle sniffer. I told them they better not put it on the 2wd emissions dyno thing and they didnt, lol. I passed, even with white smoke from oil dripping onto my exhaust, pouring out of the engine bay. It was all smokey in their work area, haha
05BluePearlGT is offline   Reply With Quote
Old 09-07-2007, 07:26 PM   #11
dozer54321
Scooby Specialist
 
Member#: 116437
Join Date: Jun 2006
Chapter/Region: SWIC
Location: Glendale, AZ
Vehicle:
2002 WRX - MINE
99 SUS - WIFEY

Default

i took my 02 in january for emissions, no visual, again completely catless passed in 5 minutes, including line time
dozer54321 is offline   Reply With Quote
Old 09-07-2007, 08:32 PM   #12
bobturismo
Scooby Specialist
 
Member#: 42145
Join Date: Aug 2003
Location: cruizin' down the street in my
Vehicle:
6-4 jockin da bish-
es and slappin the hoes.

Default

Quote:
Originally Posted by 05BluePearlGT View Post
My 93 got the hood popped, mirrors under the car to check for leaks/cats, and idle sniffer. I told them they better not put it on the 2wd emissions dyno thing and they didnt, lol. I passed, even with white smoke from oil dripping onto my exhaust, pouring out of the engine bay. It was all smokey in their work area, haha
OBD I vehicles still get the sniffer test, OBD II just get a scanner plugged into the port.

OBD II (mandatory in 1996) was designed to "on board diagnose" specifically emission problems. It's the governments way of controlling our cars, as the OBD system would give a check engine light if one of the systems was not working properly. That's why you can have intermittent sensor problems not show up in OBDII, god forbid it actually tells you about something that is hurting your performance. BUT, the instant your car puts out too much emissions, BAM!!, your car powers down.

OBD II does have it's advantages though. You could be running a 1,000 hp spitting flames out the back, but as long as your check engine light is off and the OBD returns no problems, you pass.
bobturismo is offline   Reply With Quote
Old 09-08-2007, 12:08 AM   #13
AaronB
Worst Mod Ever
Moderator
 
Member#: 369
Join Date: Oct 1999
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
12 Vagon

Default

Last time I took my swap through emissions the guy had me pop the hood and about a minute later he finally asked "is this 4 or 6 cylinders?"

He had ZERO clue what he was looking at.
AaronB is offline   Reply With Quote
Old 09-10-2007, 12:05 AM   #14
steverwrx
Scooby Newbie
 
Member#: 24193
Join Date: Sep 2002
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
2002 WRX Sedan
Blue

Default

I just had to get tested this past weekend. I just have the 3rd cat. No visual. They did rev the motor up a few times. Passed. Love OBD2!
steverwrx is offline   Reply With Quote
Old 09-10-2007, 03:57 AM   #15
pajak
Scooby Specialist
 
Member#: 95992
Join Date: Sep 2005
Chapter/Region: SWIC
Location: Mesa
Vehicle:
08 E92 335i
Grey

Default

got mine done 2 months ago put stock exhaust on but they never even looked just gas cap and scanner.
pajak is offline   Reply With Quote
Old 09-10-2007, 10:22 AM   #16
jamesnobrakes
Scooby Newbie
 
Member#: 140999
Join Date: Feb 2007
Chapter/Region: AKIC
Location: AK
Vehicle:
2004 WRX Wagon
White

Default

I wonder if it would help to flash economy or valet mode on the AP?
jamesnobrakes is offline   Reply With Quote
Old 09-10-2007, 10:59 AM   #17
r0bman
Scooby Specialist
 
Member#: 87015
Join Date: May 2005
Location: Mos Eisley, TA 85202
Default

Quote:
Originally Posted by jamesnobrakes View Post
I wonder if it would help to flash economy or valet mode on the AP?
Nah. OBDII will return basically the same results. If you've got an AP map loaded, you're good to go as long as you don't get an ass that does a visual and sees you're missing cats. No check engine light = woot.

At least, that's how it worked in VA...
r0bman is offline   Reply With Quote
Old 09-10-2007, 11:50 AM   #18
racingfish
Scooby Guru
 
Member#: 60976
Join Date: May 2004
Chapter/Region: SWIC
Location: Goodyear
Vehicle:
1969 LGT
FATURBO

Default

Your also allowed 1 ready light.
racingfish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Just got my 06 STi.. Just had my first accident ever. *pics* Drive_STIck General Community 50 06-20-2007 06:35 PM
My credit score finally got better, and I just got my pre-approval letter The Tree Off-Topic 32 05-11-2005 03:35 PM
Just got my Registration Renewal skinart76 Southern California Impreza Club Forum -- SCIC 54 12-04-2003 01:31 AM
Just got my registration renewal notice..... Project Jennifer Southern California Impreza Club Forum -- SCIC 21 10-29-2003 03:48 PM
Just got my VF30, got questions dandbest Factory 2.0L Turbo Powertrain 7 10-02-2002 10:14 PM


All times are GMT -4. The time now is 02:27 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.